summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2013-05-09 18:41:08 +0000
committerAlfredo Tupone <tupone@gentoo.org>2013-05-09 18:41:08 +0000
commit8b0bf83ebe2b944a6e80e2a8fcefe864f09d234b (patch)
treee8338b78c15e0427ff43fc549a26698c967e56d0 /games-misc
parentFix gtk+-3.8 compat (#469062 by Evgeny Bobkin), and fix colors for Gentoo var... (diff)
downloadgentoo-2-8b0bf83ebe2b944a6e80e2a8fcefe864f09d234b.tar.gz
gentoo-2-8b0bf83ebe2b944a6e80e2a8fcefe864f09d234b.tar.bz2
gentoo-2-8b0bf83ebe2b944a6e80e2a8fcefe864f09d234b.zip
Fixing build with gcc-4.8 Bug #465194
(Portage version: 2.1.11.63/cvs/Linux i686, signed Manifest commit with key 0145142D)
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/opengfx/ChangeLog6
-rw-r--r--games-misc/opengfx/files/opengfx-0.4.6.1-gcc48.patch16
-rw-r--r--games-misc/opengfx/opengfx-0.4.6.1.ebuild5
3 files changed, 24 insertions, 3 deletions
diff --git a/games-misc/opengfx/ChangeLog b/games-misc/opengfx/ChangeLog
index d95b7c01f9a2..21a5672b6d61 100644
--- a/games-misc/opengfx/ChangeLog
+++ b/games-misc/opengfx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-misc/opengfx
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/opengfx/ChangeLog,v 1.29 2013/01/15 05:42:39 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-misc/opengfx/ChangeLog,v 1.30 2013/05/09 18:41:08 tupone Exp $
+
+ 09 May 2013; Tupone Alfredo <tupone@gentoo.org> opengfx-0.4.6.1.ebuild,
+ +files/opengfx-0.4.6.1-gcc48.patch:
+ Fixing build with gcc-4.8 Bug #465194
*opengfx-0.4.6.1 (15 Jan 2013)
diff --git a/games-misc/opengfx/files/opengfx-0.4.6.1-gcc48.patch b/games-misc/opengfx/files/opengfx-0.4.6.1-gcc48.patch
new file mode 100644
index 000000000000..78b512e71cec
--- /dev/null
+++ b/games-misc/opengfx/files/opengfx-0.4.6.1-gcc48.patch
@@ -0,0 +1,16 @@
+--- scripts/Makefile.nml.old 2013-05-09 20:09:52.992038666 +0200
++++ scripts/Makefile.nml 2013-05-09 20:10:36.942970903 +0200
+@@ -14,11 +14,11 @@
+
+ %.src.dep: $(SRC_DIR)/%.pnml
+ $(_E) "[DEP] $@"
+- $(_V) $(CC) -C -M -MF $@ -E -MT $(patsubst %.src.dep,%.nml,$@) - < $<
++ $(_V) $(CC) -P -C -M -MF $@ -E -MT $(patsubst %.src.dep,%.nml,$@) - < $<
+
+ %.nml: $(SRC_DIR)/%.pnml $(TAG_FILENAME)
+ $(_E) "[CPP] $@"
+- $(_V) $(CC) -D REPO_REVISION=$(REPO_REVISION) $(CC_FLAGS) $< > $@
++ $(_V) $(CC) -P -D REPO_REVISION=$(REPO_REVISION) $(CC_FLAGS) $< > $@
+
+ %.gfx.dep: %.nml
+ $(_E) "[DEP] $@"
diff --git a/games-misc/opengfx/opengfx-0.4.6.1.ebuild b/games-misc/opengfx/opengfx-0.4.6.1.ebuild
index d75877e9d66c..4c262b598dbb 100644
--- a/games-misc/opengfx/opengfx-0.4.6.1.ebuild
+++ b/games-misc/opengfx/opengfx-0.4.6.1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/opengfx/opengfx-0.4.6.1.ebuild,v 1.1 2013/01/15 05:42:39 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-misc/opengfx/opengfx-0.4.6.1.ebuild,v 1.2 2013/05/09 18:41:08 tupone Exp $
EAPI=5
-inherit games
+inherit eutils games
DESCRIPTION="OpenGFX data files for OpenTTD"
HOMEPAGE="http://bundles.openttdcoop.org/opengfx/"
@@ -28,6 +28,7 @@ src_prepare() {
sed -i \
-e 's:echo "gimp":echo "":g' \
scripts/Makefile.def || die
+ epatch "${FILESDIR}"/${P}-gcc48.patch
}
src_compile() {