summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-07-13 12:59:34 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-07-13 12:59:34 +0000
commitf5604b0d1fa7cb14ec42fe77124489fea30c34fa (patch)
treeee60394e274655d2cffe8423d38e7fca963a3626 /games-misc/gnurobots
parentUse emake rather than make. (diff)
downloadgentoo-2-f5604b0d1fa7cb14ec42fe77124489fea30c34fa.tar.gz
gentoo-2-f5604b0d1fa7cb14ec42fe77124489fea30c34fa.tar.bz2
gentoo-2-f5604b0d1fa7cb14ec42fe77124489fea30c34fa.zip
Fix build with --as-needed Bug #277149
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-misc/gnurobots')
-rw-r--r--games-misc/gnurobots/ChangeLog6
-rw-r--r--games-misc/gnurobots/files/gnurobots-1.2.0-ldflags.patch9
-rw-r--r--games-misc/gnurobots/gnurobots-1.2.0.ebuild9
3 files changed, 20 insertions, 4 deletions
diff --git a/games-misc/gnurobots/ChangeLog b/games-misc/gnurobots/ChangeLog
index 3530643c87aa..d1e667fa8704 100644
--- a/games-misc/gnurobots/ChangeLog
+++ b/games-misc/gnurobots/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-misc/gnurobots
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/gnurobots/ChangeLog,v 1.19 2009/05/22 22:40:31 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-misc/gnurobots/ChangeLog,v 1.20 2009/07/13 12:59:33 tupone Exp $
+
+ 13 Jul 2009; Tupone Alfredo <tupone@gentoo.org>
+ +files/gnurobots-1.2.0-ldflags.patch, gnurobots-1.2.0.ebuild:
+ Fix build with --as-needed Bug #277149 by <flameeyes@gentoo.org>
22 May 2009; Tristan Heaven <nyhm@gentoo.org> gnurobots-1.2.0.ebuild:
Remove -pedantic-errors too, bug #254862
diff --git a/games-misc/gnurobots/files/gnurobots-1.2.0-ldflags.patch b/games-misc/gnurobots/files/gnurobots-1.2.0-ldflags.patch
new file mode 100644
index 000000000000..c2a36b25a285
--- /dev/null
+++ b/games-misc/gnurobots/files/gnurobots-1.2.0-ldflags.patch
@@ -0,0 +1,9 @@
+--- src/Makefile.am.old 2009-07-13 14:10:53.000000000 +0200
++++ src/Makefile.am 2009-07-13 14:11:19.000000000 +0200
+@@ -28,5 +28,5 @@
+
+ gnurobots_SOURCES = main.c api.c map.c grobot.c \
+ ui-window.c ui-cmdwin.c ui-arena.c
+-gnurobots_LDFLAGS = $(GUILE_LDFLAGS) $(READLINE_LIBS) $(GTHREAD2_LIBS) \
++gnurobots_LDADD = $(GUILE_LDFLAGS) $(READLINE_LIBS) $(GTHREAD2_LIBS) \
+ $(GTK2_LIBS) $(VTE_LIBS) -lutil
diff --git a/games-misc/gnurobots/gnurobots-1.2.0.ebuild b/games-misc/gnurobots/gnurobots-1.2.0.ebuild
index 7accc6404816..39b3f8841689 100644
--- a/games-misc/gnurobots/gnurobots-1.2.0.ebuild
+++ b/games-misc/gnurobots/gnurobots-1.2.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/gnurobots/gnurobots-1.2.0.ebuild,v 1.5 2009/05/22 22:40:31 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-misc/gnurobots/gnurobots-1.2.0.ebuild,v 1.6 2009/07/13 12:59:33 tupone Exp $
EAPI=2
-inherit games
+inherit eutils autotools games
DESCRIPTION="construct a program for a little robot then set him loose
and watch him explore a world on his own"
@@ -16,14 +16,17 @@ KEYWORDS="~amd64 ppc x86"
IUSE=""
RESTRICT="test"
-DEPEND="x11-libs/vte
+RDEPEND="x11-libs/vte
dev-scheme/guile"
+DEPEND="${RDEPEND}"
src_prepare() {
+ epatch "${FILESDIR}"/${P}-ldflags.patch
sed -i \
-e 's/-pedantic-errors -Werror//' \
configure \
|| die "sed failed"
+ eautoreconf
}
src_install() {