summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-02-26 06:58:12 +0000
committerMike Frysinger <vapier@gentoo.org>2006-02-26 06:58:12 +0000
commitb0bb03a272933778e418529e2010cb54a6fb023d (patch)
tree787b6c804876052e01056c10fca64f29efc13115 /games-misc/bsd-games
parentstabilize (diff)
downloadgentoo-2-b0bb03a272933778e418529e2010cb54a6fb023d.tar.gz
gentoo-2-b0bb03a272933778e418529e2010cb54a6fb023d.tar.bz2
gentoo-2-b0bb03a272933778e418529e2010cb54a6fb023d.zip
old
Diffstat (limited to 'games-misc/bsd-games')
-rw-r--r--games-misc/bsd-games/bsd-games-2.13-r1.ebuild111
-rw-r--r--games-misc/bsd-games/files/2.13-64bit.patch21
-rw-r--r--games-misc/bsd-games/files/2.13-debian-11.patch324
-rw-r--r--games-misc/bsd-games/files/2.13-gentoo.patch12
-rw-r--r--games-misc/bsd-games/files/bsd-games-2.13-gcc4.patch39
-rw-r--r--games-misc/bsd-games/files/digest-bsd-games-2.13-r11
6 files changed, 0 insertions, 508 deletions
diff --git a/games-misc/bsd-games/bsd-games-2.13-r1.ebuild b/games-misc/bsd-games/bsd-games-2.13-r1.ebuild
deleted file mode 100644
index ee7c307860e4..000000000000
--- a/games-misc/bsd-games/bsd-games-2.13-r1.ebuild
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/bsd-games/bsd-games-2.13-r1.ebuild,v 1.4 2005/08/13 04:04:16 vapier Exp $
-
-inherit eutils games
-
-DESCRIPTION="collection of games from NetBSD"
-HOMEPAGE="http://www.advogato.org/proj/bsd-games/"
-SRC_URI="ftp://metalab.unc.edu/pub/Linux/games/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ppc ~sparc x86"
-IUSE=""
-
-RDEPEND="!games-misc/wtf
- sys-libs/ncurses
- sys-apps/miscfiles
- sys-apps/less
- sys-devel/flex"
-DEPEND="${RDEPEND}
- sys-devel/bison"
-
-# Set GAMES_TO_BUILD variable to whatever you want
-export GAMES_TO_BUILD=${GAMES_TO_BUILD:="adventure arithmetic atc
-backgammon banner battlestar bcd boggle caesar canfield cribbage fish
-gomoku hangman hunt mille monop morse number phantasia pig pom ppt
-primes quiz rain random robots sail snake tetris trek wargames worm
-worms wtf wump"}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PV}-debian-11.patch
- epatch "${FILESDIR}"/${PV}-gentoo.patch
- epatch "${FILESDIR}"/${PV}-64bit.patch
- epatch "${FILESDIR}"/${P}-gcc4.patch
-
- sed -i \
- -e "s:/usr/games:${GAMES_BINDIR}:" \
- wargames/wargames \
- || die "sed wargames failed"
-
- cp "${FILESDIR}"/config.params-gentoo config.params
- echo bsd_games_cfg_build_dirs=\"${GAMES_TO_BUILD}\" >> ./config.params
-}
-
-src_compile() {
- ./configure || die
- emake OPTIMIZE="${CFLAGS}" || die "emake failed"
-}
-
-build_game() { has ${1} ${GAMES_TO_BUILD}; }
-do_statefile() {
- touch ${D}/${GAMES_STATEDIR}/${1}
- chmod ug+rw ${D}/${GAMES_STATEDIR}/${1}
-}
-src_install() {
- dodir ${GAMES_BINDIR} ${GAMES_STATEDIR} /usr/share/man/man{1,6}
- make DESTDIR=${D} install-strip || die "make install-strip failed"
-
- dodoc AUTHORS BUGS ChangeLog ChangeLog.0 \
- README PACKAGING SECURITY THANKS TODO YEAR2000
-
- # special subdirs
- #build_game atc && dodir ${GAMES_DATADIR}/atc
- #build_game boggle && dodir ${GAMES_DATADIR}/boggle
- #build_game quiz && dodir ${GAMES_DATADIR}/quiz
-
- # set some binaries to run as games group (+S)
- build_game atc && fperms g+s ${GAMES_BINDIR}/atc
- build_game battlestar && fperms g+s ${GAMES_BINDIR}/battlestar
- build_game canfield && fperms g+s ${GAMES_BINDIR}/canfield
- build_game cribbage && fperms g+s ${GAMES_BINDIR}/cribbage
- build_game phantasia && fperms g+s ${GAMES_BINDIR}/phantasia
- build_game robots && fperms g+s ${GAMES_BINDIR}/robots
- build_game sail && fperms g+s ${GAMES_BINDIR}/sail
- build_game snake && fperms g+s ${GAMES_BINDIR}/snake
- build_game tetris && fperms g+s ${GAMES_BINDIR}/tetris-bsd
-
- # state files
- build_game atc && do_statefile atc_score
- build_game battlestar && do_statefile battlestar.log
- build_game canfield && do_statefile cfscores
- build_game cribbage && do_statefile criblog
- build_game robots && do_statefile robots_roll
- build_game sail && do_statefile saillog
- build_game snake && do_statefile snake.log && do_statefile snakerawscores
- build_game tetris && do_statefile tetris-bsd.scores
- # state dirs
- #build_game phantasia && dodir ${GAMES_STATEDIR}/phantasia
- #build_game sail && dodir ${GAMES_STATEDIR}/sail
- chmod -R ug+rw ${D}/${GAMES_STATEDIR}/*
-
- # extra docs
- build_game atc && { docinto atc ; dodoc atc/BUGS; }
- build_game boggle && { docinto boggle ; dodoc boggle/README{,.linux}; }
- build_game hunt && { docinto hunt ; dodoc hunt/README{,.linux}; }
- build_game phantasia && { docinto phantasia ; dodoc phantasia/{OWNER,README}; }
- build_game trek && { docinto trek ; dodoc trek/USD.doc/trek.me; }
-
- # Since factor is usually not installed, and primes.6 is a symlink to
- # factor.6, make sure that primes.6 is ok ...
- if build_game primes && [ ! `build_game factor` ] ; then
- rm -f ${D}/usr/share/man/man6/{factor,primes}.6
- newman factor/factor.6 primes.6
- fi
-
- prepalldocs
- prepgamesdirs
-}
diff --git a/games-misc/bsd-games/files/2.13-64bit.patch b/games-misc/bsd-games/files/2.13-64bit.patch
deleted file mode 100644
index 1457c7ef5413..000000000000
--- a/games-misc/bsd-games/files/2.13-64bit.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-David Leverton writes:
-
-The 'adventure' game from the games-misc/bsd-games-2.13 package crashes
-when saving the game on AMD64 (and probably other 64-bit systems, but I
-haven't checked). Find attached to fix this.
-
-http://bugs.gentoo.org/show_bug.cgi?id=77032
-
---- bsd-games-2.13/adventure/crc.c~ 1999-04-04 12:49:03.000000000 +0100
-+++ bsd-games-2.13/adventure/crc.c 2005-01-07 02:42:07.027698064 +0000
-@@ -134,7 +134,8 @@
- if (step >= sizeof(crctab) / sizeof(crctab[0]))
- step = 0;
- }
-- crcval = (crcval << 8) ^ crctab[i];
-+ /* Mask to 32 bits. */
-+ crcval = ((crcval << 8) ^ crctab[i]) & 0xffffffff;
- }
-- return crcval & 0xffffffff; /* Mask to 32 bits. */
-+ return crcval;
- }
diff --git a/games-misc/bsd-games/files/2.13-debian-11.patch b/games-misc/bsd-games/files/2.13-debian-11.patch
deleted file mode 100644
index f40e1ff691d8..000000000000
--- a/games-misc/bsd-games/files/2.13-debian-11.patch
+++ /dev/null
@@ -1,324 +0,0 @@
---- bsdgames-2.13.orig/atc/atc.6.in
-+++ bsdgames-2.13/atc/atc.6.in
-@@ -175,7 +175,7 @@
- to be a command and is therefore not displayed. The following are
- some possible information lines:
- .Pp
--.Bd -literal -unfilled -offset indent
-+.Bd -literal -offset indent
- B4*A0: Circle @ b1
- g7 E4: 225
- .Ed
-@@ -438,7 +438,7 @@
- .Em exactly
- diagonal.
- .Ss "FIELD FILE EXAMPLE"
--.Bd -literal -unfilled
-+.Bd -literal
- # This is the default game.
-
- update = 5;
---- bsdgames-2.13.orig/bcd/bcd.6
-+++ bsdgames-2.13/bcd/bcd.6
-@@ -50,7 +50,7 @@
- .Op Fl ds Ar string ...
- .Sh DESCRIPTION
- The
--.Nm "" ,
-+.Nm bcd ,
- .Nm ppt
- and
- .Nm morse
---- bsdgames-2.13.orig/boggle/boggle/boggle.6
-+++ bsdgames-2.13/boggle/boggle/boggle.6
-@@ -99,7 +99,7 @@
- .El
- .Pp
- Help is available during play by typing
--.Ic Sq ? .
-+.Ic `?' .
- More detailed information on the game is given there.
- .Sh BUGS
- If there are a great many words in the cube the final display of the words
---- bsdgames-2.13.orig/factor/factor.6
-+++ bsdgames-2.13/factor/factor.6
-@@ -1,4 +1,4 @@
--.\" $NetBSD: factor.6,v 1.6 2001/04/02 22:42:38 wiz Exp $
-+.\" $NetBSD: factor.6,v 1.5 1997/10/10 12:51:27 lukem Exp $
- .\"
- .\" Copyright (c) 1989, 1993
- .\" The Regents of the University of California. All rights reserved.
-@@ -42,13 +42,12 @@
- .\" chongo <for a good prime call: 391581 * 2^216193 - 1> /\oo/\
- .\"
- .Dd May 31, 1993
--.Dt FACTOR 6
-+.Dt PRIMES 6
- .Os
- .Sh NAME
--.Nm factor ,
- .Nm primes
- .Nd
--factor a number, generate primes
-+generate primes
- .Sh SYNOPSIS
- .Nm
- .Op Ar number ...
-@@ -57,32 +56,6 @@
- .Op Ar start Op Ar stop
- .Sh DESCRIPTION
- The
--.Nm
--utility will factor integers between -2147483648 and 2147483647 inclusive.
--When a number is factored, it is printed, followed by a
--.Dq \: ,
--and the list of factors on a single line.
--Factors are listed in ascending order, and are preceded by a space.
--If a factor divides a value more than once, it will be printed
--more than once.
--.Pp
--When
--.Nm
--is invoked with one or more arguments,
--each argument will be factored.
--.Pp
--When
--.Nm
--is invoked with no arguments,
--.Nm
--reads numbers, one per line, from standard input, until end of file or error.
--Leading white-space and empty lines are ignored.
--Numbers may be preceded by a single - or +.
--Numbers are terminated by a non-digit character (such as a newline).
--After a number is read, it is factored.
--Input lines must not be longer than 255 characters.
--.Pp
--The
- .Nm primes
- utility prints primes in ascending order, one per line, starting at or above
- .Ar start
-@@ -113,14 +86,6 @@
- .Ar start
- value is terminated by a non-digit character (such as a newline).
- The input line must not be longer than 255 characters.
--.Sh DIAGNOSTICS
--Out of range or invalid input results in
--.Sq ouch
--being written to standard error.
- .Sh BUGS
--.Nm
--cannot handle the
--.Dq 10 most wanted
--factor list,
- .Nm primes
- won't get you a world record.
---- bsdgames-2.13.orig/hangman/extern.c
-+++ bsdgames-2.13/hangman/extern.c
-@@ -61,6 +61,7 @@
- };
-
- int Errors, Wordnum = 0;
-+unsigned int Minlen = MINLEN;
-
- double Average = 0.0;
-
---- bsdgames-2.13.orig/hangman/getword.c
-+++ bsdgames-2.13/hangman/getword.c
-@@ -64,7 +64,7 @@
- if (fgets(Word, BUFSIZ, inf) == NULL)
- continue;
- Word[strlen(Word) - 1] = '\0';
-- if (strlen(Word) < MINLEN)
-+ if (strlen(Word) < Minlen)
- continue;
- for (wp = Word; *wp; wp++)
- if (!islower(*wp))
---- bsdgames-2.13.orig/hangman/hangman.6.in
-+++ bsdgames-2.13/hangman/hangman.6.in
-@@ -42,6 +42,7 @@
- .Sh SYNOPSIS
- .Nm
- .Op Fl d Ar wordlist
-+.Op Fl m Ar minlen
- .Sh DESCRIPTION
- In
- .Nm "" ,
-@@ -55,6 +56,8 @@
- Use the specified
- .Ar wordlist
- instead of the default one named below.
-+.It Fl m
-+Set the minimum word length to use. The default is 6 letters.
- .El
- .Sh FILES
- .Bl -tag -width @hangman_wordsfile@ -compact
---- bsdgames-2.13.orig/hangman/hangman.h
-+++ bsdgames-2.13/hangman/hangman.h
-@@ -73,6 +73,7 @@
- extern const char *const Noose_pict[];
-
- extern int Errors, Wordnum;
-+extern unsigned int Minlen;
-
- extern double Average;
-
---- bsdgames-2.13.orig/hangman/main.c
-+++ bsdgames-2.13/hangman/main.c
-@@ -62,14 +62,21 @@
- /* Revoke setgid privileges */
- setregid(getgid(), getgid());
-
-- while ((ch = getopt(argc, argv, "d:")) != -1) {
-+ while ((ch = getopt(argc, argv, "m:d:")) != -1) {
- switch (ch) {
- case 'd':
- Dict_name = optarg;
- break;
-+ case 'm':
-+ Minlen = atoi(optarg);
-+ if (Minlen < 2) {
-+ fprintf(stderr, "minlen too short\n");
-+ exit(1);
-+ }
-+ break;
- case '?':
- default:
-- (void)fprintf(stderr, "usage: hangman [-d wordlist]\n");
-+ (void)fprintf(stderr, "usage: hangman [-d wordlist] [-m minlen]\n");
- exit(1);
- }
- }
---- bsdgames-2.13.orig/hunt/hunt/hunt.6.in
-+++ bsdgames-2.13/hunt/hunt/hunt.6.in
-@@ -164,13 +164,13 @@
- .It Ic @
- Throw biggest bomb (Takes 441 charges)
- .It Ic o
--Throw small slime (Takes 15 charges)
-+Throw small slime (Takes 5 charges)
- .It Ic O
--Throw big slime (Takes 30 charges)
-+Throw big slime (Takes 10 charges)
- .It Ic p
--Throw bigger slime (Takes 45 charges)
-+Throw bigger slime (Takes 15 charges)
- .It Ic P
--Throw biggest slime (Takes 60 charges)
-+Throw biggest slime (Takes 20 charges)
- .It Ic s
- Scan (show where other players are) (Takes 1 charge)
- .It Ic c
---- bsdgames-2.13.orig/phantasia/Makefrag
-+++ bsdgames-2.13/phantasia/Makefrag
-@@ -41,11 +41,11 @@
- $(INSTALL_SCORE_GAME) phantasia/phantasia $(INSTALL_PREFIX)$(GAMESDIR)/phantasia
- $(HIDE_GAME) phantasia
- (set -e; for f in $(phantasia_VFILES1); do \
-- cp phantasia/$$f $(PHANTASIA_DIR)/$$f; \
-+ cp phantasia/$$f $(INSTALL_PREFIX)$(PHANTASIA_DIR)/$$f; \
- $(INSTALL_SCORE_FILE) $(PHANTASIA_DIR)/$$f; done)
- (set -e; for f in $(phantasia_VFILES2); do \
- if [ ! -e $(PHANTASIA_DIR)/$$f ]; then \
-- cp phantasia/$$f $(PHANTASIA_DIR)/$$f; fi; done; \
-+ cp phantasia/$$f $(INSTALL_PREFIX)$(PHANTASIA_DIR)/$$f; fi; done; \
- $(INSTALL_SCORE_FILE) $(PHANTASIA_DIR)/scoreboard; \
- $(INSTALL_SCORE_FILE) -p $(PHANTASIA_DIR)/characs)
- $(INSTALL_MANUAL) phantasia/phantasia.6
---- bsdgames-2.13.orig/tetris/screen.c
-+++ bsdgames-2.13/tetris/screen.c
-@@ -292,6 +292,8 @@
- newtt = oldtt;
- newtt.c_lflag &= ~(ICANON|ECHO);
- newtt.c_oflag &= ~OXTABS;
-+ newtt.c_cc[VMIN] = 1; /* don't lag behind 3 keystrokes on sun */
-+ newtt.c_cc[VTIME] = 0; /* systems -- JEH */
- if (tcsetattr(0, TCSADRAIN, &newtt) < 0)
- stop("tcsetattr() fails");
- ospeed = cfgetospeed(&newtt);
---- bsdgames-2.13.orig/trek/trek.6.in
-+++ bsdgames-2.13/trek/trek.6.in
-@@ -81,7 +81,7 @@
- .Sh AUTHOR
- Eric Allman
- .Sh SEE ALSO
--.Pa /usr/share/doc/usd/31.trek
-+.Pa /usr/share/doc/bsdgames/trek.me.gz
- .Sh COMMAND SUMMARY
- .Bl -item -compact
- .It
---- bsdgames-2.13.orig/wargames/wargames.6
-+++ bsdgames-2.13/wargames/wargames.6
-@@ -44,6 +44,6 @@
- resulting is much smaller....
- .Sh SEE ALSO
- .Sy Wargames ,
--the movie (an MGM production, PGP 13, directed by John Badham, 1983).
-+the movie (an MGM production, PG 13, directed by John Badham, 1983).
- .Sh AUTHOR
- This manual page was written by Joey Hess <joeyh@kitenet.net>.
---- bsdgames-2.13.orig/AUTHORS
-+++ bsdgames-2.13/AUTHORS
-@@ -8,7 +8,7 @@
- 1997; I divided it into bsd-games and bsd-games-non-free according to
- the established (DFSG/OSD) definition, following the division used for
- the Debian package of 1.3. Much of the packaging has been written or
--extensively modified by myself. Joey Hess <joeyh@master.debian.org>
-+extensively modified by myself. Joey Hess <joeyh@debian.org>
- wrote the manpages for wargames and paranoia.
-
- Based on the source and manpages, here are the details of the people
---- bsdgames-2.13.orig/THANKS
-+++ bsdgames-2.13/THANKS
-@@ -12,7 +12,7 @@
-
- For recent work (since 1.3), thanks to:
-
--Joey Hess <joeyh@master.debian.org>
-+Joey Hess <joeyh@debian.org>
-
- For the Debian patches, which covered what was needed to make the games
- compile with current libraries, provided many bug fixes and showed
---- bsdgames-2.13.orig/config.params
-+++ bsdgames-2.13/config.params
-@@ -0,0 +1,40 @@
-+# This file is read by configure and is used during the build of the
-+# Debian package.
-+
-+# Don't run configure interactively.
-+bsd_games_cfg_non_interactive=y
-+
-+# Install into here for building the package.
-+bsd_games_cfg_install_prefix=`pwd`/debian/bsdgames
-+
-+# Do not build or install these games:
-+bsd_games_cfg_no_build_dirs="dm banner fortune factor"
-+
-+# Keep huntd in /usr/sbin as it was in the past. I may
-+# change this later.
-+bsd_games_cfg_sbindir=/usr/sbin
-+
-+# Debian doesn't like cluttering up the /usr/*/games/ dirs too much,
-+# use a subdir. /var too.
-+bsd_games_cfg_usrlibdir=/usr/lib/games/bsdgames
-+bsd_games_cfg_sharedir=/usr/share/games/bsdgames
-+bsd_games_cfg_varlibdir=/var/games/bsdgames
-+
-+# Do not do chown now, we arn't running as root.
-+bsd_games_cfg_do_chown=n
-+
-+# Debian perfers symlinks for manpages.
-+bsd_games_cfg_use_dot_so=symlinks
-+
-+# I'll handle manpage compressing.
-+bsd_games_cfg_gzip_manpages=n
-+
-+# Policy says to use /usr/bin/pager by default.
-+bsd_games_cfg_pager=/usr/bin/pager
-+
-+# Always use the same wordlist for boggle, and don't use web2, it's too
-+# big. Instead, use the union of the wenglish and wbritish wordlists.
-+bsd_games_cfg_dictionary_src=`pwd`/temp-dictionary
-+
-+# Put it in /usr/share/games with the rest of the games data.
-+bsd_games_cfg_wtf_acronymfile=/usr/share/games/bsdgames/acronyms
-
diff --git a/games-misc/bsd-games/files/2.13-gentoo.patch b/games-misc/bsd-games/files/2.13-gentoo.patch
deleted file mode 100644
index 1993659dd942..000000000000
--- a/games-misc/bsd-games/files/2.13-gentoo.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- bsdgames-2.13.debian/trek/trek.6.in
-+++ bsdgames-2.13/trek/trek.6.in
-@@ -81,7 +81,7 @@
- .Sh AUTHOR
- Eric Allman
- .Sh SEE ALSO
--.Pa /usr/share/doc/bsdgames/trek.me.gz
-+.Pa /usr/share/doc/${PF}/trek.me.gz
- .Sh COMMAND SUMMARY
- .Bl -item -compact
- .It
-
diff --git a/games-misc/bsd-games/files/bsd-games-2.13-gcc4.patch b/games-misc/bsd-games/files/bsd-games-2.13-gcc4.patch
deleted file mode 100644
index f3a762abb758..000000000000
--- a/games-misc/bsd-games/files/bsd-games-2.13-gcc4.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-Patch by Jason Bucata to fix gcc4 issues.
-
-http://bugs.gentoo.org/102311
-
---- trek/getpar.h
-+++ trek/getpar.h
-@@ -35,6 +35,9 @@
- * @(#)getpar.h 8.1 (Berkeley) 5/31/93
- */
-
-+#ifndef __GETPAR_H_
-+#define __GETPAR_H_
-+
- typedef void (*cmdfun) __P((int));
- struct cvntab /* used for getcodpar() paramater list */
- {
-@@ -52,3 +55,6 @@
- int testnl __P((void));
- void skiptonl __P((int));
- int readdelim __P((int));
-+
-+#endif /*__GETPAR_H_*/
-+
---- trek/trek.h
-+++ trek/trek.h
-@@ -35,6 +35,13 @@
- * @(#)trek.h 8.1 (Berkeley) 5/31/93
- */
-
-+/* For struct cvntab definition, which is now required for
-+ * Skitab and Lentab below. gcc 4.0 and later will emit
-+ * "array type has incomplete element type" errors otherwise.
-+ * -- Jason Bucata (jbucata@tulsaconnect.com), 12-AUG-2005
-+ */
-+#include "getpar.h"
-+
- /*
- ** Global Declarations
- **
diff --git a/games-misc/bsd-games/files/digest-bsd-games-2.13-r1 b/games-misc/bsd-games/files/digest-bsd-games-2.13-r1
deleted file mode 100644
index 59e35f1d8822..000000000000
--- a/games-misc/bsd-games/files/digest-bsd-games-2.13-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 cf33f61ce1f0c09a7473ac26a4a0a6ec bsd-games-2.13.tar.gz 2340094