summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-08-15 05:34:43 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-08-15 05:34:43 +0000
commitb765eb200c26cb88ad7c19d50cb3bb6debf91170 (patch)
tree60cb0d210a3d30355f7aea9be48d173ac19703cf /games-misc/bsd-games-non-free/bsd-games-non-free-2.17.ebuild
parentVersion bump. Patched up nice to kill u bug #102002 (diff)
downloadgentoo-2-b765eb200c26cb88ad7c19d50cb3bb6debf91170.tar.gz
gentoo-2-b765eb200c26cb88ad7c19d50cb3bb6debf91170.tar.bz2
gentoo-2-b765eb200c26cb88ad7c19d50cb3bb6debf91170.zip
version bump
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'games-misc/bsd-games-non-free/bsd-games-non-free-2.17.ebuild')
-rw-r--r--games-misc/bsd-games-non-free/bsd-games-non-free-2.17.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/games-misc/bsd-games-non-free/bsd-games-non-free-2.17.ebuild b/games-misc/bsd-games-non-free/bsd-games-non-free-2.17.ebuild
new file mode 100644
index 000000000000..baa0290eadf5
--- /dev/null
+++ b/games-misc/bsd-games-non-free/bsd-games-non-free-2.17.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/bsd-games-non-free/bsd-games-non-free-2.17.ebuild,v 1.1 2005/08/15 05:34:43 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="collection of games from NetBSD"
+HOMEPAGE="http://www.advogato.org/proj/bsd-games/"
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/games/${P}.tar.gz"
+
+# See /usr/share/doc/${P}/CHANGES.rogue
+LICENSE="|| ( BSD free-noncomm )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses
+ sys-apps/miscfiles
+ sys-apps/less
+ sys-devel/bison
+ sys-devel/flex"
+
+# Set GAMES_TO_BUILD variable to whatever you want
+export GAMES_TO_BUILD=${GAMES_TO_BUILD:="rogue"}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ cp "${FILESDIR}"/config.params-gentoo config.params || die "cp failed"
+ echo bsd_games_cfg_build_dirs=\"${GAMES_TO_BUILD}\" >> ./config.params
+}
+
+src_compile() {
+ ./configure || die
+ emake OPTIMIZE="${CFLAGS}" || die "emake failed"
+}
+
+build_game() {
+ has ${1} ${GAMES_TO_BUILD}
+}
+
+do_statefile() {
+ touch "${D}/${GAMES_STATEDIR}/${1}"
+ chmod ug+rw "${D}/${GAMES_STATEDIR}/${1}"
+}
+
+src_install() {
+ dodir ${GAMES_BINDIR} ${GAMES_STATEDIR} /usr/share/man/man{1,6}
+ make DESTDIR="${D}" install || die "make install failed"
+
+ dodoc AUTHORS BUGS ChangeLog ChangeLog.0 NEWS \
+ PACKAGING README README.non-free SECURITY THANKS TODO YEAR2000 \
+ bsd-games-non-free.lsm
+
+ # state files
+ build_game rogue && do_statefile rogue.scores
+
+ # extra docs
+ build_game rogue && { docinto rogue ; dodoc rogue/{CHANGES,USD.doc/rogue.me}; }
+
+ prepalldocs
+ prepgamesdirs
+}