summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2007-05-23 06:08:16 +0000
committerAlfredo Tupone <tupone@gentoo.org>2007-05-23 06:08:16 +0000
commitd6f0aed0c2c89f3840474922d23b4944bf8f2e36 (patch)
tree97cc93c5be1f8070e9eb6bf66a44a3a5a84cf2f1 /games-misc/OilWar/OilWar-1.2.1-r1.ebuild
parentFix broken Manifest for kbfx-0.4.9.3.1-r1.ebuild. (diff)
downloadgentoo-2-d6f0aed0c2c89f3840474922d23b4944bf8f2e36.tar.gz
gentoo-2-d6f0aed0c2c89f3840474922d23b4944bf8f2e36.tar.bz2
gentoo-2-d6f0aed0c2c89f3840474922d23b4944bf8f2e36.zip
Added menu. Bug #159757
(Portage version: 2.1.2.2)
Diffstat (limited to 'games-misc/OilWar/OilWar-1.2.1-r1.ebuild')
-rw-r--r--games-misc/OilWar/OilWar-1.2.1-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/games-misc/OilWar/OilWar-1.2.1-r1.ebuild b/games-misc/OilWar/OilWar-1.2.1-r1.ebuild
new file mode 100644
index 000000000000..d82d456529c6
--- /dev/null
+++ b/games-misc/OilWar/OilWar-1.2.1-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/OilWar/OilWar-1.2.1-r1.ebuild,v 1.1 2007/05/23 06:08:16 tupone Exp $
+
+inherit eutils games
+
+DESCRIPTION="Evil army is attacking your country and tries to steal your oil"
+HOMEPAGE="http://www.2ndpoint.fi/projektit/oilwar.html"
+SRC_URI="http://www.2ndpoint.fi/projektit/filut/${P}.tar.gz
+ ${PN}.png"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/sdl-mixer"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i '/^datafiledir/s:/games/:/:' Makefile.in || die "sed failed"
+}
+
+src_compile() {
+ egamesconf --enable-sound || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ doicon "${DISTDIR}"/${PN}.png
+ make_desktop_entry oilwar ${PN} ${PN}.png
+ prepgamesdirs
+}