summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-01-28 07:47:53 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-01-28 07:47:53 +0000
commitfadc831787c6e269609430fa3c185da5c5f27c7a (patch)
tree306b1eb81199a1f499b246b6251e78ae33b88e8b /games-kids
parentFix path of the patch (diff)
downloadgentoo-2-fadc831787c6e269609430fa3c185da5c5f27c7a.tar.gz
gentoo-2-fadc831787c6e269609430fa3c185da5c5f27c7a.tar.bz2
gentoo-2-fadc831787c6e269609430fa3c185da5c5f27c7a.zip
add upstream patch to fix cursor visibility (bug #353009)
(Portage version: 2.1.9.25/cvs/Linux i686)
Diffstat (limited to 'games-kids')
-rw-r--r--games-kids/gcompris/ChangeLog6
-rw-r--r--games-kids/gcompris/files/gcompris-9.5-cursor.patch42
-rw-r--r--games-kids/gcompris/gcompris-9.5.ebuild6
3 files changed, 51 insertions, 3 deletions
diff --git a/games-kids/gcompris/ChangeLog b/games-kids/gcompris/ChangeLog
index 8d6f96fdc099..1de1db38f183 100644
--- a/games-kids/gcompris/ChangeLog
+++ b/games-kids/gcompris/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-kids/gcompris
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-kids/gcompris/ChangeLog,v 1.58 2011/01/21 06:01:27 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-kids/gcompris/ChangeLog,v 1.59 2011/01/28 07:47:53 mr_bones_ Exp $
+
+ 28 Jan 2011; Michael Sterrett <mr_bones_@gentoo.org> gcompris-9.5.ebuild,
+ +files/gcompris-9.5-cursor.patch:
+ add upstream patch to fix cursor visibility (bug #353009)
21 Jan 2011; Michael Sterrett <mr_bones_@gentoo.org> gcompris-9.5.ebuild:
add media-plugins/gst-plugins-alsa for bug #351116 - tracked down by Peter
diff --git a/games-kids/gcompris/files/gcompris-9.5-cursor.patch b/games-kids/gcompris/files/gcompris-9.5-cursor.patch
new file mode 100644
index 000000000000..c183a9ac2e5d
--- /dev/null
+++ b/games-kids/gcompris/files/gcompris-9.5-cursor.patch
@@ -0,0 +1,42 @@
+From af5058722f44ab548c9ad754fe9d9594369c5ff2 Mon Sep 17 00:00:00 2001
+From: Peter Ujfalusi <peter.ujfalusi@gmail.com>
+Date: Thu, 27 Jan 2011 22:36:55 +0000
+Subject: Fixed invisible cursor on 64 bits systems.
+
+The propoerty struct is now properly initialized even on 64 bits systems.
+---
+diff --git a/src/gcompris/gcompris.c b/src/gcompris/gcompris.c
+index a4e618b..d5053f9 100644
+--- a/src/gcompris/gcompris.c
++++ b/src/gcompris/gcompris.c
+@@ -1541,9 +1541,6 @@ main (int argc, char *argv[])
+ g_option_context_parse (context, &argc, &argv, &error);
+ g_option_context_free(context);
+
+- // Set the default gcompris cursor
+- properties->defaultcursor = GCOMPRIS_DEFAULT_CURSOR;
+-
+ /* Set the default message handler, it avoids message with option -D */
+ g_log_set_handler (NULL, G_LOG_LEVEL_MESSAGE | G_LOG_LEVEL_WARNING | G_LOG_LEVEL_DEBUG | G_LOG_FLAG_FATAL
+ | G_LOG_FLAG_RECURSION, gc_log_handler, NULL);
+diff --git a/src/gcompris/properties.c b/src/gcompris/properties.c
+index 29e43dd..cd36624 100644
+--- a/src/gcompris/properties.c
++++ b/src/gcompris/properties.c
+@@ -143,10 +143,13 @@ gc_prop_new ()
+ {
+ GcomprisProperties *tmp;
+
+- tmp = (GcomprisProperties *) malloc (sizeof (GcomprisProperties));
++ tmp = (GcomprisProperties *) calloc (1, sizeof (GcomprisProperties));
+ tmp->music = 1;
+ tmp->fx = 1;
+ tmp->fullscreen = 1;
++ // Set the default gcompris cursor
++ tmp->defaultcursor = GCOMPRIS_DEFAULT_CURSOR;
++ tmp->nocursor = 0;
+ tmp->timer = 1;
+ tmp->skin = g_strdup("babytoy");
+ tmp->key = g_strdup("default");
+--
+cgit v0.8.3.1
diff --git a/games-kids/gcompris/gcompris-9.5.ebuild b/games-kids/gcompris/gcompris-9.5.ebuild
index f19dd5ea62f3..ee12e55d1381 100644
--- a/games-kids/gcompris/gcompris-9.5.ebuild
+++ b/games-kids/gcompris/gcompris-9.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-kids/gcompris/gcompris-9.5.ebuild,v 1.2 2011/01/21 06:01:27 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-kids/gcompris/gcompris-9.5.ebuild,v 1.3 2011/01/28 07:47:53 mr_bones_ Exp $
EAPI=2
@@ -56,7 +56,9 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}"/${P}-build.patch
+ epatch \
+ "${FILESDIR}"/${P}-build.patch \
+ "${FILESDIR}"/${P}-cursor.patch
cp /usr/share/gettext/config.rpath .
eautoreconf
}