summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-01-20 21:52:13 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-01-20 21:52:13 +0000
commit586d114ef75de16eddbdd06f2bd84a858ecb3432 (patch)
treead805edb0449c678dc921a23fec34d938ed39f83 /games-kids/tuxmath
parentinitial import wrt #453220 (diff)
downloadgentoo-2-586d114ef75de16eddbdd06f2bd84a858ecb3432.tar.gz
gentoo-2-586d114ef75de16eddbdd06f2bd84a858ecb3432.tar.bz2
gentoo-2-586d114ef75de16eddbdd06f2bd84a858ecb3432.zip
version bump wrt #452258
(Portage version: 2.2.0_alpha155/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-kids/tuxmath')
-rw-r--r--games-kids/tuxmath/ChangeLog9
-rw-r--r--games-kids/tuxmath/tuxmath-2.0.1.ebuild71
2 files changed, 78 insertions, 2 deletions
diff --git a/games-kids/tuxmath/ChangeLog b/games-kids/tuxmath/ChangeLog
index 2704897bb2e4..8279a277bd89 100644
--- a/games-kids/tuxmath/ChangeLog
+++ b/games-kids/tuxmath/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-kids/tuxmath
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-kids/tuxmath/ChangeLog,v 1.15 2012/08/06 22:29:18 mr_bones_ Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-kids/tuxmath/ChangeLog,v 1.16 2013/01/20 21:52:13 hasufell Exp $
+
+*tuxmath-2.0.1 (20 Jan 2013)
+
+ 20 Jan 2013; Julian Ospald <hasufell@gentoo.org> +tuxmath-2.0.1.ebuild:
+ version bump wrt #452258
06 Aug 2012; Michael Sterrett <mr_bones_@gentoo.org> tuxmath-1.7.2.ebuild:
any mod support will do
diff --git a/games-kids/tuxmath/tuxmath-2.0.1.ebuild b/games-kids/tuxmath/tuxmath-2.0.1.ebuild
new file mode 100644
index 000000000000..706d2fe8ed2d
--- /dev/null
+++ b/games-kids/tuxmath/tuxmath-2.0.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-kids/tuxmath/tuxmath-2.0.1.ebuild,v 1.1 2013/01/20 21:52:13 hasufell Exp $
+
+EAPI=5
+inherit eutils gnome2-utils games
+
+MY_PN="${PN}_w_fonts"
+DESCRIPTION="Educational arcade game where you have to solve maths problems"
+HOMEPAGE="http://tux4kids.alioth.debian.org/tuxmath/"
+SRC_URI="mirror://sourceforge/tuxmath/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2 OFL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls svg"
+
+RDEPEND="dev-games/t4k-common[svg?]
+ dev-libs/libxml2:2
+ media-libs/libsdl
+ media-libs/sdl-pango
+ media-libs/sdl-image[jpeg,png]
+ media-libs/sdl-mixer[mod]
+ media-libs/sdl-net
+ nls? ( virtual/libintl )
+ svg? (
+ gnome-base/librsvg:2
+ x11-libs/cairo
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_prepare() {
+ sed -i \
+ -e '/\bdoc\b/d' \
+ Makefile.in \
+ || die "sed failed"
+}
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --localedir=/usr/share/locale \
+ $(use_enable nls) \
+ $(usex svg "" "--without-rsvg")
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ doicon -s scalable data/images/icons/${PN}.svg
+ make_desktop_entry ${PN} "TuxMath"
+ dodoc doc/{README,TODO,changelog}
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}