summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-03-25 18:28:01 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-03-25 18:28:01 +0000
commitff227050008784b2df2c572029f7f4d347e492b3 (patch)
treedd35828371559ffb83d96a23211cacdc362c4a70 /games-fps
parentalpha/sparc/x86 stable, add ~ia64 (diff)
downloadgentoo-2-ff227050008784b2df2c572029f7f4d347e492b3.tar.gz
gentoo-2-ff227050008784b2df2c572029f7f4d347e492b3.tar.bz2
gentoo-2-ff227050008784b2df2c572029f7f4d347e492b3.zip
Version bump, thanks to Paul Bredbury and Rémy Dupont, bug #212575
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/alienarena/ChangeLog10
-rw-r--r--games-fps/alienarena/alienarena-20080227.ebuild94
-rw-r--r--games-fps/alienarena/files/alienarena-20080227-include.patch106
3 files changed, 208 insertions, 2 deletions
diff --git a/games-fps/alienarena/ChangeLog b/games-fps/alienarena/ChangeLog
index 22c857e0ac87..b81340c7ce27 100644
--- a/games-fps/alienarena/ChangeLog
+++ b/games-fps/alienarena/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-fps/alienarena
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/alienarena/ChangeLog,v 1.8 2008/01/22 04:46:06 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/alienarena/ChangeLog,v 1.9 2008/03/25 18:28:00 nyhm Exp $
+
+*alienarena-20080227 (25 Mar 2008)
+
+ 25 Mar 2008; Tristan Heaven <nyhm@gentoo.org>
+ +files/alienarena-20080227-include.patch, +alienarena-20080227.ebuild:
+ Version bump, thanks to Paul Bredbury and Rémy Dupont, bug #212575
22 Jan 2008; Tristan Heaven <nyhm@gentoo.org> alienarena-20071011.ebuild:
Fix deps again, bug #206378
@@ -29,7 +35,7 @@
+alienarena-20070613.ebuild:
Version bump
- 07 Mar 2007; Piotr Jaroszyński <peper@gentoo.org>
+ 07 Mar 2007; Piotr Jaroszyński <peper@gentoo.org>
alienarena-20070224-r1.ebuild:
Add ~amd64 wrt bug #169049.
diff --git a/games-fps/alienarena/alienarena-20080227.ebuild b/games-fps/alienarena/alienarena-20080227.ebuild
new file mode 100644
index 000000000000..d3b96fe59970
--- /dev/null
+++ b/games-fps/alienarena/alienarena-20080227.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/alienarena/alienarena-20080227.ebuild,v 1.1 2008/03/25 18:28:00 nyhm Exp $
+
+inherit eutils flag-o-matic toolchain-funcs games
+
+MY_PN=${PN}${PV:0:4}
+DESCRIPTION="Fast-paced multiplayer deathmatch game"
+HOMEPAGE="http://red.planetarena.org/"
+SRC_URI="http://icculus.org/${PN}/Files/${MY_PN}-linux${PV}.zip"
+
+LICENSE="GPL-2 free-noncomm"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dedicated opengl sdl"
+
+UIRDEPEND="media-libs/jpeg
+ virtual/glu
+ virtual/opengl
+ x11-libs/libXxf86dga
+ x11-libs/libXxf86vm
+ sdl? ( media-libs/libsdl )"
+RDEPEND="opengl? ( ${UIRDEPEND} )
+ !opengl? ( !dedicated? ( ${UIRDEPEND} ) )
+ net-misc/curl"
+UIDEPEND="x11-proto/xf86dgaproto
+ x11-proto/xf86vidmodeproto"
+DEPEND="${RDEPEND}
+ opengl? ( ${UIDEPEND} )
+ !opengl? ( !dedicated? ( ${UIDEPEND} ) )
+ app-arch/unzip"
+
+S=${WORKDIR}/${MY_PN}/source
+
+src_unpack() {
+ unpack ${A}
+ cd ${MY_PN}
+ rm -f */*.so cr*
+ mv data1/scripts/maps/tca-titan2k8{\ ,}.rscript
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-include.patch
+}
+
+src_compile() {
+ # To avoid audio crackling (gcc bug)
+ [[ $(gcc-fullversion) == "4.1.1" ]] && replace-flags -O? -O0
+
+ emake \
+ CC="$(tc-getCC)" \
+ OPTIMIZED_CFLAGS=no \
+ PREFIX= \
+ WITH_DATADIR=yes \
+ WITH_LIBDIR=yes \
+ DATADIR="${GAMES_DATADIR}"/${PN} \
+ LIBDIR="$(games_get_libdir)"/${PN} \
+ $(use opengl && use sdl && echo SDLSOUND=yes || echo SDLSOUND=no) \
+ $(use opengl && ! use dedicated && echo BUILD=CLIENT) \
+ $(! use opengl && use dedicated && echo BUILD=DEDICATED) \
+ $(use opengl && use dedicated && echo BUILD=ALL) \
+ $(use opengl || use dedicated || echo BUILD=CLIENT) \
+ || die "emake failed"
+}
+
+src_install() {
+ cd release
+ exeinto "$(games_get_libdir)"/${PN}
+ doexe game.so || die "doexe failed"
+ dosym . "$(games_get_libdir)"/${PN}/arena
+ dosym . "$(games_get_libdir)"/${PN}/data1
+
+ if use opengl || ! use dedicated ; then
+ newgamesbin crx ${PN}-oss || die "newgamesbin crx failed"
+ make_desktop_entry ${PN}-oss "Alien Arena (OSS audio)"
+ use sdl || dosym ${PN}-oss "${GAMES_BINDIR}"/${PN}
+ fi
+
+ if use opengl && use sdl ; then
+ newgamesbin crx.sdl ${PN}-sdl || die "newgamesbin crx.sdl failed"
+ make_desktop_entry ${PN}-sdl "Alien Arena (SDL audio)"
+ dosym ${PN}-sdl "${GAMES_BINDIR}"/${PN}
+ fi
+
+ if use dedicated ; then
+ newgamesbin crded ${PN}-ded || die "newgamesbin crded failed"
+ fi
+
+ cd "${WORKDIR}/${MY_PN}"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r arena botinfo data1 || die "doins failed"
+ newicon aa.png ${PN}.png || die "newicon failed"
+ dodoc docs/README.txt
+
+ prepgamesdirs
+}
diff --git a/games-fps/alienarena/files/alienarena-20080227-include.patch b/games-fps/alienarena/files/alienarena-20080227-include.patch
new file mode 100644
index 000000000000..4fa51dd08752
--- /dev/null
+++ b/games-fps/alienarena/files/alienarena-20080227-include.patch
@@ -0,0 +1,106 @@
+Index: unix/net_udp.c
+===================================================================
+--- unix/net_udp.c (revision 877)
++++ unix/net_udp.c (working copy)
+@@ -26,6 +26,7 @@
+ #include <sys/time.h>
+ #include <netinet/in.h>
+ #include <netdb.h>
++#include <arpa/inet.h>
+ #include <sys/param.h>
+ #include <sys/ioctl.h>
+ #include <sys/uio.h>
+Index: unix/q_shunix.c
+===================================================================
+--- unix/q_shunix.c (revision 877)
++++ unix/q_shunix.c (working copy)
+@@ -152,13 +152,6 @@
+ mkdir (path, 0777);
+ }
+
+-char *strlwr (char *s)
+-{
+- while (*s) {
+- *s = tolower(*s);
+- s++;
+- }
+-}
+
+ //============================================
+
+Index: game/q_shared.h
+===================================================================
+--- game/q_shared.h (revision 877)
++++ game/q_shared.h (working copy)
+@@ -39,6 +39,7 @@
+ #include <string.h>
+ #include <stdlib.h>
+ #include <time.h>
++#include <ctype.h>
+
+ #if (defined _M_IX86 || defined __i386__) && !defined C_ONLY && !defined __sun__
+ #define id386 1
+@@ -253,6 +254,8 @@
+ int Q_strnicmp (const char *string1, const char *string2, int n);
+ //=============================================
+
++char *Q_strlwr(char *s);
++
+ short BigShort(short l);
+ short LittleShort(short l);
+ int BigLong (int l);
+Index: qcommon/files.c
+===================================================================
+--- qcommon/files.c (revision 877)
++++ qcommon/files.c (working copy)
+@@ -19,6 +19,7 @@
+ */
+
+ #include "qcommon.h"
++#include "../unix/glob.h"
+
+ // define this to dissalow any data but the demo pak file
+ //#define NO_ADDONS
+Index: client/menu.c
+===================================================================
+--- client/menu.c (revision 877)
++++ client/menu.c (working copy)
+@@ -24,6 +24,7 @@
+
+ #ifdef __unix__
+ #include <sys/time.h>
++#include <unistd.h>
+ #endif
+
+ #ifdef _WIN32
+Index: ref_gl/r_main.c
+===================================================================
+--- ref_gl/r_main.c (revision 877)
++++ ref_gl/r_main.c (working copy)
+@@ -1659,10 +1659,10 @@
+ Com_Printf ("GL_EXTENSIONS: %s\n", gl_config.extensions_string );
+
+ strcpy( renderer_buffer, gl_config.renderer_string );
+- strlwr( renderer_buffer );
++ Q_strlwr( renderer_buffer );
+
+ strcpy( vendor_buffer, gl_config.vendor_string );
+- strlwr( vendor_buffer );
++ Q_strlwr( vendor_buffer );
+
+ if ( strstr( renderer_buffer, "voodoo" ) )
+ {
+Index: ref_gl/r_script.h
+===================================================================
+--- ref_gl/r_script.h (revision 877)
++++ ref_gl/r_script.h (working copy)
+@@ -160,9 +160,7 @@
+ void RS_FreeUnmarked(void);
+ rscript_t *RS_FindScript(char *name);
+ void RS_ReadyScript(rscript_t *rs);
+-#ifdef _WINDOWS
+ void RS_ScanPathForScripts(void);
+-#endif
+ int RS_Animate(rs_stage_t *stage);
+ void RS_UpdateRegistration(void);
+ void RS_DrawSurface (msurface_t *surf, qboolean lightmap);