summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-07-22 13:10:50 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-07-22 13:10:50 +0000
commitfda16c7c374ebfe3c092daa0185fadcaab97951b (patch)
tree0ac73283e8764f0a01dba3c890998146581f223f /games-fps
parentNew package for glossaries (or list of acronyms). (diff)
downloadgentoo-2-fda16c7c374ebfe3c092daa0185fadcaab97951b.tar.gz
gentoo-2-fda16c7c374ebfe3c092daa0185fadcaab97951b.tar.bz2
gentoo-2-fda16c7c374ebfe3c092daa0185fadcaab97951b.zip
Add demo USE flag, bug #178443
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/rott/ChangeLog6
-rw-r--r--games-fps/rott/files/rott-1.0-full-version.patch11
-rw-r--r--games-fps/rott/rott-1.0.ebuild29
3 files changed, 33 insertions, 13 deletions
diff --git a/games-fps/rott/ChangeLog b/games-fps/rott/ChangeLog
index 2fd4f0b1629f..e3770e292bcb 100644
--- a/games-fps/rott/ChangeLog
+++ b/games-fps/rott/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-fps/rott
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/rott/ChangeLog,v 1.7 2007/03/12 15:08:23 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/rott/ChangeLog,v 1.8 2007/07/22 13:10:50 nyhm Exp $
+
+ 22 Jul 2007; Tristan Heaven <nyhm@gentoo.org>
+ +files/rott-1.0-full-version.patch, rott-1.0.ebuild:
+ Add demo USE flag, bug #178443
12 Mar 2007; Marius Mauch <genone@gentoo.org> rott-1.0.ebuild:
Replacing einfo with elog
diff --git a/games-fps/rott/files/rott-1.0-full-version.patch b/games-fps/rott/files/rott-1.0-full-version.patch
new file mode 100644
index 000000000000..e1615e77f7fa
--- /dev/null
+++ b/games-fps/rott/files/rott-1.0-full-version.patch
@@ -0,0 +1,11 @@
+--- develop.h.orig 2007-05-13 22:42:39.000000000 +0200
++++ develop.h 2007-05-13 22:42:44.000000000 +0200
+@@ -40,7 +40,7 @@
+ #define LOWCOST 0
+
+ // Make sure only one of the following are on at one time
+-#define SHAREWARE 1
++#define SHAREWARE 0
+ #define SUPERROTT 0
+ #define SITELICENSE 0
+
diff --git a/games-fps/rott/rott-1.0.ebuild b/games-fps/rott/rott-1.0.ebuild
index 184070098613..265b8440629a 100644
--- a/games-fps/rott/rott-1.0.ebuild
+++ b/games-fps/rott/rott-1.0.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/rott/rott-1.0.ebuild,v 1.9 2007/03/12 15:08:23 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/rott/rott-1.0.ebuild,v 1.10 2007/07/22 13:10:49 nyhm Exp $
inherit eutils games
DESCRIPTION="Rise of the Triad for Linux!"
HOMEPAGE="http://www.icculus.org/rott/"
SRC_URI="http://www.icculus.org/rott/releases/${P}.tar.gz
- http://filesingularity.timedoctor.org/swdata.zip"
+ demo? ( http://filesingularity.timedoctor.org/swdata.zip )"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~ppc x86"
-IUSE=""
+IUSE="demo"
RDEPEND="media-libs/libsdl
media-libs/sdl-mixer"
@@ -24,12 +24,14 @@ S=${WORKDIR}/${P}/rott
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/${PV}-custom-datapath.patch \
- "${FILESDIR}/${P}"-gcc41.patch
+ epatch \
+ "${FILESDIR}"/${PV}-custom-datapath.patch \
+ "${FILESDIR}"/${P}-gcc41.patch
+ use demo || epatch "${FILESDIR}"/${P}-full-version.patch
}
src_compile() {
- make clean || die
+ emake clean || die
emake -j1 EXTRACFLAGS="${CFLAGS} -DDATADIR=\\\"${GAMES_DATADIR}/${PN}/\\\"" \
|| die "emake failed"
}
@@ -37,15 +39,18 @@ src_compile() {
src_install() {
dogamesbin rott || die "dogamesbin failed"
dodoc *.txt ../{README,readme.txt}
- cd "${WORKDIR}"
- insinto "${GAMES_DATADIR}"/${PN}
- doins *.dmo huntbgin.* remote1.rts || die "doins failed"
+ if use demo ; then
+ cd "${WORKDIR}"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins *.dmo huntbgin.* remote1.rts || die "doins failed"
+ fi
prepgamesdirs
}
pkg_postinst() {
games_pkg_postinst
- elog "The shareware version has been installed."
- elog "To play the full version, just copy the"
- elog "data files to ${GAMES_DATADIR}/${PN}/"
+ if ! use demo ; then
+ elog "To play the full version, just copy the"
+ elog "data files to ${GAMES_DATADIR}/${PN}/"
+ fi
}