summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-10-15 11:42:52 +0000
committerPacho Ramos <pacho@gentoo.org>2014-10-15 11:42:52 +0000
commitfc74c63e0d847cb3d14f8d3f171172777de70baa (patch)
treea6c73f1dc1fb60352fc737193313b6fbfb523cfc /games-fps
parentAdd dev-db/etcd. (diff)
downloadgentoo-2-fc74c63e0d847cb3d14f8d3f171172777de70baa.tar.gz
gentoo-2-fc74c63e0d847cb3d14f8d3f171172777de70baa.tar.bz2
gentoo-2-fc74c63e0d847cb3d14f8d3f171172777de70baa.zip
Support multilib providers for deps. Bump to EAPI=5.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/unreal-tournament-goty/ChangeLog6
-rw-r--r--games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild29
-rw-r--r--games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild39
3 files changed, 49 insertions, 25 deletions
diff --git a/games-fps/unreal-tournament-goty/ChangeLog b/games-fps/unreal-tournament-goty/ChangeLog
index 9dc035d305d4..e2144548bb4f 100644
--- a/games-fps/unreal-tournament-goty/ChangeLog
+++ b/games-fps/unreal-tournament-goty/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-fps/unreal-tournament-goty
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/ChangeLog,v 1.16 2014/05/01 13:58:53 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/ChangeLog,v 1.17 2014/10/15 11:42:52 pacho Exp $
+
+ 15 Oct 2014; Pacho Ramos <pacho@gentoo.org> unreal-tournament-goty-436.ebuild,
+ unreal-tournament-goty-451.ebuild:
+ Support multilib providers for deps. Bump to EAPI=5.
01 May 2014; Ulrich Müller <ulm@gentoo.org>
unreal-tournament-goty-436.ebuild, unreal-tournament-goty-451.ebuild:
diff --git a/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild b/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild
index 299873ab9a64..42131767ffef 100644
--- a/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild
+++ b/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild,v 1.16 2014/05/01 13:58:53 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild,v 1.17 2014/10/15 11:42:52 pacho Exp $
+
+EAPI=5
inherit eutils unpacker cdrom games
@@ -16,12 +18,23 @@ IUSE="3dfx S3TC nls opengl"
RESTRICT="mirror bindist"
DEPEND="!games-fps/unreal-tournament
- app-arch/unzip"
-RDEPEND="opengl? ( virtual/opengl )
- x11-libs/libXext
- x11-libs/libX11
- x11-libs/libXau
- x11-libs/libXdmcp"
+ app-arch/unzip
+"
+RDEPEND="
+ || (
+ (
+ opengl? ( virtual/opengl[abi_x86_32(-)] )
+ x11-libs/libXext[abi_x86_32(-)]
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXau[abi_x86_32(-)]
+ x11-libs/libXdmcp[abi_x86_32(-)]
+ )
+ amd64? (
+ opengl? ( app-emulation/emul-linux-x86-opengl[-abi_x86_32(-)] )
+ app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)]
+ )
+ )
+"
S=${WORKDIR}
@@ -49,7 +62,7 @@ src_install() {
# the most important things, ucc & ut :)
exeinto "${dir}"
doexe bin/x86/{ucc,ut} || die "install ucc/ut"
- dosed "s:\`FindPath \$0\`:${dir}:" "${dir}"/ucc
+ sed -i -e "s:\`FindPath \$0\`:${dir}:" "${ED}/${dir}"/ucc || die
# export some symlinks so ppl can run
dodir "${GAMES_BINDIR}"
diff --git a/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild b/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild
index e920c0bcb970..00cf615c7b5b 100644
--- a/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild
+++ b/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild,v 1.19 2014/05/01 13:58:53 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild,v 1.20 2014/10/15 11:42:52 pacho Exp $
+
+EAPI=5
inherit eutils unpacker cdrom games
@@ -15,19 +17,24 @@ KEYWORDS="~amd64 x86"
IUSE="3dfx S3TC nls opengl"
RESTRICT="mirror bindist"
-RDEPEND="!amd64? (
- x11-libs/libXext
- x11-libs/libX11
- x11-libs/libXau
- x11-libs/libXdmcp
- =media-libs/libsdl-1.2*
- opengl? ( virtual/opengl ) )
- amd64? ( app-emulation/emul-linux-x86-sdl
- app-emulation/emul-linux-x86-baselibs
- app-emulation/emul-linux-x86-xlibs )"
-DEPEND="${RDEPEND}
- !games-fps/unreal-tournament
- app-arch/unzip"
+RDEPEND="
+ || (
+ (
+ opengl? ( virtual/opengl[abi_x86_32(-)] )
+ >=media-libs/libsdl-1.2.15-r5[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXau[abi_x86_32(-)]
+ x11-libs/libXdmcp[abi_x86_32(-)]
+ )
+ amd64? (
+ opengl? ( app-emulation/emul-linux-x86-opengl[-abi_x86_32(-)] )
+ app-emulation/emul-linux-x86-sdl[-abi_x86_32(-)]
+ app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)]
+ )
+ )
+"
+DEPEND=""
S=${WORKDIR}
@@ -57,7 +64,7 @@ src_install() {
# the most important things, ucc & ut :)
exeinto "${dir}"
doexe bin/x86/{ucc,ut} || die "install ucc/ut"
- dosed "s:\`FindPath \$0\`:${dir}:" "${dir}"/ucc
+ sed -i -e "s:\`FindPath \$0\`:${dir}:" "${ED}/${dir}"/ucc || die
# export some symlinks so ppl can run
dodir "${GAMES_BINDIR}"
@@ -148,7 +155,7 @@ src_install() {
# finally, unleash the UTPG patch
cp -rf UTPG/* "${Ddir}"/ || die "cp failed"
# fix a small bug until next official release
- dosed "/^LoadClassMismatch/s:%s.%s:%s:" "${dir}"/System/Core.int
+ sed -i -e "/^LoadClassMismatch/s:%s.%s:%s:" "${ED}/${dir}"/System/Core.int
# install a few random files
insinto "${dir}"