summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-11-05 22:43:44 +0000
committerMike Frysinger <vapier@gentoo.org>2005-11-05 22:43:44 +0000
commitda19b70b861e467407d9ce2b65e3601f57bd5a01 (patch)
treec1856c6e2c248cf334bc97fe10751bf25208185a /games-fps
parentquake-data -> quake1 #111622 (diff)
downloadgentoo-2-da19b70b861e467407d9ce2b65e3601f57bd5a01.tar.gz
gentoo-2-da19b70b861e467407d9ce2b65e3601f57bd5a01.tar.bz2
gentoo-2-da19b70b861e467407d9ce2b65e3601f57bd5a01.zip
quake-data -> quake1 #111622
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/quake1-movies/quake1-movies-0.ebuild21
-rw-r--r--games-fps/quake1-rally/quake1-rally-1.2.ebuild11
-rw-r--r--games-fps/quake1-teamfortress/quake1-teamfortress-2.9.ebuild8
-rw-r--r--games-fps/quake1-textures/quake1-textures-20040716.ebuild4
4 files changed, 18 insertions, 26 deletions
diff --git a/games-fps/quake1-movies/quake1-movies-0.ebuild b/games-fps/quake1-movies/quake1-movies-0.ebuild
index 8f41caf902df..2108bc42093b 100644
--- a/games-fps/quake1-movies/quake1-movies-0.ebuild
+++ b/games-fps/quake1-movies/quake1-movies-0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake1-movies/quake1-movies-0.ebuild,v 1.3 2005/09/26 18:05:31 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake1-movies/quake1-movies-0.ebuild,v 1.4 2005/11/05 22:40:11 vapier Exp $
inherit eutils games
@@ -14,8 +14,7 @@ SRC_URI="http://ftp.se.kde.org/pub/pc/games/idgames2/planetquake/cineplex/camper
http://ftp.se.kde.org/pub/pc/games/idgames2/planetquake/cineplex/op_bays.zip
http://ftp.se.kde.org/pub/pc/games/idgames2/planetquake/cineplex/artifact.zip
http://ftp.se.kde.org/pub/pc/games/idgames2/planetquake/blah/blahmov.zip
- http://ftp.se.kde.org/pub/pc/games/idgames2/planetquake/blah/blahouts.zip
- "
+ http://ftp.se.kde.org/pub/pc/games/idgames2/planetquake/blah/blahouts.zip"
LICENSE="as-is"
SLOT="0"
@@ -33,14 +32,14 @@ myunpack() {
}
src_unpack() {
- cd ${S}
+ cd "${S}"
einfo "Diary of a Camper ..."
mkdir id1
cd id1
myunpack camper.zip
mv movies.txt movies-camper.txt
- cd ${S}
+ cd "${S}"
einfo "Ranger Gone Bad ..."
cd id1
myunpack rgb.zip
@@ -54,33 +53,31 @@ src_unpack() {
cd ta2
myunpack ta2.zip
- cd ${S}
+ cd "${S}"
einfo "Operation Bayshield ..."
mkdir op_bays
cd op_bays
myunpack op_bays.zip
- cd ${S}
+ cd "${S}"
einfo "The Artifact ..."
mkdir artifact
cd artifact
myunpack artifact.zip
- cd ${S}
+ cd "${S}"
einfo "Blahbalicious ..."
myunpack blahmov.zip
rm *.bat
cd blah
myunpack blahouts.zip
- cd ${S}
+ cd "${S}"
edos2unix $(find . -name '*.txt' -o -name '*.cfg')
}
src_install() {
- local dir=${GAMES_DATADIR}/quake-data
- dodir "${dir}"
- insinto "${dir}"
+ insinto "${GAMES_DATADIR}/quake-data"
doins -r * || die "doins"
prepgamesdirs
}
diff --git a/games-fps/quake1-rally/quake1-rally-1.2.ebuild b/games-fps/quake1-rally/quake1-rally-1.2.ebuild
index 946b4dfe8a49..00a878eb0432 100644
--- a/games-fps/quake1-rally/quake1-rally-1.2.ebuild
+++ b/games-fps/quake1-rally/quake1-rally-1.2.ebuild
@@ -1,13 +1,12 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake1-rally/quake1-rally-1.2.ebuild,v 1.3 2005/09/26 18:01:07 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake1-rally/quake1-rally-1.2.ebuild,v 1.4 2005/11/05 22:41:28 vapier Exp $
-inherit eutils games
+inherit games
DESCRIPTION="TC which turns Quake into a Rally racing game"
HOMEPAGE="http://www.quakerally.com/"
-SRC_URI="
- mirror://gentoo/qr12.zip
+SRC_URI="mirror://gentoo/qr12.zip
mirror://gentoo/qrlo1.zip"
LICENSE="as-is"
@@ -32,9 +31,7 @@ src_unpack() {
}
src_install() {
- local dir=${GAMES_DATADIR}/quake-data
- dodir "${dir}"
- insinto "${dir}"
+ insinto "${GAMES_DATADIR}/quake1"
doins -r * || die "doins"
prepgamesdirs
}
diff --git a/games-fps/quake1-teamfortress/quake1-teamfortress-2.9.ebuild b/games-fps/quake1-teamfortress/quake1-teamfortress-2.9.ebuild
index 4c98d3f3f008..9258e17fc9b9 100644
--- a/games-fps/quake1-teamfortress/quake1-teamfortress-2.9.ebuild
+++ b/games-fps/quake1-teamfortress/quake1-teamfortress-2.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake1-teamfortress/quake1-teamfortress-2.9.ebuild,v 1.2 2005/09/26 18:11:39 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake1-teamfortress/quake1-teamfortress-2.9.ebuild,v 1.3 2005/11/05 22:42:43 vapier Exp $
inherit eutils games
@@ -31,9 +31,7 @@ src_unpack() {
}
src_install() {
- local dir=${GAMES_DATADIR}/quake-data
- dodir "${dir}"
- insinto "${dir}"
- doins -r *
+ insinto "${GAMES_DATADIR}/quake1"
+ doins -r * || die
prepgamesdirs
}
diff --git a/games-fps/quake1-textures/quake1-textures-20040716.ebuild b/games-fps/quake1-textures/quake1-textures-20040716.ebuild
index 76fd7e65e522..cd437041eb68 100644
--- a/games-fps/quake1-textures/quake1-textures-20040716.ebuild
+++ b/games-fps/quake1-textures/quake1-textures-20040716.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake1-textures/quake1-textures-20040716.ebuild,v 1.3 2004/12/10 21:41:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake1-textures/quake1-textures-20040716.ebuild,v 1.4 2005/11/05 22:43:44 vapier Exp $
inherit games
@@ -20,7 +20,7 @@ S=${WORKDIR}
src_install () {
dodoc *.txt
rm *.txt
- insinto ${GAMES_DATADIR}/quake-data/id1/textures
+ insinto "${GAMES_DATADIR}"/quake1/id1/textures
doins * || die "doins failed"
prepgamesdirs
}