summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-01-22 02:53:36 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-01-22 02:53:36 +0000
commitc54d81e90e20554a8a2f47a46e7333a6ef29a064 (patch)
treead4c7435a6a8f26ee4748365e3946d353d8fe159 /games-fps
parentStable on x86 for bug #119634; Stabilize Gnome-2.12.2 (diff)
downloadgentoo-2-c54d81e90e20554a8a2f47a46e7333a6ef29a064.tar.gz
gentoo-2-c54d81e90e20554a8a2f47a46e7333a6ef29a064.tar.bz2
gentoo-2-c54d81e90e20554a8a2f47a46e7333a6ef29a064.zip
support dedicated use flag more (bug #119874)
(Portage version: 2.0.53)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/quake3/ChangeLog6
-rw-r--r--games-fps/quake3/quake3-1.33_alpha510.ebuild18
2 files changed, 15 insertions, 9 deletions
diff --git a/games-fps/quake3/ChangeLog b/games-fps/quake3/ChangeLog
index 4ee2f1a1069b..3395f60f6d0f 100644
--- a/games-fps/quake3/ChangeLog
+++ b/games-fps/quake3/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-fps/quake3
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/ChangeLog,v 1.29 2006/01/20 01:20:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/ChangeLog,v 1.30 2006/01/22 02:53:36 mr_bones_ Exp $
+
+ 22 Jan 2006; Michael Sterrett <mr_bones_@gentoo.org>
+ quake3-1.33_alpha510.ebuild:
+ support dedicated use flag more (bug #119874)
*quake3-1.33_alpha510 (20 Jan 2006)
diff --git a/games-fps/quake3/quake3-1.33_alpha510.ebuild b/games-fps/quake3/quake3-1.33_alpha510.ebuild
index 7d8caffd542b..ef82aff9871c 100644
--- a/games-fps/quake3/quake3-1.33_alpha510.ebuild
+++ b/games-fps/quake3/quake3-1.33_alpha510.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/quake3-1.33_alpha510.ebuild,v 1.1 2006/01/20 01:20:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/quake3-1.33_alpha510.ebuild,v 1.2 2006/01/22 02:53:36 mr_bones_ Exp $
# quake3-9999 -> latest svn
# quake3-9999.REV -> use svn REV
@@ -8,7 +8,7 @@
# quake3-VER -> normal quake release
if [[ ${PV} == 9999* ]] ; then
- [[ ${PV} == 9999.* ]] && ESVN_UPDATE_CMD="svn up -r ${PV/9999.}"
+ [[ ${PV} == 9999.* ]] && ESVN_UPDATE_CMD="svn up -r ${PV/9999./}"
ESVN_REPO_URI="svn://svn.icculus.org/quake3/trunk"
inherit subversion games toolchain-funcs
@@ -17,8 +17,8 @@ if [[ ${PV} == 9999* ]] ; then
elif [[ ${PV} == *_alpha* ]] ; then
inherit games toolchain-funcs
- MY_PV=${PV/_alpha*}
- SNAP=${PV/*_alpha}
+ MY_PV=${PV/_alpha*/}
+ SNAP=${PV/*_alpha/}
MY_P=${PN}-${MY_PV}_SVN${SNAP}M
SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
S=${WORKDIR}/${MY_P}
@@ -86,14 +86,16 @@ src_install() {
cd code/unix
dodoc README.*
- doicon quake3.xpm
- make_desktop_entry quake3 "Quake III Arena" quake3.xpm
+ if use opengl ; then
+ doicon quake3.xpm
+ make_desktop_entry quake3 "Quake III Arena" quake3.xpm
+ fi
cd ../../build/release*
local old_x x
- for old_x in ioquake3* ; do
+ for old_x in ioq* ; do
x=${old_x%.*}
- newgamesbin ${old_x} ${x} || die "dobin ${x}"
+ newgamesbin ${old_x} ${x} || die "newgamesbin ${x}"
dosym ${x} "${GAMES_BINDIR}"/${x/io}
done
exeinto "${GAMES_LIBDIR}"/${PN}/baseq3