summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2005-02-23 00:36:17 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2005-02-23 00:36:17 +0000
commitc54c847ee989ed70cefb984d7f972eb40e40413b (patch)
treeb156d55389cd6e6566b8f8681a023184e6a20e03 /games-fps
parentInitial import of new broken-up ut2004 install. (diff)
downloadgentoo-2-c54c847ee989ed70cefb984d7f972eb40e40413b.tar.gz
gentoo-2-c54c847ee989ed70cefb984d7f972eb40e40413b.tar.bz2
gentoo-2-c54c847ee989ed70cefb984d7f972eb40e40413b.zip
Initial import of broken-up ut2004 install and version bumped to 3355.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/ut2004/ChangeLog7
-rw-r--r--games-fps/ut2004/files/digest-ut2004-33551
-rw-r--r--games-fps/ut2004/ut2004-3355.ebuild111
3 files changed, 118 insertions, 1 deletions
diff --git a/games-fps/ut2004/ChangeLog b/games-fps/ut2004/ChangeLog
index 92149b771f96..d10caaf216fc 100644
--- a/games-fps/ut2004/ChangeLog
+++ b/games-fps/ut2004/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-fps/ut2004
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004/ChangeLog,v 1.21 2005/01/18 22:24:04 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004/ChangeLog,v 1.22 2005/02/23 00:36:17 wolf31o2 Exp $
+
+*ut2004-3355 (22 Feb 2005)
+
+ 22 Feb 2005; Chris Gianelloni <wolf31o2@gentoo.org> +ut2004-3355.ebuild:
+ Initial import of broken-up ut2004 install and version bumped to 3355.
18 Jan 2005; Chris Gianelloni <wolf31o2@gentoo.org> ut2004-3339.ebuild:
Added ROOT to dosym.
diff --git a/games-fps/ut2004/files/digest-ut2004-3355 b/games-fps/ut2004/files/digest-ut2004-3355
new file mode 100644
index 000000000000..00276a0f7f5f
--- /dev/null
+++ b/games-fps/ut2004/files/digest-ut2004-3355
@@ -0,0 +1 @@
+MD5 379198183e16cefeb585a1c3252e63dd ut2004-lnxpatch3355.tar.bz2 20655315
diff --git a/games-fps/ut2004/ut2004-3355.ebuild b/games-fps/ut2004/ut2004-3355.ebuild
new file mode 100644
index 000000000000..35e2681f2897
--- /dev/null
+++ b/games-fps/ut2004/ut2004-3355.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004/ut2004-3355.ebuild,v 1.1 2005/02/23 00:36:17 wolf31o2 Exp $
+
+inherit games
+
+MY_P="${PN}-lnxpatch${PV}.tar.bz2"
+DESCRIPTION="Unreal Tournament 2004 - Editor's Choice Edition"
+HOMEPAGE="http://www.unrealtournament2004.com/"
+SRC_URI="mirror://3dgamers/pub/3dgamers/games/unrealtourn2k4/${MY_P}
+ http://speculum.twistedgamer.com/pub/0day.icculus.org/${PN}/${MY_P}"
+
+LICENSE="ut2003"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+RESTRICT="nostrip nomirror"
+IUSE="opengl dedicated"
+
+RDEPEND="games-fps/ut2004-data
+ games-fps/ut2004-bonuspack-ece
+ opengl? ( virtual/opengl )
+ dedicated? ( app-misc/screen )"
+
+S=${WORKDIR}/UT2004-Patch
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+
+pkg_setup() {
+ check_license || die "License check failed"
+
+ games_pkg_setup
+}
+
+src_install() {
+ # Installing patch files
+ for p in {Animations,Help,Speech,System,Textures,Web}
+ do
+ dodir ${dir}/${p}
+ cp -r ${S}/${p}/* ${Ddir}/${p} \
+ || die "copying ${p} from patch"
+ done
+
+ use amd64 && rm ${Ddir}/System/u{cc,t2004}-bin \
+ && mv ${Ddir}/System/ucc-bin-linux-amd64 ${Ddir}/System/ucc-bin \
+ && mv ${Ddir}/System/ut2004-bin-linux-amd64 ${Ddir}/System/ut2004-bin \
+ && chmod ug+x ${Ddir}/System/ucc-bin ${Ddir}/System/ut2004-bin
+ use x86 && rm ${Ddir}/System/ucc-bin-linux-amd64 \
+ ${Ddir}/System/ut2004-bin-linux-amd64
+
+ # creating .manifest files
+ insinto ${dir}/.manifest
+ doins ${FILESDIR}/${PN}.xml
+
+ # creating .loki/installed links
+ mkdir -p ${D}/root/.loki/installed
+ dosym ${dir}/.manifest/${PN}.xml ${ROOT}/root/.loki/installed/${PN}.xml
+
+ games_make_wrapper ut2004 ./ut2004 ${dir}
+
+ prepgamesdirs
+ make_desktop_entry ut2004 "Unreal Tournament 2004" ut2004.xpm
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ # here is where we check for the existence of a cdkey...
+ # if we don't find one, we ask the user for it
+ if [ -f ${dir}/System/cdkey ]; then
+ einfo "A cdkey file is already present in ${dir}/System"
+ else
+ ewarn "You MUST run this before playing the game:"
+ ewarn "ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config"
+ ewarn "That way you can [re]enter your cdkey."
+ fi
+ echo
+ einfo "To play the game run:"
+ einfo " ut2004"
+ echo
+}
+
+pkg_postrm() {
+ ewarn "This package leaves a cdkey file in ${dir}/System that you need"
+ ewarn "to remove to completely get rid of this game's files."
+}
+
+pkg_config() {
+ ewarn "Your CD key is NOT checked for validity here."
+ ewarn " Make sure you type it in correctly."
+ eerror "If you CTRL+C out of this, the game will not run!"
+ echo
+ einfo "CD key format is: XXXXX-XXXXX-XXXXX-XXXXX"
+ while true ; do
+ einfo "Please enter your CD key:"
+ read CDKEY1
+ einfo "Please re-enter your CD key:"
+ read CDKEY2
+ if [ "$CDKEY1" == "" ] ; then
+ echo "You entered a blank CD key. Try again."
+ else
+ if [ "$CDKEY1" == "$CDKEY2" ] ; then
+ echo "$CDKEY1" | tr a-z A-Z > ${dir}/System/cdkey
+ einfo "Thank you!"
+ break
+ else
+ eerror "Your CD key entries do not match. Try again."
+ fi
+ fi
+ done
+}