summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-09-16 18:16:22 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-09-16 18:16:22 +0000
commitc17daec74a85682c4c79cc6c0b64881858aa0573 (patch)
tree96a6a1b64fd94682c4fcebfa39688113668cb99e /games-fps
parentadded new ExtPatch-64 version; fix for bug 237583 (diff)
downloadgentoo-2-c17daec74a85682c4c79cc6c0b64881858aa0573.tar.gz
gentoo-2-c17daec74a85682c4c79cc6c0b64881858aa0573.tar.bz2
gentoo-2-c17daec74a85682c4c79cc6c0b64881858aa0573.zip
old
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/tremulous/tremulous-1.1.0-r1.ebuild95
1 files changed, 0 insertions, 95 deletions
diff --git a/games-fps/tremulous/tremulous-1.1.0-r1.ebuild b/games-fps/tremulous/tremulous-1.1.0-r1.ebuild
deleted file mode 100644
index 35ddefbe5ac3..000000000000
--- a/games-fps/tremulous/tremulous-1.1.0-r1.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/tremulous/tremulous-1.1.0-r1.ebuild,v 1.3 2008/02/29 19:22:46 carlo Exp $
-
-inherit eutils toolchain-funcs games
-
-DESCRIPTION="Team-based aliens vs humans FPS with buildable structures"
-HOMEPAGE="http://tremulous.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.zip
- http://0day.icculus.org/mirrors/${PN}/${P}.zip
- ftp://ftp.wireplay.co.uk/pub/quake3arena/mods/${PN}/${P}.zip"
-
-LICENSE="GPL-2
- CCPL-Attribution-ShareAlike-2.5"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="dedicated openal opengl vorbis"
-
-UIDEPEND="openal? ( media-libs/openal )
- media-libs/libsdl
- vorbis? ( media-libs/libogg media-libs/libvorbis )
- virtual/opengl
- x11-libs/libX11
- x11-libs/libXau
- x11-libs/libXdmcp
- x11-libs/libXext"
-RDEPEND="opengl? ( ${UIDEPEND} )
- !opengl? ( !dedicated? ( ${UIDEPEND} ) )
- !games-fps/tremulous-bin"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-S=${WORKDIR}/${PN}/${P}-src
-
-pkg_setup() {
- games_pkg_setup
-
- if use amd64 ; then
- ewarn "emerge games-fps/tremulous-bin instead for better performance."
- echo
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd ${PN}
-
- unpack ./${P}-src.tar.gz
- cd "${S}"
- epatch "${FILESDIR}"/${P}-gcc42.patch
-}
-
-src_compile() {
- buildit() { use $1 && echo 1 || echo 0 ; }
-
- local build_client=1
- if use dedicated && ! use opengl ; then
- build_client=0
- fi
-
- emake \
- BUILD_CLIENT=${build_client} \
- BUILD_SERVER=$(buildit dedicated) \
- CC="$(tc-getCC)" \
- DEFAULT_BASEDIR="${GAMES_DATADIR}/${PN}" \
- USE_CODEC_VORBIS=$(buildit vorbis) \
- USE_OPENAL=$(buildit openal) \
- USE_LOCAL_HEADERS=0 \
- OPTIMIZE= \
- COMPILE_ARCH=${ARCH} \
- || die "emake failed"
-}
-
-src_install() {
- insinto "${GAMES_DATADIR}"/${PN}
- doins -r ../base || die "doins -r failed"
-
- dodoc ChangeLog ../manual.pdf
-
- local bindir=build/release-linux-${ARCH}
-
- if use opengl || ! use dedicated ; then
- newgamesbin ${bindir}/${PN}.${ARCH} ${PN} \
- || die "newgamesbin client failed"
- doicon misc/${PN}.xpm
- make_desktop_entry ${PN} Tremulous ${PN}
- fi
-
- if use dedicated ; then
- newgamesbin ${bindir}/tremded.${ARCH} ${PN}-ded \
- || die "newgamesbin ded failed"
- fi
-
- prepgamesdirs
-}