summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2009-09-24 19:41:30 +0000
committerTristan Heaven <nyhm@gentoo.org>2009-09-24 19:41:30 +0000
commitb4489566f873d3a78927e036a3530c4452ea49c7 (patch)
tree8bc3c5b5a38ed3b7f7403835719aed4b9f863e7e /games-fps
parentalpha/arm/ia64/s390/sh/sparc stable (diff)
downloadgentoo-2-b4489566f873d3a78927e036a3530c4452ea49c7.tar.gz
gentoo-2-b4489566f873d3a78927e036a3530c4452ea49c7.tar.bz2
gentoo-2-b4489566f873d3a78927e036a3530c4452ea49c7.zip
Use system libraries instead of the bundled ones
(Portage version: 2.2_rc41/cvs/Linux x86_64)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/postal2/ChangeLog9
-rw-r--r--games-fps/postal2/postal2-1409.2-r1.ebuild75
2 files changed, 82 insertions, 2 deletions
diff --git a/games-fps/postal2/ChangeLog b/games-fps/postal2/ChangeLog
index 60e987577fec..b064319c17db 100644
--- a/games-fps/postal2/ChangeLog
+++ b/games-fps/postal2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-fps/postal2
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/postal2/ChangeLog,v 1.6 2008/06/04 00:13:42 nyhm Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/postal2/ChangeLog,v 1.7 2009/09/24 19:41:30 nyhm Exp $
+
+*postal2-1409.2-r1 (24 Sep 2009)
+
+ 24 Sep 2009; Tristan Heaven <nyhm@gentoo.org> +postal2-1409.2-r1.ebuild:
+ Use system libraries instead of the bundled ones
04 Jun 2008; Tristan Heaven <nyhm@gentoo.org> postal2-1409.2.ebuild:
Remove unneeded dependencies
diff --git a/games-fps/postal2/postal2-1409.2-r1.ebuild b/games-fps/postal2/postal2-1409.2-r1.ebuild
new file mode 100644
index 000000000000..210253382d9e
--- /dev/null
+++ b/games-fps/postal2/postal2-1409.2-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/postal2/postal2-1409.2-r1.ebuild,v 1.1 2009/09/24 19:41:30 nyhm Exp $
+
+EAPI=2
+inherit eutils multilib games
+
+DESCRIPTION="Postal 2: Share the Pain"
+HOMEPAGE="http://www.gopostal.com/"
+SRC_URI="http://updatefiles.linuxgamepublishing.com/${PN}/${P/%?/1}.run
+ http://updatefiles.linuxgamepublishing.com/${PN}/${P}.run"
+
+LICENSE="postal2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="strip"
+PROPERTIES="interactive"
+
+DEPEND="games-util/loki_patch"
+RDEPEND="sys-libs/glibc
+ virtual/opengl
+ virtual/libstdc++:3.3
+ amd64? ( app-emulation/emul-linux-x86-sdl )
+ x86? (
+ media-libs/libsdl[X,opengl]
+ media-libs/openal
+ )"
+
+S=${WORKDIR}
+
+GAMES_CHECK_LICENSE="yes"
+
+src_unpack() {
+ cdrom_get_cds .installation_data/linux-specific.tar.bz2
+ mkdir ${A}
+
+ local f
+ for f in * ; do
+ cd "${S}"/${f}
+ unpack_makeself ${f}
+ done
+}
+
+src_install() {
+ has_multilib_profile && ABI=x86
+
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+
+ dodir "${dir}"
+ cd "${D}/${dir}"
+
+ ln -s "${CDROM_ROOT}"/.installation_data/*.bz2 .
+ unpack ./*.bz2
+ rm -f ./*.bz2
+
+ local d
+ for d in "${S}"/* ; do
+ pushd "${d}" > /dev/null
+ loki_patch patch.dat "${D}/${dir}" || die "loki_patch ${d} failed"
+ popd > /dev/null
+ done
+
+ rm -f System/{libstdc++.so.5,libgcc_s.so.1}
+
+ dosym /usr/$(get_libdir)/libopenal.so "${dir}"/System/openal.so || die
+ dosym /usr/$(get_libdir)/libSDL-1.2.so.0 "${dir}"/System/libSDL-1.2.so.0 \
+ || die
+
+ games_make_wrapper ${PN} ./${PN}-bin "${dir}"/System .
+ doicon "${CDROM_ROOT}"/.installation_data/${PN}.xpm
+ make_desktop_entry ${PN} "Postal 2: Share the Pain"
+
+ prepgamesdirs
+}