summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-09-09 09:44:15 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-09-09 09:44:15 +0000
commitac470ac3d1ebcd5508b7462cc6f970837bf543fd (patch)
treef7cea2997df891cac1c08bf81555399ac90304a0 /games-fps
parentCorrect bug # (diff)
downloadgentoo-2-ac470ac3d1ebcd5508b7462cc6f970837bf543fd.tar.gz
gentoo-2-ac470ac3d1ebcd5508b7462cc6f970837bf543fd.tar.bz2
gentoo-2-ac470ac3d1ebcd5508b7462cc6f970837bf543fd.zip
Respect LDFLAGS. Bug #336261
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/tremulous/ChangeLog6
-rw-r--r--games-fps/tremulous/files/tremulous-1.1.0-ldflags.patch22
-rw-r--r--games-fps/tremulous/tremulous-1.1.0-r4.ebuild5
3 files changed, 30 insertions, 3 deletions
diff --git a/games-fps/tremulous/ChangeLog b/games-fps/tremulous/ChangeLog
index e8ce08f1e213..6e31af3e7a5c 100644
--- a/games-fps/tremulous/ChangeLog
+++ b/games-fps/tremulous/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-fps/tremulous
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/tremulous/ChangeLog,v 1.17 2010/05/23 20:08:45 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/tremulous/ChangeLog,v 1.18 2010/09/09 09:44:15 tupone Exp $
+
+ 09 Sep 2010; Tupone Alfredo <tupone@gentoo.org> tremulous-1.1.0-r4.ebuild,
+ +files/tremulous-1.1.0-ldflags.patch:
+ Respect LDFLAGS. Bug #336261 by flameeyes@gentoo.org
23 May 2010; Pacho Ramos <pacho@gentoo.org> tremulous-1.1.0-r4.ebuild:
stable amd64, bug 313021
diff --git a/games-fps/tremulous/files/tremulous-1.1.0-ldflags.patch b/games-fps/tremulous/files/tremulous-1.1.0-ldflags.patch
new file mode 100644
index 000000000000..9d7e57e5db3d
--- /dev/null
+++ b/games-fps/tremulous/files/tremulous-1.1.0-ldflags.patch
@@ -0,0 +1,22 @@
+--- Makefile.old 2010-09-09 11:30:26.000000000 +0200
++++ Makefile 2010-09-09 11:33:41.000000000 +0200
+@@ -253,7 +253,7 @@
+ SHLIBLDFLAGS=-shared $(LDFLAGS)
+
+ THREAD_LDFLAGS=-lpthread
+- LDFLAGS=-ldl -lm
++ LDLIBS=-ldl -lm
+
+ ifeq ($(USE_SDL),1)
+ CLIENT_LDFLAGS=$(shell sdl-config --libs)
+@@ -1074,8 +1074,8 @@
+
+ $(B)/tremulous-smp.$(ARCH)$(BINEXT): $(Q3OBJ) $(Q3POBJ_SMP) $(LIBSDLMAIN)
+ @echo "LD $@"
+- @$(CC) -o $@ $(Q3OBJ) $(Q3POBJ_SMP) $(CLIENT_LDFLAGS) \
+- $(THREAD_LDFLAGS) $(LDFLAGS) $(LIBSDLMAIN)
++ @$(CC) -o $@ ${LDFLAGS} $(Q3OBJ) $(Q3POBJ_SMP) $(CLIENT_LDFLAGS) \
++ $(THREAD_LDFLAGS) $(LDLIBS) $(LIBSDLMAIN)
+
+ ifneq ($(strip $(LIBSDLMAIN)),)
+ ifneq ($(strip $(LIBSDLMAINSRC)),)
diff --git a/games-fps/tremulous/tremulous-1.1.0-r4.ebuild b/games-fps/tremulous/tremulous-1.1.0-r4.ebuild
index 04e0cc71402d..2201898d7d2f 100644
--- a/games-fps/tremulous/tremulous-1.1.0-r4.ebuild
+++ b/games-fps/tremulous/tremulous-1.1.0-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/tremulous/tremulous-1.1.0-r4.ebuild,v 1.3 2010/05/23 20:08:45 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/tremulous/tremulous-1.1.0-r4.ebuild,v 1.4 2010/09/09 09:44:15 tupone Exp $
EAPI=2
@@ -47,7 +47,8 @@ src_prepare() {
epatch "${WORKDIR}"/${PN}-svn755-upto-971.patch
epatch "${WORKDIR}"/${PN}-t971-client.patch
epatch "${FILESDIR}"/${P}-system_jpeg.patch \
- "${FILESDIR}"/${P}-system_jpeg-2.patch
+ "${FILESDIR}"/${P}-system_jpeg-2.patch \
+ "${FILESDIR}"/${P}-ldflags.patch
# fix the gcc-4.3.3 Werror issue
# This is probably issue for all icculus q3 based games
sed -i -e '16s/-Werror //' src/tools/asm/Makefile || die