summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2003-09-11 19:24:42 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2003-09-11 19:24:42 +0000
commitaa820ea95ffc58499f461c0565db342795529d3e (patch)
tree0b726e849d1bf6fdd8a2922e9d7b8d19f7c8dd08 /games-fps
parentVersion bumped. (diff)
downloadgentoo-2-aa820ea95ffc58499f461c0565db342795529d3e.tar.gz
gentoo-2-aa820ea95ffc58499f461c0565db342795529d3e.tar.bz2
gentoo-2-aa820ea95ffc58499f461c0565db342795529d3e.zip
Updated to fix possible problem with coreutils.
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/ut2003/ChangeLog5
-rw-r--r--games-fps/ut2003/ut2003-2225.ebuild16
2 files changed, 12 insertions, 9 deletions
diff --git a/games-fps/ut2003/ChangeLog b/games-fps/ut2003/ChangeLog
index 870f558433e7..0ab2c0282953 100644
--- a/games-fps/ut2003/ChangeLog
+++ b/games-fps/ut2003/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-fps/ut2003
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2003/ChangeLog,v 1.2 2003/09/10 16:07:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2003/ChangeLog,v 1.3 2003/09/11 19:24:42 wolf31o2 Exp $
+
+ 11 Sep 2003; Chris Gianelloni <wolf31o2@gentoo.org> ut2003-2225.ebuild:
+ Updated to fix possible problem with coreutils.
08 Sep 2003; Chris Gianelloni <wolf31o2@gentoo.org> ut2003-2225.ebuild:
Fixed sound and player model picker issues. Closes bugs # 27357 and 27451.
diff --git a/games-fps/ut2003/ut2003-2225.ebuild b/games-fps/ut2003/ut2003-2225.ebuild
index ec8cbd16f724..6de9e9df8198 100644
--- a/games-fps/ut2003/ut2003-2225.ebuild
+++ b/games-fps/ut2003/ut2003-2225.ebuild
@@ -1,13 +1,14 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2003/ut2003-2225.ebuild,v 1.2 2003/09/10 18:36:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2003/ut2003-2225.ebuild,v 1.3 2003/09/11 19:24:42 wolf31o2 Exp $
inherit games
IUSE="dedicated"
DESCRIPTION="Unreal Tournament 2003 - Sequel to the 1999 Game of the Year multi-player first-person shooter"
HOMEPAGE="http://www.unrealtournament2003.com/"
-SRC_URI="ftp://david.hedbor.org/ut2k3/updates/${PN}lnx_2107to${PV}.sh.bin"
+SRC_URI="http://unreal.epicgames.com/linux/ut2003/${PN}lnx_2107to${PV}.sh.bin
+ ftp://david.hedbor.org/ut2k3/updates/${PN}lnx_2107to${PV}.sh.bin"
LICENSE="ut2003"
SLOT="0"
@@ -15,7 +16,7 @@ KEYWORDS="x86"
RESTRICT="nostrip"
DEPEND="virtual/glibc"
-RDEPEND="dedicated? ( games-server/ut2003-ded )
+RDEPEND="dedicated? ( app-games/ut2003-ded )
!dedicated? ( virtual/opengl )"
S=${WORKDIR}
@@ -80,8 +81,7 @@ src_install() {
rm ${Ddir}/System/{Def{ault,User},UT2003,User}.ini || die "deleting ini files"
# unpack_makeself won't take absolute path
- cd ${S}
- tail +266 ${GAMES_CD}/linux_installer.sh | tar xf -
+ unpack_makeself ${GAMES_CD}/linux_installer.sh || die "unpacking linux installer"
# install extra help files
insinto ${dir}/Help
@@ -96,11 +96,11 @@ src_install() {
doins ${S}/eula/License.int
# uncompress original binaries/libraries
- tar xf ut2003lnxbins.tar || die "unpacking original binaries/libraries"
+ tar -xf ut2003lnxbins.tar || die "unpacking original binaries/libraries"
# copying extra/updater
cp -r ${S}/{extras,updater} ${Ddir} || die "copying extras/updater"
-
+
# install benchmarks
exeinto ${dir}/Benchmark
doexe ${S}/Benchmark/botmatch-* ${S}/Benchmark/flyby-* || die "copying benchmark files"