summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-04-20 01:07:54 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-04-20 01:07:54 +0000
commita544f75bcb8eee14125cb3eaedfe32c360fd7b2f (patch)
tree6cef8529a085cf432c6a49972f2199cd140233a7 /games-fps
parentAdd Categories to the .desktop file to make it appear on the right menu. (diff)
downloadgentoo-2-a544f75bcb8eee14125cb3eaedfe32c360fd7b2f.tar.gz
gentoo-2-a544f75bcb8eee14125cb3eaedfe32c360fd7b2f.tar.bz2
gentoo-2-a544f75bcb8eee14125cb3eaedfe32c360fd7b2f.zip
Version bump and closing bug #128183.
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/legends/ChangeLog8
-rw-r--r--games-fps/legends/files/digest-legends-0.4.1.396
-rw-r--r--games-fps/legends/legends-0.4.1.39.ebuild78
3 files changed, 91 insertions, 1 deletions
diff --git a/games-fps/legends/ChangeLog b/games-fps/legends/ChangeLog
index 7843d32ac1f4..768b499e6592 100644
--- a/games-fps/legends/ChangeLog
+++ b/games-fps/legends/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-fps/legends
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/legends/ChangeLog,v 1.14 2006/03/31 21:02:58 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/legends/ChangeLog,v 1.15 2006/04/20 01:07:54 wolf31o2 Exp $
+
+*legends-0.4.1.39 (20 Apr 2006)
+
+ 20 Apr 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ +legends-0.4.1.39.ebuild:
+ Version bump and closing bug #128183.
31 Mar 2006; Chris Gianelloni <wolf31o2@gentoo.org> legends-0.4.1c.ebuild:
Changed nomirror to mirror.
diff --git a/games-fps/legends/files/digest-legends-0.4.1.39 b/games-fps/legends/files/digest-legends-0.4.1.39
new file mode 100644
index 000000000000..708f82b7b9ab
--- /dev/null
+++ b/games-fps/legends/files/digest-legends-0.4.1.39
@@ -0,0 +1,6 @@
+MD5 c9f9604ff10219479dc33a4213dc30bd legends.png 5092
+RMD160 81aee5b6dbbca35011da2c665f8126fd01230d2a legends.png 5092
+SHA256 f4ac0db949c2f0a373f331a7a7528ef17c674a226c2366a5a443b5b5a44b6ce2 legends.png 5092
+MD5 54aeee62c34c1192109af36ab45afc5f legends_linux_0.4.1.39.sh 114463477
+RMD160 3b8965739c011bf8c21284da7148c6c967ff1fe0 legends_linux_0.4.1.39.sh 114463477
+SHA256 6a3478a3dbadafbc325919262618c0722d742624691e2c23b3504a459db47512 legends_linux_0.4.1.39.sh 114463477
diff --git a/games-fps/legends/legends-0.4.1.39.ebuild b/games-fps/legends/legends-0.4.1.39.ebuild
new file mode 100644
index 000000000000..ab2b2d2dcf3a
--- /dev/null
+++ b/games-fps/legends/legends-0.4.1.39.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/legends/legends-0.4.1.39.ebuild,v 1.1 2006/04/20 01:07:54 wolf31o2 Exp $
+
+inherit games
+
+MY_P=${PN}_linux_${PV}
+DESCRIPTION="A fast-paced first-person-perspective online multiplayer game similar to Tribes"
+HOMEPAGE="http://legendsthegame.net/"
+SRC_URI="http://www.legendsthegame.net/files/${MY_P}.sh
+ mirror://gentoo/${PN}.png
+ http://dev.gentoo.org/~wolf31o2/sources/dump/${PN}.png"
+
+RESTRICT="mirror"
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="as-is"
+SLOT="0"
+IUSE="dedicated"
+
+DEPEND=""
+RDEPEND=">=media-libs/libsdl-1.2
+ media-libs/libogg
+ media-libs/libvorbis
+ media-libs/openal
+ amd64? ( >=app-emulation/emul-linux-x86-sdl-2.1
+ >=app-emulation/emul-linux-x86-soundlibs-2.1 )
+ || (
+ media-fonts/font-adobe-75dpi
+ virtual/x11 )"
+
+S=${WORKDIR}
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+
+src_unpack() {
+ local LIBSDL=libSDL-1.3.so.0
+ SKIP=$(awk '/^__ARCHIVE_FOLLOWS__/ { print NR + 1; exit 0; }' \
+ ${DISTDIR}/${MY_P}.sh)
+ tail -n +${SKIP} ${DISTDIR}/${MY_P}.sh | tar -C ${WORKDIR} -xjf - \
+ || die "unpacking"
+
+ cd "${S}"
+ # keep libSDL-1.3.so because legends requires it as of 0.4.0, and
+ # 1.2.6 is highest in portage
+ # rm libSDL-*.so*
+ rm runlegends libSDL-1.2.so.0 libopenal.so libogg.so.0 libvorbis.so.0 *.DLL
+ find . -type f -exec chmod a-x '{}' \;
+ chmod a+x lindedicated LinLegends
+ cp "${FILESDIR}"/legends{,-ded} "${T}" || die "cp failed"
+ sed -i \
+ -e "s:GENTOO_DIR:${GAMES_PREFIX_OPT}/${PN}:" \
+ -e "s:LIBSDL:${LIBSDL}:" \
+ "${T}"/legends{,-ded} \
+ || die "sed failed"
+}
+
+src_install() {
+ cd "${S}"
+ dogamesbin "${T}/legends" || die "dogamesbin failed (1)"
+ keepdir "${dir}/"{show/ui,show/scripts,legends/scripts,legends/data,common/server,common/edit,common/client}
+ cp -rPp * "${Ddir}/" || die "cp failed"
+ if use dedicated ; then
+ dogamesbin "${T}"/legends-ded || die "dogamesbin failed (2)"
+ fi
+ doicon "${DISTDIR}"/${PN}.png
+ make_desktop_entry legends "Legends"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ einfo "Version ${PV} of ${PN} may give problems if there are"
+ einfo "config-files from earlier versions. Removing the ~/.legends dir"
+ einfo "and restarting will solve this."
+ echo
+}