summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-02-17 22:29:54 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-02-17 22:29:54 +0000
commit9e07403850ff7f797926402c8d7f18ea392d0be1 (patch)
tree4e7bd8146452a15cdbeb2fe88aa17415f20fa636 /games-fps
parentFix automagic depend on libselinux. (diff)
downloadgentoo-2-9e07403850ff7f797926402c8d7f18ea392d0be1.tar.gz
gentoo-2-9e07403850ff7f797926402c8d7f18ea392d0be1.tar.bz2
gentoo-2-9e07403850ff7f797926402c8d7f18ea392d0be1.zip
version bump #452290
(Portage version: 2.2.0_alpha162/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/rott/ChangeLog9
-rw-r--r--games-fps/rott/rott-1.1.2.ebuild56
2 files changed, 63 insertions, 2 deletions
diff --git a/games-fps/rott/ChangeLog b/games-fps/rott/ChangeLog
index 846d95640e21..670f254f84c3 100644
--- a/games-fps/rott/ChangeLog
+++ b/games-fps/rott/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-fps/rott
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/rott/ChangeLog,v 1.11 2010/03/18 05:43:20 mr_bones_ Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/rott/ChangeLog,v 1.12 2013/02/17 22:29:54 hasufell Exp $
+
+*rott-1.1.2 (17 Feb 2013)
+
+ 17 Feb 2013; Julian Ospald <hasufell@gentoo.org> +rott-1.1.2.ebuild:
+ version bump #452290
18 Mar 2010; Michael Sterrett <mr_bones_@gentoo.org> rott-1.1.1.ebuild:
add use-deps for libsdl
diff --git a/games-fps/rott/rott-1.1.2.ebuild b/games-fps/rott/rott-1.1.2.ebuild
new file mode 100644
index 000000000000..0f1164e4b326
--- /dev/null
+++ b/games-fps/rott/rott-1.1.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/rott/rott-1.1.2.ebuild,v 1.1 2013/02/17 22:29:54 hasufell Exp $
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Rise of the Triad for Linux!"
+HOMEPAGE="http://www.icculus.org/rott/"
+SRC_URI="http://www.icculus.org/rott/releases/${P}.tar.gz
+ demo? ( http://filesingularity.timedoctor.org/swdata.zip )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="demo"
+
+RDEPEND="media-libs/libsdl[audio,joystick,video]
+ media-libs/sdl-mixer"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${P}/rott
+
+src_prepare() {
+ sed -i \
+ -e '/^CC =/d' \
+ Makefile || die "sed failed"
+ emake clean
+}
+
+src_compile() {
+ emake -j1 \
+ EXTRACFLAGS="${CFLAGS} -DDATADIR=\\\"${GAMES_DATADIR}/${PN}/\\\"" \
+ SHAREWARE=$(usex demo "1" "0")
+}
+
+src_install() {
+ dogamesbin rott
+ dodoc ../doc/*.txt ../README
+ doman ../doc/rott.6
+ if use demo ; then
+ cd "${WORKDIR}" || die
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins *.dmo huntbgin.* remote1.rts
+ fi
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ if ! use demo ; then
+ elog "To play the full version, just copy the"
+ elog "data files to ${GAMES_DATADIR}/${PN}/"
+ fi
+}