summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-06-14 20:47:25 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-06-14 20:47:25 +0000
commit69081e2d907566458a227d4b8905f0fc30ca676f (patch)
treee9db12f9debc0adbffa8880dedc5119e0ba504ed /games-fps
parentChange pidof to pgrep; bug #182044 (diff)
downloadgentoo-2-69081e2d907566458a227d4b8905f0fc30ca676f.tar.gz
gentoo-2-69081e2d907566458a227d4b8905f0fc30ca676f.tar.bz2
gentoo-2-69081e2d907566458a227d4b8905f0fc30ca676f.zip
Version bump
(Portage version: 2.1.2.9)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/alienarena/ChangeLog9
-rw-r--r--games-fps/alienarena/alienarena-20070613.ebuild88
-rw-r--r--games-fps/alienarena/files/alienarena-20070613-paths.patch19
-rw-r--r--games-fps/alienarena/files/alienarena.xpm256
-rw-r--r--games-fps/alienarena/files/digest-alienarena-200706133
5 files changed, 374 insertions, 1 deletions
diff --git a/games-fps/alienarena/ChangeLog b/games-fps/alienarena/ChangeLog
index 7bd72d1104ed..f07b013a2f41 100644
--- a/games-fps/alienarena/ChangeLog
+++ b/games-fps/alienarena/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-fps/alienarena
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/alienarena/ChangeLog,v 1.3 2007/03/07 01:26:50 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/alienarena/ChangeLog,v 1.4 2007/06/14 20:47:25 nyhm Exp $
+
+*alienarena-20070613 (14 Jun 2007)
+
+ 14 Jun 2007; Tristan Heaven <nyhm@gentoo.org>
+ +files/alienarena-20070613-paths.patch, +files/alienarena.xpm,
+ +alienarena-20070613.ebuild:
+ Version bump
07 Mar 2007; Piotr Jaroszyński <peper@gentoo.org>
alienarena-20070224-r1.ebuild:
diff --git a/games-fps/alienarena/alienarena-20070613.ebuild b/games-fps/alienarena/alienarena-20070613.ebuild
new file mode 100644
index 000000000000..9f893e0e94da
--- /dev/null
+++ b/games-fps/alienarena/alienarena-20070613.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/alienarena/alienarena-20070613.ebuild,v 1.1 2007/06/14 20:47:25 nyhm Exp $
+
+inherit eutils flag-o-matic toolchain-funcs games
+
+MY_PN=${PN}${PV:0:4}
+DESCRIPTION="Fast paced multiplayer deathmatch game"
+HOMEPAGE="http://red.planetarena.org/"
+SRC_URI="http://cor.planetquake.gamespy.com/codered/files/${MY_PN}-${PV}-linux.zip
+ http://icculus.org/${PN}/files/${MY_PN}-${PV}-linux.zip"
+
+LICENSE="GPL-2 free-noncomm"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dedicated opengl sdl"
+
+UIRDEPEND="media-libs/jpeg
+ virtual/glu
+ virtual/opengl
+ x11-libs/libXxf86dga
+ x11-libs/libXxf86vm
+ sdl? ( media-libs/libsdl )"
+UIDEPEND="x11-proto/xf86dgaproto
+ x11-proto/xf86vidmodeproto
+ x11-proto/xproto"
+RDEPEND="opengl? ( ${UIRDEPEND} )
+ !opengl? ( !dedicated? ( ${UIRDEPEND} ) )"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ opengl? ( ${UIDEPEND} )
+ !opengl? ( !dedicated? ( ${UIDEPEND} ) )"
+
+S=${WORKDIR}/${MY_PN}
+
+src_unpack() {
+ unpack ${A}
+ cd ${MY_PN}
+ rm -f */*.so
+ epatch "${FILESDIR}"/${P}-paths.patch
+ sed -i \
+ -e "s:GENTOO_DATADIR:${GAMES_DATADIR}/${PN}:" \
+ -e "s:GENTOO_LIBDIR:$(games_get_libdir)/${PN}:" \
+ source/unix/sys_unix.c \
+ || die "sed failed"
+}
+
+src_compile() {
+ [[ $(gcc-fullversion) == "4.1.1" ]] && replace-flags -O? -O0
+ emake \
+ CC="$(tc-getCC)" \
+ OPTIMIZED_CFLAGS= \
+ $(use sdl && echo SDLSOUND=1) \
+ $(use opengl && ! use dedicated && echo BUILD=GAME) \
+ $(! use opengl && use dedicated && echo BUILD=DEDICATED) \
+ $(use opengl && use dedicated && echo BUILD=ALL) \
+ $(! use opengl && ! use dedicated && echo BUILD=GAME) \
+ || die "emake failed"
+}
+
+src_install() {
+ cd release
+ exeinto "$(games_get_libdir)"/${PN}
+ doexe game.so || die "doexe failed"
+
+ if use opengl || ! use dedicated ; then
+ newgamesbin crx ${PN}-oss || die "newgamesbin crx failed"
+ make_desktop_entry ${PN}-oss "Alien Arena (OSS audio)" ${PN}.xpm
+ use sdl || dosym ${PN}-oss "${GAMES_BINDIR}"/${PN}
+ fi
+
+ if use sdl ; then
+ newgamesbin crx.sdl ${PN}-sdl || die "newgamesbin crx.sdl failed"
+ make_desktop_entry ${PN}-sdl "Alien Arena (SDL audio)" ${PN}.xpm
+ dosym ${PN}-sdl "${GAMES_BINDIR}"/${PN}
+ fi
+
+ if use dedicated ; then
+ newgamesbin crded ${PN}-ded || die "newgamesbin crded failed"
+ fi
+
+ cd "${WORKDIR}"/${MY_PN}
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r arena botinfo data1 || die "doins failed"
+ doicon "${FILESDIR}"/${PN}.xpm
+ dodoc docs/README.txt docs/changelog.txt
+ prepgamesdirs
+}
diff --git a/games-fps/alienarena/files/alienarena-20070613-paths.patch b/games-fps/alienarena/files/alienarena-20070613-paths.patch
new file mode 100644
index 000000000000..263aa58666b6
--- /dev/null
+++ b/games-fps/alienarena/files/alienarena-20070613-paths.patch
@@ -0,0 +1,19 @@
+--- source/unix/sys_unix.c 2007-06-14 13:15:32.834511771 -0400
++++ source/unix/sys_unix.c 2007-06-14 13:16:54.505565372 -0400
+@@ -234,7 +234,7 @@
+ path = FS_NextPath (path);
+ if (!path)
+ return NULL; // couldn't find one anywhere
+- snprintf (name, MAX_OSPATH, "%s/%s", path, gamename);
++ snprintf (name, MAX_OSPATH, "%s/%s", "GENTOO_LIBDIR", gamename);
+
+ /* skip it if it just doesn't exist */
+ fp = fopen(name, "rb");
+@@ -308,6 +308,7 @@
+ saved_euid = geteuid();
+ seteuid(getuid());
+
++ chdir("GENTOO_DATADIR");
+ Qcommon_Init(argc, argv);
+
+ fcntl(0, F_SETFL, fcntl (0, F_GETFL, 0) | FNDELAY);
diff --git a/games-fps/alienarena/files/alienarena.xpm b/games-fps/alienarena/files/alienarena.xpm
new file mode 100644
index 000000000000..ee78ac5a0127
--- /dev/null
+++ b/games-fps/alienarena/files/alienarena.xpm
@@ -0,0 +1,256 @@
+/* XPM */
+static char * Q2_xpm[] = {
+"32 32 221 2",
+" c None",
+". c #160300",
+"+ c #342234",
+"@ c #170300",
+"# c #150300",
+"$ c #180300",
+"% c #250500",
+"& c #240400",
+"* c #130200",
+"= c #0E0100",
+"- c #0D0100",
+"; c #0B0100",
+"> c #090100",
+", c #1A0300",
+"' c #280500",
+") c #1C0400",
+"! c #100200",
+"~ c #0C0100",
+"{ c #0A0100",
+"] c #100100",
+"^ c #140300",
+"/ c #200400",
+"( c #5E0E00",
+"_ c #962609",
+": c #42190A",
+"< c #29150A",
+"[ c #27150A",
+"} c #26140A",
+"| c #22130A",
+"1 c #0F0905",
+"2 c #020000",
+"3 c #2D0600",
+"4 c #630E00",
+"5 c #4A1B0A",
+"6 c #26150A",
+"7 c #24140A",
+"8 c #1F120A",
+"9 c #0C0704",
+"0 c #070000",
+"a c #1F0400",
+"b c #6B1000",
+"c c #D83208",
+"d c #E34615",
+"e c #7B3215",
+"f c #5B2D15",
+"g c #582C15",
+"h c #562B15",
+"i c #472815",
+"j c #311E12",
+"k c #000000",
+"l c #480A00",
+"m c #C12A07",
+"n c #AD3B15",
+"o c #632E15",
+"p c #592C15",
+"q c #532B15",
+"r c #442715",
+"s c #020100",
+"t c #380800",
+"u c #7C1200",
+"v c #C2370F",
+"w c #B73D15",
+"x c #723015",
+"y c #622E15",
+"z c #602D15",
+"A c #512A15",
+"B c #3C2415",
+"C c #120C07",
+"D c #450A00",
+"E c #F34512",
+"F c #B33C15",
+"G c #692F15",
+"H c #612E15",
+"I c #5D2C15",
+"J c #4B2915",
+"K c #392315",
+"L c #1E0400",
+"M c #4E0B00",
+"N c #771502",
+"O c #C03D13",
+"P c #963715",
+"Q c #682F15",
+"R c #5A2C15",
+"S c #462715",
+"T c #301D10",
+"U c #491506",
+"V c #D54215",
+"W c #813315",
+"X c #5F2D15",
+"Y c #522A15",
+"Z c #3D2415",
+"` c #1D120B",
+" . c #270500",
+".. c #610E00",
+"+. c #8A2107",
+"@. c #BF3F15",
+"#. c #542B15",
+"$. c #4D2915",
+"%. c #622A12",
+"&. c #853415",
+"*. c #612D15",
+"=. c #432615",
+"-. c #2D1C11",
+";. c #010000",
+">. c #030000",
+",. c #190300",
+"'. c #370800",
+"). c #6C1000",
+"!. c #AA320E",
+"~. c #AF3C15",
+"{. c #713015",
+"]. c #5D2D15",
+"^. c #652E15",
+"/. c #5C2C15",
+"(. c #4A2815",
+"_. c #382214",
+":. c #0B0704",
+"<. c #140200",
+"[. c #1D0400",
+"}. c #4C0B00",
+"|. c #751502",
+"1. c #BF3D13",
+"2. c #993715",
+"3. c #1B110A",
+"4. c #080000",
+"5. c #982307",
+"6. c #803315",
+"7. c #602E15",
+"8. c #2C1C11",
+"9. c #4B0B00",
+"0. c #C51E00",
+"a. c #FA430E",
+"b. c #A63A15",
+"c. c #3D2515",
+"d. c #090503",
+"e. c #600E00",
+"f. c #D02201",
+"g. c #FC4C13",
+"h. c #9D3815",
+"i. c #3F2515",
+"j. c #190F09",
+"k. c #090000",
+"l. c #390800",
+"m. c #921600",
+"n. c #D9370C",
+"o. c #763115",
+"p. c #372214",
+"q. c #070403",
+"r. c #771200",
+"s. c #B62605",
+"t. c #EC4615",
+"u. c #8E3515",
+"v. c #572C15",
+"w. c #2C1B10",
+"x. c #050000",
+"y. c #120200",
+"z. c #570C00",
+"A. c #A21B01",
+"B. c #ED4413",
+"C. c #6B2F15",
+"D. c #3A0800",
+"E. c #D7370D",
+"F. c #D04115",
+"G. c #773115",
+"H. c #422614",
+"I. c #48200E",
+"J. c #8D3515",
+"K. c #6D2F15",
+"L. c #080503",
+"M. c #791200",
+"N. c #B82606",
+"O. c #EB4615",
+"P. c #8C3515",
+"Q. c #552B15",
+"R. c #21140C",
+"S. c #280902",
+"T. c #C63F15",
+"U. c #8E3615",
+"V. c #580D00",
+"W. c #A41B01",
+"X. c #F04513",
+"Y. c #6A2F15",
+"Z. c #492815",
+"`. c #362114",
+" + c #050302",
+".+ c #320700",
+"++ c #BA320C",
+"@+ c #C13F15",
+"#+ c #1A100A",
+"$+ c #A31800",
+"%+ c #E53D0D",
+"&+ c #733115",
+"*+ c #1D130C",
+"=+ c #350700",
+"-+ c #901902",
+";+ c #D34114",
+">+ c #090603",
+",+ c #0F0100",
+"'+ c #1B0300",
+")+ c #560C00",
+"!+ c #D82D06",
+"~+ c #CC4415",
+"{+ c #4E2915",
+"]+ c #4C2915",
+"^+ c #240500",
+"/+ c #6F1000",
+"(+ c #84270C",
+"_+ c #662F15",
+":+ c #4E2A15",
+"<+ c #482815",
+"[+ c #2D1C10",
+"}+ c #571304",
+"|+ c #210C05",
+"1+ c #120A05",
+"2+ c #110A05",
+"3+ c #100905",
+"4+ c #360700",
+"5+ c #320901",
+"6+ c #190B05",
+"7+ c #060201",
+"8+ c #110200",
+". . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . ",
+". . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . ",
+". . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . ",
+". . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . ",
+". . . . . . . . + . . . . . . . . . . . . . . . . . . . . . . . ",
+". . . . . . @ @ . . . . . # # # . @ @ . . . . . # # # . . . . . ",
+". . . . . $ % & * = = - - ; > = , ' ) ! = = - ~ { { ] ^ . . . . ",
+". . . . . / ( _ : < [ [ } | 1 2 3 4 5 < [ [ 6 7 8 9 0 * . . . . ",
+". . . . . a b c d e f g h i j k l m n o p g q r j s 0 * . . . . ",
+". . . . . $ t u v w x y z A B C D E F G H I J K 9 k - # . . . . ",
+". . . . . . L M N O P Q H R S T U V W o X Y Z ` k 0 * . . . . . ",
+". . . . . . . ...+.@.W o X #.$.%.&.Q *.g =.-.;.>.! # . . . . . ",
+". . . . . . . ,.'.).!.~.{.y X ].o ^.y /.(._.:.;.~ <.. . . . . . ",
+". . . . . . . . [.}.|.1.2.Q H H y H X A B 3.k 4.* . . . . . . . ",
+". . . . . . . . . .4 5.V 6.o y y 7.p =.8.k >.! # . . . . . . . ",
+". . . . . . . . . , 9.0.a.b.^.y y 7.q c.d.k ; ^ . . . . . . . . ",
+". . . . . . . . . [.e.f.g.h.^.y y 7.h i.j.k k.<.. . . . . . . . ",
+". . . . . . . . $ l.m.n.V o.y y y H /.(.p.q.;.= # . . . . . . . ",
+". . . . . . . . .r.s.t.u.^.H 7.H H z v.=.w.k x.y.# . . . . . . ",
+". . . . . . . [.z.A.B.n C.H /.h y Q o X A Z j.k { <.. . . . . . ",
+". . . . . . $ D.m.E.F.G.y ].$.H.I.J.K.H /.(._.L.;.= ^ . . . . . ",
+". . . . . . .M.N.O.P.^.z Q.i.R.S.T.U.^.z v.=.w.k x.y.# . . . . ",
+". . . . . [.V.W.X.n Y.H ].Z.`. +.+++@+{.H X A Z #+k { <.. . . . ",
+". . . . @ '.$+%+V &+X ].#.i.*+k =+-+;+&.*.].p Z._.>+2 ,+# . . . ",
+". . . . '+)+!+~+G {+]+J S _. +2 ^+/+(+_+:+]+J <+i.[+k { ^ . . . ",
+". . . . ,.t }+|+1+2+2+2+3+9 ;.; ,.4+5+6+1+2+2+2+3+1 7+~ ^ . . . ",
+". . . . . '+'+! - - - ~ ; ; = * . , '+8+- - - ~ ~ ; - * # . . . ",
+". . . . . . . # # # # # # # # # . . . # # # # # # # # # . . . . ",
+". . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . ",
+". . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . ",
+". . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . ",
+". . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . "};
diff --git a/games-fps/alienarena/files/digest-alienarena-20070613 b/games-fps/alienarena/files/digest-alienarena-20070613
new file mode 100644
index 000000000000..d6346c0e6e31
--- /dev/null
+++ b/games-fps/alienarena/files/digest-alienarena-20070613
@@ -0,0 +1,3 @@
+MD5 65d2948fa636cbc28c82da2264df2fea alienarena2007-20070613-linux.zip 223204178
+RMD160 ae4b12d8f3271dd6e4c0ad801ec58e218a686e96 alienarena2007-20070613-linux.zip 223204178
+SHA256 593a7b106768abaff4c55f0b06dc20b5914601516c98ca5dfe93526de0559933 alienarena2007-20070613-linux.zip 223204178