summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-08-16 10:09:11 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-08-16 10:09:11 +0000
commit5c7a5ab41760d3837f94057386dcf61981825d1a (patch)
tree502896b1ebb3f0c55b0a873648e95f01e72e8632 /games-fps
parentinitial revision (Manifest recommit) (diff)
downloadgentoo-2-5c7a5ab41760d3837f94057386dcf61981825d1a.tar.gz
gentoo-2-5c7a5ab41760d3837f94057386dcf61981825d1a.tar.bz2
gentoo-2-5c7a5ab41760d3837f94057386dcf61981825d1a.zip
fix compile issue (bug #60453); more error checking; tidy
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/cube/ChangeLog5
-rw-r--r--games-fps/cube/cube-20040522.ebuild32
2 files changed, 22 insertions, 15 deletions
diff --git a/games-fps/cube/ChangeLog b/games-fps/cube/ChangeLog
index a13e10c9fa4c..80c11535a012 100644
--- a/games-fps/cube/ChangeLog
+++ b/games-fps/cube/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-fps/cube
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/cube/ChangeLog,v 1.6 2004/08/15 09:17:41 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/cube/ChangeLog,v 1.7 2004/08/16 10:09:11 mr_bones_ Exp $
+
+ 16 Aug 2004; Michael Sterrett <mr_bones_@gentoo.org> cube-20040522.ebuild:
+ fix compile issue (bug #60453); more error checking; tidy
*cube-20040522 (15 Aug 2004)
diff --git a/games-fps/cube/cube-20040522.ebuild b/games-fps/cube/cube-20040522.ebuild
index 1e90d792962e..31158c828d15 100644
--- a/games-fps/cube/cube-20040522.ebuild
+++ b/games-fps/cube/cube-20040522.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/cube/cube-20040522.ebuild,v 1.2 2004/08/15 09:18:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/cube/cube-20040522.ebuild,v 1.3 2004/08/16 10:09:11 mr_bones_ Exp $
inherit eutils games
@@ -49,35 +49,39 @@ src_unpack() {
Makefile \
|| die "sed Makefile failed"
edos2unix *.cpp
+ chmod a+x ${S}/source/enet/configure
}
src_compile() {
cd source/enet
- chmod +x configure
- econf || die "econf failed"
- emake || die
+ econf ||
+ emake || die "emake failed"
cd ../src
- emake CXXOPTFLAGS="-fpermissive ${CXXFLAGS}" || die "emake failed"
+ einfo "Compiling in $(pwd)"
+ emake CXXOPTFLAGS="-DHAS_SOCKLEN_T=1 -fpermissive ${CXXFLAGS}" \
+ || die "emake failed"
}
src_install() {
dogamesbin source/src/cube_{client,server} || die "dogamesbin failed"
- exeinto ${GAMES_LIBDIR}/${PN}
+ exeinto "${GAMES_LIBDIR}/${PN}"
if [ "${ARCH}" == "x86" ] ; then
- newexe bin_unix/linux_client cube_client
- newexe bin_unix/linux_server cube_server
+ newexe bin_unix/linux_client cube_client || die "newexe failed"
+ newexe bin_unix/linux_server cube_server || die "newexe failed"
elif [ "${ARCH}" == "ppc" ] ; then
- newexe bin_unix/ppc_linux_client cube_client
- newexe bin_unix/ppc_linux_server cube_server
+ newexe bin_unix/ppc_linux_client cube_client || die "newexe failed"
+ newexe bin_unix/ppc_linux_server cube_server || die "newexe failed"
fi
- dogamesbin ${FILESDIR}/cube_{client,server}-bin || die "dogamesbin failed (bin)"
+ dogamesbin "${FILESDIR}/cube_"{client,server}-bin \
+ || die "dogamesbin failed (bin)"
sed -i \
-e "s:GENTOO_DATADIR:${CUBE_DATADIR}:" \
-e "s:GENTOO_LIBDIR:${GAMES_LIBDIR}/${PN}:" \
- ${D}/${GAMES_BINDIR}/cube_{client,server}-bin
+ "${D}/${GAMES_BINDIR}/cube_"{client,server}-bin
- dodir ${CUBE_DATADIR}
- cp -r *.cfg data packages ${D}/${CUBE_DATADIR} || die "cp failed"
+ dodir "${CUBE_DATADIR}"
+ cp -r *.cfg data packages "${D}/${CUBE_DATADIR}" \
+ || die "cp failed"
dodoc source/src/CUBE_TODO.txt
dohtml -r docs/