summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-03-29 16:13:55 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-03-29 16:13:55 +0000
commit3156d8d0648cacbf697507160910a7751bfc6c08 (patch)
tree2d3a756184a7a3e4c05e4c82c972edea3221e1d0 /games-fps
parentuse unpack_zip from unpacker.eclass instead of unzip (diff)
downloadgentoo-2-3156d8d0648cacbf697507160910a7751bfc6c08.tar.gz
gentoo-2-3156d8d0648cacbf697507160910a7751bfc6c08.tar.bz2
gentoo-2-3156d8d0648cacbf697507160910a7751bfc6c08.zip
use unpack_zip from unpacker.eclass instead of unzip
(Portage version: 2.2.0_alpha169/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/quake2-demodata/ChangeLog8
-rw-r--r--games-fps/quake2-demodata/quake2-demodata-3.14.ebuild8
2 files changed, 9 insertions, 7 deletions
diff --git a/games-fps/quake2-demodata/ChangeLog b/games-fps/quake2-demodata/ChangeLog
index 689ad34ed5db..0305463e4ff3 100644
--- a/games-fps/quake2-demodata/ChangeLog
+++ b/games-fps/quake2-demodata/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-fps/quake2-demodata
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-demodata/ChangeLog,v 1.6 2009/11/19 18:36:12 armin76 Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-demodata/ChangeLog,v 1.7 2013/03/29 16:13:55 hasufell Exp $
+
+ 29 Mar 2013; Julian Ospald <hasufell@gentoo.org> quake2-demodata-3.14.ebuild:
+ use unpack_zip from unpacker.eclass instead of unzip
19 Nov 2009; Raúl Porcel <armin76@gentoo.org>
quake2-demodata-3.14.ebuild:
@@ -28,4 +31,3 @@
+quake2-demodata-3.14.ebuild:
Initial import. Ebuild by Paul Bredbury <brebs@sent.com>. Closing bug
#137519.
-
diff --git a/games-fps/quake2-demodata/quake2-demodata-3.14.ebuild b/games-fps/quake2-demodata/quake2-demodata-3.14.ebuild
index 1862e52b0363..4ef768138786 100644
--- a/games-fps/quake2-demodata/quake2-demodata-3.14.ebuild
+++ b/games-fps/quake2-demodata/quake2-demodata-3.14.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-demodata/quake2-demodata-3.14.ebuild,v 1.7 2009/11/19 18:36:12 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-demodata/quake2-demodata-3.14.ebuild,v 1.8 2013/03/29 16:13:55 hasufell Exp $
-inherit eutils versionator games
+inherit unpacker eutils versionator games
MY_PV=$(delete_all_version_separators)
MY_PN="quake2"
@@ -54,7 +54,7 @@ pkg_setup() {
}
src_unpack() {
- unzip -qo "${DISTDIR}/${FILE}" || die "unzip failed"
+ unpack_zip ${A}
}
src_install() {