summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2005-11-03 18:30:24 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2005-11-03 18:30:24 +0000
commit3100257db99023ba7061f4cd4a628223401cab95 (patch)
tree75aa4bf8f114271b38a3a1dbbbebfedde91c93e5 /games-fps
parentold (diff)
downloadgentoo-2-3100257db99023ba7061f4cd4a628223401cab95.tar.gz
gentoo-2-3100257db99023ba7061f4cd4a628223401cab95.tar.bz2
gentoo-2-3100257db99023ba7061f4cd4a628223401cab95.zip
Made the ebuild respect USE=dedicated and also adjusted the path patch. Closing bug #104613. Thanks to Paul Bredbury and Tuomas Suutari for finding and fixing these.
(Portage version: 2.0.53_rc6)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/quake2-icculus/ChangeLog9
-rw-r--r--games-fps/quake2-icculus/files/quake2-icculus-0.16.1-gentoo-paths.patch32
-rw-r--r--games-fps/quake2-icculus/quake2-icculus-0.16.1.ebuild4
3 files changed, 39 insertions, 6 deletions
diff --git a/games-fps/quake2-icculus/ChangeLog b/games-fps/quake2-icculus/ChangeLog
index 4c4f3f786040..82ed1bce7423 100644
--- a/games-fps/quake2-icculus/ChangeLog
+++ b/games-fps/quake2-icculus/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-fps/quake2-icculus
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/ChangeLog,v 1.16 2005/09/01 02:34:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/ChangeLog,v 1.17 2005/11/03 18:30:24 wolf31o2 Exp $
+
+ 03 Nov 2005; Chris Gianelloni <wolf31o2@gentoo.org>
+ files/quake2-icculus-0.16.1-gentoo-paths.patch,
+ quake2-icculus-0.16.1.ebuild:
+ Made the ebuild respect USE=dedicated and also adjusted the path patch.
+ Closing bug #104613. Thanks to Paul Bredbury and Tuomas Suutari for finding
+ and fixing these.
01 Sep 2005; Mike Frysinger <vapier@gentoo.org>
quake2-icculus-0.16.1.ebuild:
diff --git a/games-fps/quake2-icculus/files/quake2-icculus-0.16.1-gentoo-paths.patch b/games-fps/quake2-icculus/files/quake2-icculus-0.16.1-gentoo-paths.patch
index 4e126c39338a..c017051583b8 100644
--- a/games-fps/quake2-icculus/files/quake2-icculus-0.16.1-gentoo-paths.patch
+++ b/games-fps/quake2-icculus/files/quake2-icculus-0.16.1-gentoo-paths.patch
@@ -5,7 +5,7 @@ retrieving revision 1.56
diff -u -p -r1.56 Makefile
--- Makefile 5 May 2005 22:23:34 -0000 1.56
+++ Makefile 29 Aug 2005 22:52:28 -0000
-@@ -74,35 +74,38 @@ endif
+@@ -74,35 +74,46 @@ endif
CC=gcc
@@ -47,6 +47,14 @@ diff -u -p -r1.56 Makefile
endif
+endif
+RELEASE_CFLAGS=$(BASE_CFLAGS) $(OPT_CFLAGS)
++
++ifeq ($(ADDCFLAGS),debug)
++CFLAGS=$(DEBUG_CFLAGS) -DLINUX_VERSION=\"$(VERSION) Debug\"
++endif
++
++ifeq ($(ADDCFLAGS),release)
++CFLAGS=$(RELEASE_CFLAGS) -DLINUX_VERSION=\"$(VERSION)\"
++endif
VERSION=3.21+r0.16
@@ -55,15 +63,33 @@ diff -u -p -r1.56 Makefile
endif
+ifdef DEFAULT_BASEDIR
-+BASE_CFLAGS += -DDEFAULT_BASEDIR='\"$(DEFAULT_BASEDIR)\"'
++BASE_CFLAGS += -DDEFAULT_BASEDIR=\"$(DEFAULT_BASEDIR)\"
+endif
+ifdef DEFAULT_LIBDIR
-+BASE_CFLAGS += -DDEFAULT_LIBDIR='\"$(DEFAULT_LIBDIR)\"'
++BASE_CFLAGS += -DDEFAULT_LIBDIR=\"$(DEFAULT_LIBDIR)\"
+endif
+
ifeq ($(strip $(BUILD_QMAX)),YES)
BASE_CFLAGS+=-DQMAX
endif
+@@ -406,7 +424,7 @@
+ $(BUILD_DEBUG_DIR)/ctf \
+ $(BUILD_DEBUG_DIR)/xatrix \
+ $(BUILD_DEBUG_DIR)/rogue
+- $(MAKE) targets BUILDDIR=$(BUILD_DEBUG_DIR) CFLAGS="$(DEBUG_CFLAGS) -DLINUX_VERSION='\"$(VERSION) Debug\"'"
++ $(MAKE) targets BUILDDIR=$(BUILD_DEBUG_DIR) ADDCFLAGS=debug
+
+ build_release:
+ @-mkdir -p $(BUILD_RELEASE_DIR) \
+@@ -418,7 +436,7 @@
+ $(BUILD_RELEASE_DIR)/ctf \
+ $(BUILD_RELEASE_DIR)/xatrix \
+ $(BUILD_RELEASE_DIR)/rogue
+- $(MAKE) targets BUILDDIR=$(BUILD_RELEASE_DIR) CFLAGS="$(RELEASE_CFLAGS) -DLINUX_VERSION='\"$(VERSION)\"'"
++ $(MAKE) targets BUILDDIR=$(BUILD_RELEASE_DIR) ADDCFLAGS=release
+
+ targets: $(TARGETS)
+
Index: src/linux/qgl_linux.c
===================================================================
RCS file: /cvs/cvsroot/quake2/src/linux/qgl_linux.c,v
diff --git a/games-fps/quake2-icculus/quake2-icculus-0.16.1.ebuild b/games-fps/quake2-icculus/quake2-icculus-0.16.1.ebuild
index 4ed0c3e35435..c136d35e54b8 100644
--- a/games-fps/quake2-icculus/quake2-icculus-0.16.1.ebuild
+++ b/games-fps/quake2-icculus/quake2-icculus-0.16.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/quake2-icculus-0.16.1.ebuild,v 1.8 2005/09/01 02:34:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/quake2-icculus-0.16.1.ebuild,v 1.9 2005/11/03 18:30:24 wolf31o2 Exp $
inherit eutils games
@@ -90,7 +90,7 @@ src_compile() {
BUILD_XATRIX=$(yesno xatrix) \
BUILD_ROGUE=$(yesno rogue) \
BUILD_JOYSTICK=$(yesno joystick) \
- BUILD_DEDICATED=YES \
+ BUILD_DEDICATED=$(yesno dedicated) \
BUILD_AA=$(yesno aalib) \
BUILD_QMAX=${BUILD_QMAX} \
HAVE_IPV6=$(yesno ipv6) \