summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2012-11-01 21:43:39 +0000
committerJulian Ospald <hasufell@gentoo.org>2012-11-01 21:43:39 +0000
commit2d4d9c52e5a60896b1cc1f3ea1b7a3b29564f93c (patch)
treee1e41a304f742dbb71e709ca191c85117c57f0af /games-fps
parentMark _python_ln_rel as @INTERNAL. (diff)
downloadgentoo-2-2d4d9c52e5a60896b1cc1f3ea1b7a3b29564f93c.tar.gz
gentoo-2-2d4d9c52e5a60896b1cc1f3ea1b7a3b29564f93c.tar.bz2
gentoo-2-2d4d9c52e5a60896b1cc1f3ea1b7a3b29564f93c.zip
version bump
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/urbanterror/ChangeLog8
-rw-r--r--games-fps/urbanterror/files/urbanterror-4.2.004-build.patch52
-rw-r--r--games-fps/urbanterror/urbanterror-4.2.004.ebuild122
3 files changed, 181 insertions, 1 deletions
diff --git a/games-fps/urbanterror/ChangeLog b/games-fps/urbanterror/ChangeLog
index 7d108f75b118..4103ca22dcc1 100644
--- a/games-fps/urbanterror/ChangeLog
+++ b/games-fps/urbanterror/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-fps/urbanterror
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/urbanterror/ChangeLog,v 1.9 2012/10/26 20:45:41 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/urbanterror/ChangeLog,v 1.10 2012/11/01 21:43:39 hasufell Exp $
+
+*urbanterror-4.2.004 (01 Nov 2012)
+
+ 01 Nov 2012; Julian Ospald <hasufell@gentoo.org> +urbanterror-4.2.004.ebuild,
+ +files/urbanterror-4.2.004-build.patch:
+ version bump
*urbanterror-4.2.003 (26 Oct 2012)
diff --git a/games-fps/urbanterror/files/urbanterror-4.2.004-build.patch b/games-fps/urbanterror/files/urbanterror-4.2.004-build.patch
new file mode 100644
index 000000000000..7cc4623f9bd4
--- /dev/null
+++ b/games-fps/urbanterror/files/urbanterror-4.2.004-build.patch
@@ -0,0 +1,52 @@
+--- Makefile
++++ Makefile
+@@ -213,7 +213,7 @@
+ endif
+ endif
+
+- BASE_CFLAGS = -Wall -fno-strict-aliasing -Wimplicit -Wstrict-prototypes -pipe
++ BASE_CFLAGS = -Wall -fno-strict-aliasing -Wimplicit -Wstrict-prototypes
+
+ ifeq ($(USE_OPENAL),1)
+ BASE_CFLAGS += -DUSE_OPENAL=1
+@@ -239,19 +239,15 @@
+ BASE_CFLAGS += -I/usr/X11R6/include
+ endif
+
+- OPTIMIZE = -O3 -ffast-math -funroll-loops -fomit-frame-pointer
++ OPTIMIZE = -ffast-math -funroll-loops
+
+ ifeq ($(ARCH),x86_64)
+- OPTIMIZE = -O3 -fomit-frame-pointer -ffast-math -funroll-loops \
+- -falign-loops=2 -falign-jumps=2 -falign-functions=2 \
+- -fstrength-reduce
++ OPTIMIZE = -ffast-math -funroll-loops
+ # experimental x86_64 jit compiler! you need GNU as
+ HAVE_VM_COMPILED = true
+ else
+ ifeq ($(ARCH),i386)
+- OPTIMIZE = -O3 -march=i586 -fomit-frame-pointer -ffast-math \
+- -funroll-loops -falign-loops=2 -falign-jumps=2 \
+- -falign-functions=2 -fstrength-reduce
++ OPTIMIZE = -ffast-math -funroll-loops
+ HAVE_VM_COMPILED=true
+ else
+ ifeq ($(ARCH),ppc)
+@@ -265,7 +261,7 @@
+ BASE_CFLAGS += -DNO_VM_COMPILED
+ endif
+
+- DEBUG_CFLAGS = $(BASE_CFLAGS) -g -O0
++ DEBUG_CFLAGS = $(BASE_CFLAGS) $(OPTIMIZE)
+
+ RELEASE_CFLAGS=$(BASE_CFLAGS) -DNDEBUG $(OPTIMIZE)
+
+@@ -274,7 +270,7 @@
+ SHLIBLDFLAGS=-shared $(LDFLAGS)
+
+ THREAD_LDFLAGS=-lpthread
+- LDFLAGS=-ldl -lm
++ LDFLAGS+=-ldl -lm
+
+ ifeq ($(USE_SDL),1)
+ CLIENT_LDFLAGS=$(shell sdl-config --libs)
diff --git a/games-fps/urbanterror/urbanterror-4.2.004.ebuild b/games-fps/urbanterror/urbanterror-4.2.004.ebuild
new file mode 100644
index 000000000000..d2eb635998cf
--- /dev/null
+++ b/games-fps/urbanterror/urbanterror-4.2.004.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/urbanterror/urbanterror-4.2.004.ebuild,v 1.1 2012/11/01 21:43:39 hasufell Exp $
+
+EAPI=4
+
+inherit check-reqs eutils gnome2-utils games
+
+DESCRIPTION="Hollywood tactical shooter based on the ioquake3 engine"
+HOMEPAGE="http://www.urbanterror.info/home/"
+SRC_URI="http://178.63.102.135/svens_stuff/UrbanTerror42.tar.xz -> ${PN}-4.2.003.tar.xz
+ http://dev.gentoo.org/~hasufell/distfiles/ioq3-for-UrbanTerror-4.2.002.tar.xz
+ http://upload.wikimedia.org/wikipedia/en/5/56/Urbanterror.svg -> ${PN}.svg
+ mirror://gentoo/urbanterror-4.2.003-to-4.2.004-update.tar"
+
+LICENSE="GPL-2 Q3AEULA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+curl debug dedicated openal +sdl server smp vorbis"
+
+RDEPEND="
+ !dedicated? (
+ virtual/opengl
+ curl? ( net-misc/curl )
+ openal? ( media-libs/openal )
+ sdl? ( media-libs/libsdl[X,audio,joystick,opengl,video] )
+ !sdl? ( x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXxf86dga
+ x11-libs/libXxf86vm )
+ vorbis? ( media-libs/libogg
+ media-libs/libvorbis )
+ )"
+DEPEND="${RDEPEND}
+ dedicated? ( curl? ( net-misc/curl ) )"
+
+S=${WORKDIR}/ioq3-for-UrbanTerror-4.2.002
+S_DATA=${WORKDIR}/UrbanTerror42
+S_UPDATE=${WORKDIR}/urbanterror-4.2.003-to-4.2.004-update
+
+CHECKREQS_DISK_BUILD="2700M"
+CHECKREQS_DISK_USR="1300M"
+
+pkg_pretend() {
+ check-reqs_pkg_pretend
+
+ if ! use dedicated ; then
+ if ! use sdl && ! use openal ; then
+ ewarn
+ ewarn "Sound support disabled. Enable 'sdl' or 'openal' useflag."
+ ewarn
+ fi
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_compile() {
+ buildit() { use $1 && echo 1 || echo 0 ; }
+ nobuildit() { use $1 && echo 0 || echo 1 ; }
+
+ emake \
+ ARCH=$(usex amd64 "x86_64" "i386") \
+ DEFAULT_BASEDIR="${GAMES_DATADIR}/${PN}" \
+ BUILD_CLIENT=$(nobuildit dedicated) \
+ BUILD_CLIENT_SMP=$(usex smp "$(nobuildit dedicated)" "0") \
+ BUILD_SERVER=$(usex dedicated "1" "$(buildit server)") \
+ USE_SDL=$(buildit sdl) \
+ USE_OPENAL=$(buildit openal) \
+ USE_CURL=$(buildit curl) \
+ USE_CODEC_VORBIS=$(buildit vorbis) \
+ USE_LOCAL_HEADERS=0 \
+ Q="" \
+ $(usex debug "debug" "release")
+}
+
+src_install() {
+ local my_arch=$(usex amd64 "x86_64" "i386")
+
+ doicon -s scalable "${DISTDIR}"/${PN}.svg
+ dodoc ChangeLog README md4-readme.txt "${S_DATA}"/q3ut4/readme42.txt
+ insinto "${GAMES_DATADIR}"/${PN}/q3ut4
+ doins "${S_DATA}"/q3ut4/*.pk3
+ doins "${S_UPDATE}"/*.pk3
+
+ if use !dedicated ; then
+ newgamesbin build/$(usex debug "debug" "release")-linux-${my_arch}/Quake3-UrT$(usex smp "-smp" "").${my_arch} ${PN}
+ make_desktop_entry ${PN} "UrbanTerror"
+ fi
+
+ if use dedicated || use server ; then
+ newgamesbin build/$(usex debug "debug" "release")-linux-${my_arch}/Quake3-UrT-Ded.${my_arch} ${PN}-dedicated
+ docinto examples
+ dodoc "${S_DATA}"/q3ut4/{server.cfg,mapcycle.txt}
+ fi
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+
+ if use openal && ! use dedicated ; then
+ einfo
+ elog "You might need to set:"
+ elog " seta s_useopenal \"1\""
+ elog "in your ~/.q3a/q3ut4/q3config.cfg for openal to work."
+ einfo
+ fi
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}