summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-08-11 02:38:47 +0000
committerMike Frysinger <vapier@gentoo.org>2006-08-11 02:38:47 +0000
commit29df0a16f5dfe1cc82e0e29177cb1a0750d01c03 (patch)
treed6310dd399a0ab765a282f14fbeb5c0e45a850b1 /games-fps
parentmake sure quake1-demodata is installed first (diff)
downloadgentoo-2-29df0a16f5dfe1cc82e0e29177cb1a0750d01c03.tar.gz
gentoo-2-29df0a16f5dfe1cc82e0e29177cb1a0750d01c03.tar.bz2
gentoo-2-29df0a16f5dfe1cc82e0e29177cb1a0750d01c03.zip
Add support for newer Quake cds #142207 by Joe Quanaim.
(Portage version: 2.1.1_pre4)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/quake1-data/ChangeLog5
-rw-r--r--games-fps/quake1-data/quake1-data-2.40.ebuild18
2 files changed, 17 insertions, 6 deletions
diff --git a/games-fps/quake1-data/ChangeLog b/games-fps/quake1-data/ChangeLog
index b8a10082566d..b252c9b5aab0 100644
--- a/games-fps/quake1-data/ChangeLog
+++ b/games-fps/quake1-data/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-fps/quake1-data
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake1-data/ChangeLog,v 1.5 2006/06/27 19:54:48 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake1-data/ChangeLog,v 1.6 2006/08/11 02:38:47 vapier Exp $
+
+ 11 Aug 2006; Mike Frysinger <vapier@gentoo.org> quake1-data-2.40.ebuild:
+ Add support for newer Quake cds #142207 by Joe Quanaim.
27 Jun 2006; Chris Gianelloni <wolf31o2@gentoo.org>
quake1-data-2.40.ebuild:
diff --git a/games-fps/quake1-data/quake1-data-2.40.ebuild b/games-fps/quake1-data/quake1-data-2.40.ebuild
index 929d8bcd67a6..32d42b4dc9d3 100644
--- a/games-fps/quake1-data/quake1-data-2.40.ebuild
+++ b/games-fps/quake1-data/quake1-data-2.40.ebuild
@@ -1,6 +1,11 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake1-data/quake1-data-2.40.ebuild,v 1.10 2006/08/11 02:32:10 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake1-data/quake1-data-2.40.ebuild,v 1.11 2006/08/11 02:38:47 vapier Exp $
+
+# TODO: if installing off of the 1.01 cd, need to fetch the
+# quake shareware and use that pak0
+# http://linux.omnipotent.net/article.php?article_id=11287
+# ftp://ftp.cdrom.com/pub/idgames/idstuff/quake/quake106.zip
inherit eutils games
@@ -27,17 +32,20 @@ pkg_setup() {
die "Unmerge games-fps/quake1-demodata to remove the conflict"
fi
- export CDROM_NAME_SET=("Existing Install" "Quake CD" "Ultimate Quake Collection")
- cdrom_get_cds id1:q101_int.1:Setup/ID1
+ export CDROM_NAME_SET=("Existing Install" "Quake CD (1.01)" "Ultimate Quake Collection" "Quake CD (newer)")
+ cdrom_get_cds id1:q101_int.1:Setup/ID1:resource.1
}
src_unpack() {
- echo ">>> Unpacking q101_int to ${PWD}"
if [[ ${CDROM_SET} == "1" ]] ; then
+ echo ">>> Unpacking q101_int.lha to ${PWD}"
cat "${CDROM_ROOT}"/q101_int.1 "${CDROM_ROOT}"/q101_int.2 > \
"${S}"/q101_int.exe
lha xqf "${S}"/q101_int.exe || die "failure unpacking q101_int.exe"
rm -f q101_int.exe
+ elif [[ ${CDROM_SET} == "3" ]] ; then
+ echo ">>> Unpacking resource.1 to ${PWD}"
+ lha xqf "${CDROM_ROOT}"/resource.1 || die "failure unpacking resource.1"
fi
}
@@ -50,7 +58,7 @@ src_install() {
1) doins id1/* || die "doins pak files"
dodoc *.txt
;;
- 2) newins "${CDROM_ROOT}"/Setup/ID1/PAK0.PAK pak0.pak \
+ 2|3)newins "${CDROM_ROOT}"/Setup/ID1/PAK0.PAK pak0.pak \
|| die "ins pak0.pak failed"
newins "${CDROM_ROOT}"/Setup/ID1/PAK1.PAK pak1.pak \
|| die "ins pak1.pak failed"