summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-03-29 16:21:26 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-03-29 16:21:26 +0000
commit27138f50fc1d857cb28ecdaf4228f5d74cfbc19a (patch)
treebd76825d4f77aec8553d865d91548eff2de126fb /games-fps
parentsrc_unpack not needed explicitly anymore (diff)
downloadgentoo-2-27138f50fc1d857cb28ecdaf4228f5d74cfbc19a.tar.gz
gentoo-2-27138f50fc1d857cb28ecdaf4228f5d74cfbc19a.tar.bz2
gentoo-2-27138f50fc1d857cb28ecdaf4228f5d74cfbc19a.zip
use unpack_zip from unpacker.eclass instead of unzip
(Portage version: 2.2.0_alpha169/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/ut2004-hamsterbash/ChangeLog8
-rw-r--r--games-fps/ut2004-hamsterbash/ut2004-hamsterbash-1.ebuild10
2 files changed, 8 insertions, 10 deletions
diff --git a/games-fps/ut2004-hamsterbash/ChangeLog b/games-fps/ut2004-hamsterbash/ChangeLog
index 734b70080cf7..faefc6eca945 100644
--- a/games-fps/ut2004-hamsterbash/ChangeLog
+++ b/games-fps/ut2004-hamsterbash/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-fps/ut2004-hamsterbash
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004-hamsterbash/ChangeLog,v 1.3 2009/10/08 18:33:16 nyhm Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004-hamsterbash/ChangeLog,v 1.4 2013/03/29 16:21:26 hasufell Exp $
+
+ 29 Mar 2013; Julian Ospald <hasufell@gentoo.org> ut2004-hamsterbash-1.ebuild:
+ use unpack_zip from unpacker.eclass instead of unzip
08 Oct 2009; Tristan Heaven <nyhm@gentoo.org> ut2004-hamsterbash-1.ebuild:
EAPI=2
@@ -14,4 +17,3 @@
+ut2004-hamsterbash-1.ebuild:
Initial import. Original ebuild by Paul Bredbury <brebs@sent.com> and ported
to the games-mods eclass by me. Closing bug #118838.
-
diff --git a/games-fps/ut2004-hamsterbash/ut2004-hamsterbash-1.ebuild b/games-fps/ut2004-hamsterbash/ut2004-hamsterbash-1.ebuild
index 4de1acacbc36..cd14bdc5be8b 100644
--- a/games-fps/ut2004-hamsterbash/ut2004-hamsterbash-1.ebuild
+++ b/games-fps/ut2004-hamsterbash/ut2004-hamsterbash-1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004-hamsterbash/ut2004-hamsterbash-1.ebuild,v 1.3 2009/10/08 18:33:16 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004-hamsterbash/ut2004-hamsterbash-1.ebuild,v 1.4 2013/03/29 16:21:26 hasufell Exp $
EAPI=2
@@ -8,7 +8,7 @@ MOD_DESC="Cute and violent hamster cage rampage mod"
MOD_NAME="Hamster Bash"
MOD_DIR="hamsterbash"
-inherit games games-mods
+inherit unpacker games games-mods
HOMEPAGE="http://www.eigensoft.com/hamsterbash.htm"
SRC_URI="http://server088.eigensoft.com/HamsterBashFinal.zip"
@@ -17,10 +17,6 @@ LICENSE="freedist"
KEYWORDS="~amd64 ~x86"
IUSE="dedicated opengl"
-src_unpack() {
- unzip "${DISTDIR}"/${A} # unpack fails
-}
-
src_prepare() {
mv -f HamsterBash ${MOD_DIR} || die
rm -rf System