summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-31 05:12:44 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-31 05:12:44 +0000
commit1fd4cf4d6ea1baf494700983e181aeda73e74473 (patch)
tree98a32ff19393e8ad9b27c39664b6dde7b6a5e769 /games-fps
parentfix sed DEPEND #44817 (Manifest recommit) (diff)
downloadgentoo-2-1fd4cf4d6ea1baf494700983e181aeda73e74473.tar.gz
gentoo-2-1fd4cf4d6ea1baf494700983e181aeda73e74473.tar.bz2
gentoo-2-1fd4cf4d6ea1baf494700983e181aeda73e74473.zip
old
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/doomlegacy/doomlegacy-1.41-r1.ebuild113
-rw-r--r--games-fps/doomlegacy/files/1.41-errno.patch30
-rw-r--r--games-fps/doomlegacy/files/1.41-makefile.patch105
-rw-r--r--games-fps/doomlegacy/files/digest-doomlegacy-1.41-r13
-rw-r--r--games-fps/duke3d/duke3d-20030817-r1.ebuild110
-rw-r--r--games-fps/duke3d/files/20030817-buildengine-makefile-cflags.patch13
-rw-r--r--games-fps/duke3d/files/20030817-credits.patch38
-rw-r--r--games-fps/duke3d/files/20030817-duke3d-makefile-opts.patch33
8 files changed, 0 insertions, 445 deletions
diff --git a/games-fps/doomlegacy/doomlegacy-1.41-r1.ebuild b/games-fps/doomlegacy/doomlegacy-1.41-r1.ebuild
deleted file mode 100644
index 7038ba3d0f37..000000000000
--- a/games-fps/doomlegacy/doomlegacy-1.41-r1.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/doomlegacy/doomlegacy-1.41-r1.ebuild,v 1.6 2004/06/24 22:41:23 agriffis Exp $
-
-inherit eutils games
-
-DESCRIPTION="Doom legacy, THE doom port"
-HOMEPAGE="http://legacy.newdoom.com/"
-SRC_URI="mirror://sourceforge/doomlegacy/legacy_${PV/./}_src.tar.gz
- mirror://gentoo/legacy-${PV}.dat.bz2
- http://www.lbjhs.net/~jessh/lsdldoom/doom1.wad.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 ppc"
-IUSE="sdl X dga esd"
-
-RDEPEND="
- virtual/opengl
- virtual/x11
- esd? ( media-sound/esound )
- sdl? (
- media-libs/libsdl
- media-libs/sdl-mixer
- )"
-DEPEND="${RDEPEND}
- x86? ( >=dev-lang/nasm-0.98 )
- >=sys-apps/sed-4"
-
-S="${WORKDIR}/legacy_${PV//.}_src"
-
-src_unpack() {
- unpack ${A}
- mkdir bin
- cd ${S}
- epatch ${FILESDIR}/${PV}-errno.patch
- epatch ${FILESDIR}/${PV}-makefile.patch
-
- # disable logfile writing
- sed -i \
- -e 's:#define LOGMESSAGES::' doomdef.h \
- || die 'sed doomdef.h failed'
-
- # make sure the games can find the wads/data files
- sed -i \
- -e "/#define DEFAULTWADLOCATION1/s:\".*\":\"${GAMES_DATADIR}/${PN}\":" \
- linux_x/i_system.c \
- || die "sed linux_x/i_system.c failed"
-
- # move opengl lib file because it's not useful to anyone else
- sed -i \
- -e "s:\"r_opengl:\"${GAMES_LIBDIR}/${PN}/r_opengl:" \
- linux_x/i_video_xshm.c \
- || die "sed linux_x/i_video_xshm.c failed"
-
- cd linux_x/musserv
- make -f Makefile.linux clean
-}
-
-src_compile() {
- # this is ugly but it's late (here) and it works
- local makeopts=""
- local redosnd=0
- local interfaces=""
- use sdl && interfaces="${interfaces} SDL"
- use X && interfaces="${interfaces} X"
- [ -z "${interfaces}" ] && interfaces="X"
- mkdir ${WORKDIR}/my-bins
- for i in ${interfaces} ; do
- redosnd=0
- case ${i} in
- SDL)
- makeopts="SDL=1";;
- X)
- makeopts="LINUX=1 X=1"
- use x86 && makeopts="${makeopts} USEASM=1"
- use dga && makeopts="${makeopts} WITH_DGA=1"
- use esd && makeopts="${makeopts} HAVE_ESD=1";;
- esac
- emake EXTRAOPTS="${CFLAGS}" ${makeopts} || redosnd=1
- if [ ${redosnd} -eq 1 ] ; then
- cd linux_x/sndserv
- emake clean || die "clean snd srv failed"
- emake EXTRAOPTS="${CFLAGS}" || die "snd serv failed"
- fi
- cd ${S}
- emake EXTRAOPTS="${CFLAGS}" ${makeopts} || die "build failed"
- mv \
- ${WORKDIR}/bin/* \
- linux_x/musserv/linux/musserver \
- linux_x/sndserv/linux/llsndserv \
- ${WORKDIR}/my-bins/
- rm ${WORKDIR}/objs/*
- done
-}
-
-src_install() {
- dohtml _doc/*.html
- rm _doc/*.html
- dodoc _doc/*
-
- cd ${WORKDIR}
- exeinto ${GAMES_LIBDIR}/${PN}
- doexe my-bins/r_opengl.so
- rm my-bins/r_opengl.so
- dogamesbin my-bins/*
-
- insinto ${GAMES_DATADIR}/${PN}
- doins doom1.wad
- newins legacy-${PV}.dat legacy.dat
-
- prepgamesdirs
-}
diff --git a/games-fps/doomlegacy/files/1.41-errno.patch b/games-fps/doomlegacy/files/1.41-errno.patch
deleted file mode 100644
index c9aa3c6ffef0..000000000000
--- a/games-fps/doomlegacy/files/1.41-errno.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-diff -ur legacy_141_src.orig/linux_x/i_video_xshm.c legacy_141_src/linux_x/i_video_xshm.c
---- legacy_141_src.orig/linux_x/i_video_xshm.c 2003-10-11 00:28:13.262502728 -0400
-+++ legacy_141_src/linux_x/i_video_xshm.c 2003-10-11 00:29:16.525885232 -0400
-@@ -1561,7 +1561,6 @@
- id = shmget((key_t) key, size, IPC_CREAT | 0777);
- if (id == -1)
- {
-- extern int errno;
- fprintf(stderr, "errno=%d\n", errno);
- I_Error("Could not get any shared memory");
- }
-diff -ur legacy_141_src.orig/linux_x/sndserv/linux.c legacy_141_src/linux_x/sndserv/linux.c
---- legacy_141_src.orig/linux_x/sndserv/linux.c 2003-10-11 00:28:13.264502424 -0400
-+++ legacy_141_src/linux_x/sndserv/linux.c 2003-10-11 00:28:40.480364984 -0400
-@@ -42,6 +42,7 @@
- //
- //-----------------------------------------------------------------------------
-
-+#include <errno.h>
- #include <stdlib.h>
- #include <stdio.h>
- #include <fcntl.h>
-@@ -68,7 +69,6 @@
- void myioctl(int fd, int command, int *arg)
- {
- int rc;
-- extern int errno;
-
- rc = ioctl(fd, command, arg);
- if (rc < 0)
diff --git a/games-fps/doomlegacy/files/1.41-makefile.patch b/games-fps/doomlegacy/files/1.41-makefile.patch
deleted file mode 100644
index c48890f4af15..000000000000
--- a/games-fps/doomlegacy/files/1.41-makefile.patch
+++ /dev/null
@@ -1,105 +0,0 @@
---- makefile.orig 2003-10-11 00:47:50.326561792 -0400
-+++ makefile 2003-10-11 00:50:16.859285432 -0400
-@@ -533,11 +533,11 @@
-
- ifndef SOLARIS
- ifdef GCC30
-- M5=-march=pentium
-- M4=-march=486
-+ M5=
-+ M4=
- else
-- M5=-mpentium
-- M4=-m486
-+ M5=
-+ M4=
- endif
- endif
-
-@@ -547,7 +547,7 @@
- ifdef PGCC
- CFLAGS = -g -pg -DPARANOIA -fwritable-strings $(OPTS)
- else
-- CFLAGS = -g -pg $(M4) -O3 -ffast-math -fwritable-strings $(OPTS)
-+ CFLAGS = -g -pg $(M4) $(OPTS) $(EXTRAOPTS)
- endif
- LDFLAGS = -g -pg -L/usr/X11R6/lib
- else
-@@ -555,13 +555,13 @@
-
- # build a normal optimised version
- ifdef PGCC
-- CFLAGS = $(OPTS) $(M5) -O6 -ffast-math -fomit-frame-pointer -fwritable-strings
-+ CFLAGS = $(OPTS) $(M5) -fwritable-strings $(EXTRAOPTS)
- # -fgcse -fcse-follow-jumps -fcse-skip-blocks -frerun-cse-after-loop -ffunction-cse \
- # -fexpensive-optimizations -fforce-mem -fstrength-reduce -fthread-jumps \
- # -fregmove -fschedule-insns -fschedule-insns2 -fmove-all-movables \
- # -fcaller-saves -finline-functions -mieee-fp -mfp-ret-in-387 -m80387 -mhard-float -finline
- else
-- CFLAGS = $(M4) -O3 -ffast-math -fomit-frame-pointer -fwritable-strings $(OPTS)
-+ CFLAGS = $(M4) -fwritable-strings $(OPTS) $(EXTRAOPTS)
- endif
- endif
-
-@@ -735,7 +735,7 @@
-
- #dll
- dll : $(O)/r_opengl.o $(O)/ogl_x11.o
-- $(CC) $(M5) -O6 -o $(BIN)/r_opengl.so -shared -nostartfiles $(O)/r_opengl.o $(O)/ogl_x11.o -L/usr/X11R6/lib -L/usr/local/lib -lX11 -lXext -lGL -lGLU -lm
-+ $(CC) $(M5) -o $(BIN)/r_opengl.so -shared -nostartfiles $(O)/r_opengl.o $(O)/ogl_x11.o -L/usr/X11R6/lib -L/usr/local/lib -lX11 -lXext -lGL -lGLU -lm
-
- musserv:
- @mkdir -p $(MUSSERV)/linux
-@@ -749,7 +749,7 @@
-
- ifdef LINUX
- $(O)/r_opengl.o: hardware/r_opengl/r_opengl.c hardware/r_opengl/r_opengl.h
-- $(CC) $(M5) -O6 -o $(O)/r_opengl.o -DHWRENDER -DVID_X11 -DLINUX $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/r_opengl.c
-+ $(CC) $(M5) -o $(O)/r_opengl.o -DHWRENDER -DVID_X11 -DLINUX $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/r_opengl.c
- endif
-
- ifdef SDL
-@@ -763,7 +763,7 @@
- $(CC) $(CFLAGS) $(LDFLAGS) $(WFLAGS) -I/usr/X11R6/include -c $< -o $@
- else #FBSD_SDL
- $(O)/r_opengl.o: hardware/r_opengl/r_opengl.c hardware/r_opengl/r_opengl.h
-- $(CC) $(M5) -O6 -o $(O)/r_opengl.o -DHWRENDER -DVID_X11 -DLINUX -DFREEBSD $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/r_opengl.c
-+ $(CC) $(M5) -o $(O)/r_opengl.o -DHWRENDER -DVID_X11 -DLINUX -DFREEBSD $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/r_opengl.c
- endif #FBSD_SDL
- endif #FREEBSD
-
-@@ -774,10 +774,10 @@
-
- ifndef FREEBSD
- $(O)/ogl_x11.o: hardware/r_opengl/ogl_x11.c hardware/r_opengl/r_opengl.h
-- $(CC) $(M5) -O6 -o $(O)/ogl_x11.o -DHWRENDER -DVID_X11 -DLINUX $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/ogl_x11.c
-+ $(CC) $(M5) -o $(O)/ogl_x11.o -DHWRENDER -DVID_X11 -DLINUX $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/ogl_x11.c
- else
- $(O)/ogl_x11.o: hardware/r_opengl/ogl_x11.c hardware/r_opengl/r_opengl.h
-- $(CC) $(M5) -O6 -o $(O)/ogl_x11.o -DHWRENDER -DVID_X11 -DLINUX -DFREEBSD $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/ogl_x11.c
-+ $(CC) $(M5) -o $(O)/ogl_x11.o -DHWRENDER -DVID_X11 -DLINUX -DFREEBSD $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/ogl_x11.c
- endif
-
-
---- linux_x/musserv/Makefile.linux.orig 2003-10-11 00:51:31.193984840 -0400
-+++ linux_x/musserv/Makefile.linux 2003-10-11 00:51:36.756139264 -0400
-@@ -3,7 +3,7 @@
- #
-
- CC = gcc
--CFLAGS = -I. -Wall -O2 -m486
-+CFLAGS = -I. -Wall $(EXTRAOPTS)
- LDFLAGS =
- #LDFLAGS = -static
-
---- linux_x/sndserv/Makefile.orig 2003-10-11 00:50:41.640518112 -0400
-+++ linux_x/sndserv/Makefile 2003-10-11 00:50:58.250992936 -0400
-@@ -30,7 +30,7 @@
- #
-
- CC=gcc
--CFLAGS=-O2 -m486 -Wall -DNORMALUNIX -DLINUX
-+CFLAGS=$(EXTRAOPTS) -Wall -DNORMALUNIX -DLINUX
- ifdef FREEBSD
- CFLAGS:=${CFLAGS} -DFREEBSD
- endif
diff --git a/games-fps/doomlegacy/files/digest-doomlegacy-1.41-r1 b/games-fps/doomlegacy/files/digest-doomlegacy-1.41-r1
deleted file mode 100644
index 504a132d5375..000000000000
--- a/games-fps/doomlegacy/files/digest-doomlegacy-1.41-r1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 4e64cb19e0e57055e664bdf09bce14d2 legacy_141_src.tar.gz 1600679
-MD5 03aad1e378ea16cad26c59c63c28c2eb legacy-1.41.dat.bz2 314470
-MD5 66851d7cecbc7845d612e7073c1355ad doom1.wad.gz 1765820
diff --git a/games-fps/duke3d/duke3d-20030817-r1.ebuild b/games-fps/duke3d/duke3d-20030817-r1.ebuild
deleted file mode 100644
index 3d3de736ffe5..000000000000
--- a/games-fps/duke3d/duke3d-20030817-r1.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/duke3d/duke3d-20030817-r1.ebuild,v 1.17 2004/07/14 14:43:54 agriffis Exp $
-
-ECVS_PASS="anonymous"
-ECVS_SERVER="icculus.org:/cvs/cvsroot"
-ECVS_MODULE="duke3d"
-inherit eutils flag-o-matic games
-#inherit cvs
-
-DESCRIPTION="port of the original DukeNukem 3D"
-HOMEPAGE="http://icculus.org/projects/duke3d/"
-SRC_URI="mirror://gentoo/${P}.tbz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 ppc"
-IUSE="opengl" # nophysfs"
-
-RDEPEND="virtual/x11
- media-libs/libsdl
- media-libs/sdl-mixer
- media-sound/timidity++
- media-sound/timidity-eawpatches
- opengl? ( virtual/opengl )"
-DEPEND="${RDEPEND}
- x86? ( dev-lang/nasm )
- >=sys-apps/sed-4"
-
-S="${WORKDIR}/${ECVS_MODULE}"
-
-use_tf() { use ${1} > /dev/null && echo "true" || echo "false"; }
-
-src_unpack() {
- local fromcvs=0
- if [ ${fromcvs} -eq 1 ] ; then
- cvs_src_unpack
- cd duke3d/source
- ECVS_MODULE="buildengine"
- cvs_src_unpack
- else
- unpack ${A}
- fi
-
- # configure buildengine
- cd ${S}/source/buildengine
- sed -i \
- -e "/^useperl := / s:=.*:= $(use_tf perl):" \
- -e "/^useopengl := / s:=.*:= $(use_tf opengl):" \
- -e "/^usephysfs := / s:=.*:= false:" Makefile \
- || die "sed Makefile failed"
- if use x86 ; then
- sed -i \
- -e 's:^#USE_ASM:USE_ASM:' Makefile \
- || die "sed Makefile failed (x86)"
- fi
- epatch "${FILESDIR}/${PV}-buildengine-makefile-cflags.patch"
- sed -i \
- -e 's:/usr/lib/perl5/i386-linux/CORE/libperl.a::' Makefile \
- || die "sed Makefile failed (libperl)"
-
- # configure duke3d
- cd ${S}/source
- epatch "${FILESDIR}/${PV}-credits.patch"
- epatch "${FILESDIR}/${PV}-duke3d-makefile-opts.patch"
- if use x86 ; then
- sed -i \
- -e '/^#use_asm/s:#::' Makefile \
- || die "sed Makefile failed"
- fi
- if use opengl ; then
- sed -i \
- -e '/^#use_opengl/s:#::' Makefile \
- || die "sed Makefile failed"
- fi
-}
-
-src_compile() {
- # -O3 fails on athlon with gcc 3.2.3, maybe others.
- replace-flags "-O3" "-O2"
- cd source/buildengine
- emake OPTFLAGS="${CFLAGS}" || die "buildengine failed"
- cd ..
- emake OPTIMIZE="${CFLAGS}" || die "duke3d failed"
-}
-
-src_install() {
- games_make_wrapper duke3d "${GAMES_BINDIR}/duke3d.bin" "${GAMES_DATADIR}/${PN}"
- newgamesbin source/duke3d duke3d.bin || die "newgamesbin failed"
-
- dodoc readme.txt
-
- cd testdata
- insinto "${GAMES_DATADIR}/${PN}"
- newins defs.con DEFS.CON
- newins game.con GAME.CON
- newins user.con USER.CON
- doins "${FILESDIR}/network.cfg"
- insinto "${GAMES_SYSCONFDIR}"
- doins "${FILESDIR}/duke3d.cfg"
- dosym "${GAMES_SYSCONFDIR}/duke3d.cfg" "${GAMES_DATADIR}/${PN}/DUKE3D.CFG"
-
- prepgamesdirs
-}
-
-pkg_postinst() {
- games_pkg_postinst
- einfo "Just put the data files in ${GAMES_DATADIR}/${PN}"
- einfo "before playing !"
-}
diff --git a/games-fps/duke3d/files/20030817-buildengine-makefile-cflags.patch b/games-fps/duke3d/files/20030817-buildengine-makefile-cflags.patch
deleted file mode 100644
index b8a8434bf1a6..000000000000
--- a/games-fps/duke3d/files/20030817-buildengine-makefile-cflags.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- Makefile.orig 2003-08-17 17:03:30.643555488 -0400
-+++ Makefile 2003-08-17 17:03:50.415549688 -0400
-@@ -195,8 +195,8 @@
- ENGINEDIR = .
- ASMFLAGS = -f $(ASMOBJFMT) $(ASMDEFS)
- LINKER = gcc
--CFLAGS += $(USE_ASM) -funsigned-char -O2 -DPLATFORM_UNIX -g -Wall $(SDL_CFLAGS) -fno-omit-frame-pointer
--LDFLAGS += -g $(SDL_LDFLAGS)
-+CFLAGS += $(USE_ASM) $(OPTFLAGS) -funsigned-char -DPLATFORM_UNIX -Wall $(SDL_CFLAGS) -fno-omit-frame-pointer
-+LDFLAGS += $(SDL_LDFLAGS)
-
- # Rules for turning source files into .o files
- %.o: %.c
diff --git a/games-fps/duke3d/files/20030817-credits.patch b/games-fps/duke3d/files/20030817-credits.patch
deleted file mode 100644
index 5aea61558395..000000000000
--- a/games-fps/duke3d/files/20030817-credits.patch
+++ /dev/null
@@ -1,38 +0,0 @@
---- menues.c 2003-08-17 22:16:10.000000000 +0200
-+++ menues.c 2004-03-29 01:59:28.000000000 +0200
-@@ -1747,9 +1747,10 @@
- case 996:
- case 997:
-
--// rotatesprite(c<<16,200<<15,65536L,0,MENUSCREEN,16,0,10+64,0,0,xdim-1,ydim-1);
--// rotatesprite(c<<16,19<<16,65536L,0,MENUBAR,16,0,10,0,0,xdim-1,ydim-1);
--// menutext(c,24,0,0,"CREDITS");
-+ c = (320>>1);
-+ rotatesprite(c<<16,200<<15,65536L,0,MENUSCREEN,16,0,10+64,0,0,xdim-1,ydim-1);
-+ rotatesprite(c<<16,19<<16,65536L,0,MENUBAR,16,0,10,0,0,xdim-1,ydim-1);
-+ menutext(c,24,0,0,"CREDITS");
-
- if(KB_KeyPressed(sc_Escape)) { cmenu(0); break; }
-
-@@ -1926,6 +1927,21 @@
-
- menutext(c,67+16+16+16+16+16,SHX(-7),PHX(-7),"QUIT");
-
-+ gametext(c,67+16+16+16+16+16+16+16,"Duke Nukem 3D for "
-+#if defined PLATFORM_MACOSX
-+ "MacOS"
-+#elif defined PLATFORM_DOS
-+ "MS-Dos"
-+#elif defined PLATFORM_WIN32
-+ "Win32"
-+#elif defined PLATFORM_UNIX
-+ "Gentoo Linux"
-+#else
-+ "unknown"
-+#endif
-+ ,16,2+8+16);
-+ gametext(c,67+16+16+16+16+16+16+16+9,"build " __DATE__ " " __TIME__,16,2+8+16);
-+
- break;
- // CTW END - MODIFICATION
-
diff --git a/games-fps/duke3d/files/20030817-duke3d-makefile-opts.patch b/games-fps/duke3d/files/20030817-duke3d-makefile-opts.patch
deleted file mode 100644
index 6f961a11eb27..000000000000
--- a/games-fps/duke3d/files/20030817-duke3d-makefile-opts.patch
+++ /dev/null
@@ -1,33 +0,0 @@
---- Makefile.orig 2003-08-17 17:45:35.948650760 -0400
-+++ Makefile 2003-08-17 17:46:36.894385600 -0400
-@@ -4,6 +4,8 @@
- beos := false
- macosx := false
- #use_asm := true
-+#use_opengl := true
-+#use_physfs := true
-
- #-----------------------------------------------------------------------------#
- # If this makefile fails to detect Cygwin correctly, or you want to force
-@@ -80,6 +81,10 @@
- buildengine/pragmas.o \
- buildengine/unix_compat.o
-
-+ifeq ($(strip $(use_opengl)),true)
-+ BUILDOBJS += buildengine/buildgl.o
-+endif
-+
- ifeq ($(strip $(use_asm)),true)
- BUILDOBJS += buildengine/a_gnu.o buildengine/a_nasm.o
- else
-@@ -106,6 +106,10 @@
-
- LDLIBS = $(SDL_LDFLAGS) -lSDL -lSDL_mixer $(EXTRALDFLAGS)
-
-+ifeq ($(strip $(use_physfs)),true)
-+ LDLIBS += -lphysfs
-+endif
-+
- # !!! FIXME: Do we even need this? It doesn't fly on MacOS X. --ryan.
- #LDLIBS += -Wl,-E
-