summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-09-18 03:26:32 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-09-18 03:26:32 +0000
commit0e365f5c3402aa8239e67f634770b3ae1cffcc9a (patch)
tree62e164e6393fd3cb508c14509bc45d2007dd23d6 /games-fps
parentAdded ~sparc keyword. (diff)
downloadgentoo-2-0e365f5c3402aa8239e67f634770b3ae1cffcc9a.tar.gz
gentoo-2-0e365f5c3402aa8239e67f634770b3ae1cffcc9a.tar.bz2
gentoo-2-0e365f5c3402aa8239e67f634770b3ae1cffcc9a.zip
initial commit - ebuild submitted by fabien Zouaoui via bug #94764
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/nexuiz/ChangeLog10
-rw-r--r--games-fps/nexuiz/Manifest2
-rw-r--r--games-fps/nexuiz/files/digest-nexuiz-1.2.11
-rw-r--r--games-fps/nexuiz/metadata.xml5
-rw-r--r--games-fps/nexuiz/nexuiz-1.2.1.ebuild92
5 files changed, 110 insertions, 0 deletions
diff --git a/games-fps/nexuiz/ChangeLog b/games-fps/nexuiz/ChangeLog
new file mode 100644
index 000000000000..3db0df24b269
--- /dev/null
+++ b/games-fps/nexuiz/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-fps/nexuiz
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/nexuiz/ChangeLog,v 1.1 2005/09/18 03:26:32 mr_bones_ Exp $
+
+*nexuiz-1.2.1 (18 Sep 2005)
+
+ 18 Sep 2005; Michael Sterrett <mr_bones_@gentoo.org> +metadata.xml,
+ +nexuiz-1.2.1.ebuild:
+ initial commit - ebuild submitted by fabien Zouaoui via bug #94764
+
diff --git a/games-fps/nexuiz/Manifest b/games-fps/nexuiz/Manifest
new file mode 100644
index 000000000000..1ba5d4819930
--- /dev/null
+++ b/games-fps/nexuiz/Manifest
@@ -0,0 +1,2 @@
+MD5 1ddd50c3f1d5f68bedd08cd50f14d51d nexuiz-1.2.1.ebuild 2059
+MD5 33383983267ad2c04687135876d5dbfb files/digest-nexuiz-1.2.1 61
diff --git a/games-fps/nexuiz/files/digest-nexuiz-1.2.1 b/games-fps/nexuiz/files/digest-nexuiz-1.2.1
new file mode 100644
index 000000000000..07affde7cdb0
--- /dev/null
+++ b/games-fps/nexuiz/files/digest-nexuiz-1.2.1
@@ -0,0 +1 @@
+MD5 d5f31c9e1199abbe3a89ea9bf6b7515e nexuiz121.zip 171720620
diff --git a/games-fps/nexuiz/metadata.xml b/games-fps/nexuiz/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-fps/nexuiz/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-fps/nexuiz/nexuiz-1.2.1.ebuild b/games-fps/nexuiz/nexuiz-1.2.1.ebuild
new file mode 100644
index 000000000000..bf315f0a2298
--- /dev/null
+++ b/games-fps/nexuiz/nexuiz-1.2.1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/nexuiz/nexuiz-1.2.1.ebuild,v 1.1 2005/09/18 03:26:32 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="a free deathmatch FPS based on the Quake I engine"
+HOMEPAGE="http://www.nexuiz.com"
+SRC_URI="mirror://sourceforge/${PN}/${PN}${PV//./}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="dedicated sdl"
+
+RDEPEND="virtual/opengl
+ sdl? ( media-libs/libsdl )
+ media-libs/libogg
+ media-libs/libvorbis
+ media-libs/jpeg
+ media-libs/alsa-lib
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ app-arch/unzip"
+
+S=${WORKDIR}/${PN/n/N}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ unzip $(ls nexuizenginesource* | head -n 1)
+
+ cd darkplaces
+ sed -i \
+ -e "/strcpy(fs_basedir/s:\.:${GAMES_DATADIR}/${PN}:" \
+ fs.c \
+ || die "sed failed"
+
+ sed -i \
+ -e '/^CC/d' \
+ -e "s:-lasound:$(pkg-config --libs alsa):" \
+ -e 's:darkplaces-sdl:nexuiz-sdl:' \
+ -e 's:darkplaces-glx:nexuiz-glx:' \
+ -e 's:darkplaces-dedicated:nexuiz-dedicated:' \
+ makefile.inc \
+ || die "sed failed"
+}
+
+src_compile() {
+ cd darkplaces
+
+ emake cl-release \
+ CFLAGS_RELEASE="" OPTIM_RELEASE="" \
+ CFLAGS_COMMON="${CFLAGS}" \
+ || die "emake cl-release failed"
+
+ if use sdl; then
+ emake sdl-release \
+ CFLAGS_RELEASE="" OPTIM_RELEASE="" \
+ CFLAGS_COMMON="${CFLAGS}" \
+ || die "emake sdl-release failed"
+ fi
+
+ if use dedicated; then
+ emake sv-release \
+ CFLAGS_RELEASE="" OPTIM_RELEASE="" \
+ CFLAGS_COMMON="${CFLAGS}" \
+ || die "emake dedicated failed"
+ fi
+}
+
+src_install() {
+ dogamesbin darkplaces/nexuiz-glx || die "dogamesbin failed"
+ if use sdl; then
+ dogamesbin darkplaces/nexuiz-sdl || die "dogamesbin failed"
+ fi
+ if use dedicated; then
+ dogamesbin darkplaces/nexuiz-dedicated || die "dogamesbin failed"
+ fi
+
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r data/ || die "doins failed"
+ newicon darkplaces/darkplaces72x72.png ${PN}.png
+
+ if use sdl; then
+ make_desktop_entry nexuiz-sdl "Nexuiz" ${PN}.png
+ else
+ make_desktop_entry nexuiz-glx "Nexuiz" ${PN}.png
+ fi
+ prepgamesdirs
+}