summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-01-20 01:20:27 +0000
committerMike Frysinger <vapier@gentoo.org>2006-01-20 01:20:27 +0000
commit0add213907fa346cea924d19cbd8c0bd4e5de5c7 (patch)
tree76784bd6e9f4ff1675cfb5fca879abcb92325e9c /games-fps
parentold (diff)
downloadgentoo-2-0add213907fa346cea924d19cbd8c0bd4e5de5c7.tar.gz
gentoo-2-0add213907fa346cea924d19cbd8c0bd4e5de5c7.tar.bz2
gentoo-2-0add213907fa346cea924d19cbd8c0bd4e5de5c7.zip
svn version
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/quake3/files/digest-quake3-99990
-rw-r--r--games-fps/quake3/quake3-9999.ebuild113
2 files changed, 113 insertions, 0 deletions
diff --git a/games-fps/quake3/files/digest-quake3-9999 b/games-fps/quake3/files/digest-quake3-9999
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/games-fps/quake3/files/digest-quake3-9999
diff --git a/games-fps/quake3/quake3-9999.ebuild b/games-fps/quake3/quake3-9999.ebuild
new file mode 100644
index 000000000000..f54b4b9b858f
--- /dev/null
+++ b/games-fps/quake3/quake3-9999.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/quake3-9999.ebuild,v 1.1 2006/01/20 01:20:27 vapier Exp $
+
+# quake3-9999 -> latest svn
+# quake3-9999.REV -> use svn REV
+# quake3-VER_alphaREV -> svn snapshot REV for version VER
+# quake3-VER -> normal quake release
+
+if [[ ${PV} == 9999* ]] ; then
+ [[ ${PV} == 9999.* ]] && ESVN_UPDATE_CMD="svn up -r ${PV/9999.}"
+ ESVN_REPO_URI="svn://svn.icculus.org/quake3/trunk"
+ inherit subversion games toolchain-funcs
+
+ SRC_URI=""
+ S=${WORKDIR}/trunk
+elif [[ ${PV} == *_alpha* ]] ; then
+ inherit games toolchain-funcs
+
+ MY_PV=${PV/_alpha*}
+ SNAP=${PV/*_alpha}
+ MY_P=${PN}-${MY_PV}_SVN${SNAP}M
+ SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
+ S=${WORKDIR}/${MY_P}
+else
+ inherit games toolchain-funcs
+
+ SRC_URI="http://icculus.org/quake3/${P}.tar.bz2"
+fi
+
+DESCRIPTION="Quake III Arena - 3rd installment of the classic id 3D first-person shooter"
+HOMEPAGE="http://icculus.org/quake3/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-*"
+IUSE="dedicated opengl"
+
+RDEPEND="opengl? (
+ virtual/opengl
+ media-libs/openal
+ || (
+ (
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp )
+ virtual/x11 )
+ media-libs/libsdl )
+ !dedicated? (
+ virtual/opengl
+ || (
+ (
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp )
+ virtual/x11 )
+ media-libs/libsdl )
+ games-fps/quake3-data"
+
+src_unpack() {
+ if [[ ${PV} == 9999* ]] ; then
+ subversion_src_unpack
+ else
+ unpack ${A}
+ fi
+}
+
+src_compile() {
+ buildit() { use $1 && echo 1 || echo 0 ; }
+ emake \
+ BUILD_SERVER=$(buildit dedicated) \
+ BUILD_CLIENT=$(buildit opengl) \
+ TEMPDIR="${T}" \
+ CC="$(tc-getCC)" \
+ ARCH=$(tc-arch-kernel) \
+ OPTIMIZE="${CFLAGS}" \
+ DEFAULT_BASEDIR="${GAMES_DATADIR}/quake3" \
+ DEFAULT_LIBDIR="${GAMES_LIBDIR}/quake3" \
+ || die
+}
+
+src_install() {
+ dodoc id-readme.txt TODO README BUGS ChangeLog
+ cd code/unix
+ dodoc README.*
+
+ doicon quake3.xpm
+ make_desktop_entry quake3 "Quake III Arena" quake3.xpm
+
+ cd ../../build/release*
+ local old_x x
+ for old_x in ioquake3* ; do
+ x=${old_x%.*}
+ newgamesbin ${old_x} ${x} || die "dobin ${x}"
+ dosym ${x} "${GAMES_BINDIR}"/${x/io}
+ done
+ exeinto "${GAMES_LIBDIR}"/${PN}/baseq3
+ doexe baseq3/*.so || die "baseq3 .so"
+ exeinto "${GAMES_LIBDIR}"/${PN}/missionpack
+ doexe missionpack/*.so || die "missionpack .so"
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ ewarn "The source version of Quake 3 will not work with Punk Buster."
+ ewarn "If you need pb support, then use the quake3-bin package."
+ echo
+}