summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-03-22 16:03:14 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-03-22 16:03:14 +0000
commit01ea261fb86f5234dbba6f15500fd54cb9c4bd29 (patch)
tree6dab4f47003076b3ada861bb2da8dbbb2229bd0f /games-fps/wmquake/wmquake-1.1.ebuild
parent~hppa blessing (diff)
downloadgentoo-2-01ea261fb86f5234dbba6f15500fd54cb9c4bd29.tar.gz
gentoo-2-01ea261fb86f5234dbba6f15500fd54cb9c4bd29.tar.bz2
gentoo-2-01ea261fb86f5234dbba6f15500fd54cb9c4bd29.zip
fix DEPEND; use user CC instead of hard-coded gcc
(Portage version: 2.1_pre6-r5)
Diffstat (limited to 'games-fps/wmquake/wmquake-1.1.ebuild')
-rw-r--r--games-fps/wmquake/wmquake-1.1.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/games-fps/wmquake/wmquake-1.1.ebuild b/games-fps/wmquake/wmquake-1.1.ebuild
index ed0ff9590463..f2bfbbe58056 100644
--- a/games-fps/wmquake/wmquake-1.1.ebuild
+++ b/games-fps/wmquake/wmquake-1.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/wmquake/wmquake-1.1.ebuild,v 1.5 2005/11/05 22:46:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/wmquake/wmquake-1.1.ebuild,v 1.6 2006/03/22 16:03:14 mr_bones_ Exp $
inherit games
@@ -13,14 +13,13 @@ SLOT="0"
KEYWORDS="x86"
IUSE=""
-RDEPEND="virtual/x11"
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4"
+DEPEND="=x11-libs/gtk+-1.2*"
src_unpack() {
unpack ${A}
cd "${S}"
sed -i \
+ -e '/^CC/d' \
-e "s:CFLAGS = .*:CFLAGS = ${CFLAGS}:" Makefile \
|| die "sed Makefile failed"
}