summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-06-07 22:03:55 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-06-07 22:03:55 +0000
commit59546662d282fc516ae182a2c2c282c617c860a6 (patch)
tree0a29a2dcd6850eb0c0e415ddd35039c052e3b7fa /games-fps/warsow/files
parentAnother patch to fix bug #202561. (diff)
downloadgentoo-2-59546662d282fc516ae182a2c2c282c617c860a6.tar.gz
gentoo-2-59546662d282fc516ae182a2c2c282c617c860a6.tar.bz2
gentoo-2-59546662d282fc516ae182a2c2c282c617c860a6.zip
old
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-fps/warsow/files')
-rw-r--r--games-fps/warsow/files/warsow-0.3.2-build.patch37
-rw-r--r--games-fps/warsow/files/warsow-0.3.2-mapdl.patch11
2 files changed, 0 insertions, 48 deletions
diff --git a/games-fps/warsow/files/warsow-0.3.2-build.patch b/games-fps/warsow/files/warsow-0.3.2-build.patch
deleted file mode 100644
index 86510a42de7a..000000000000
--- a/games-fps/warsow/files/warsow-0.3.2-build.patch
+++ /dev/null
@@ -1,37 +0,0 @@
---- source/Makefile
-+++ source/Makefile
-@@ -100,9 +100,9 @@
- LOCALBASE?=/usr/local
- X11BASE?=/usr/X11R6
-
--CFLAGS_COMMON=$(CFLAGS) -I. -I$(LOCALBASE)/include -I$(X11BASE)/include -Wall
--CFLAGS_RELEASE=-O2 -fno-strict-aliasing -ffast-math -funroll-loops -DNDEBUG
--CFLAGS_DEBUG=-O0 -ggdb -D_DEBUG
-+CFLAGS_COMMON=$(CFLAGS) -I. -fno-strict-aliasing -Wall
-+CFLAGS_RELEASE=-DNDEBUG
-+CFLAGS_DEBUG=-D_DEBUG
- ifeq ($(DEBUG_BUILD),YES)
- CFLAGS_COMMON+=$(CFLAGS_DEBUG)
- else
-@@ -116,7 +116,7 @@
- ifeq ($(OS),FreeBSD)
- LDFLAGS_COMMON=-L/usr/local/lib -lm
- else
--LDFLAGS_COMMON=-L/usr/local/lib -ldl -lm
-+LDFLAGS_COMMON=$(LDFLAGS) -ldl -lm
- endif
-
- ifeq ($(ARCH),x86_64)
-@@ -287,10 +287,10 @@
-
- all: client openal qf ded cgame game ui irc
-
--client: $(BUILDDIRS) message-client compile-client link-client start-script-client
-+client: $(BUILDDIRS) message-client compile-client link-client
- openal: $(BUILDDIRS) message-openal compile-openal link-openal
- qf: $(BUILDDIRS) message-qf compile-qf link-qf
--ded: $(BUILDDIRS) message-ded compile-ded link-ded start-script-ded
-+ded: $(BUILDDIRS) message-ded compile-ded link-ded
- cgame: $(BUILDDIRS) message-cgame compile-cgame link-cgame
- game: $(BUILDDIRS) message-game compile-game link-game
- ui: $(BUILDDIRS) message-ui compile-ui link-ui
diff --git a/games-fps/warsow/files/warsow-0.3.2-mapdl.patch b/games-fps/warsow/files/warsow-0.3.2-mapdl.patch
deleted file mode 100644
index fcbe76597119..000000000000
--- a/games-fps/warsow/files/warsow-0.3.2-mapdl.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- warsow-0.32/warsow_0.32/source/qcommon/files.c 2007-08-07 17:47:31.000000000 +0200
-+++ warsow-0.32.fixed/warsow_0.32/source/qcommon/files.c 2007-09-27 04:42:09.000000000 +0200
-@@ -2277,7 +2277,7 @@
- if( !fullname )
- return qfalse;
-
-- pakfile = FS_LoadPK3File( filename, qtrue );
-+ pakfile = FS_LoadPK3File( fullname, qtrue );
- if( pakfile ) { // unlock and free, we don't need this file anyway
- if( pakfile->sysHandle )
- Sys_FS_UnlockFile( pakfile->sysHandle );