summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2004-05-20 20:39:15 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2004-05-20 20:39:15 +0000
commitdf6743b20f51442aaa4825c479b9d8c2bb82d682 (patch)
tree5a79ba3923e504d5a7fb6db24b82df46c6241313 /games-fps/ut2004
parentYeah, so it would be good not to remove the only stable version 0.91 (diff)
downloadgentoo-2-df6743b20f51442aaa4825c479b9d8c2bb82d682.tar.gz
gentoo-2-df6743b20f51442aaa4825c479b9d8c2bb82d682.tar.bz2
gentoo-2-df6743b20f51442aaa4825c479b9d8c2bb82d682.zip
Initial import. Ebuild by me.
Diffstat (limited to 'games-fps/ut2004')
-rw-r--r--games-fps/ut2004/ChangeLog10
-rw-r--r--games-fps/ut2004/Manifest3
-rw-r--r--games-fps/ut2004/files/digest-ut2004-32041
-rw-r--r--games-fps/ut2004/files/ut2004.xml7
-rw-r--r--games-fps/ut2004/metadata.xml9
-rw-r--r--games-fps/ut2004/ut2004-3204.ebuild236
6 files changed, 266 insertions, 0 deletions
diff --git a/games-fps/ut2004/ChangeLog b/games-fps/ut2004/ChangeLog
new file mode 100644
index 000000000000..2b85ccb7befb
--- /dev/null
+++ b/games-fps/ut2004/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-fps/ut2004
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004/ChangeLog,v 1.1 2004/05/20 20:39:15 wolf31o2 Exp $
+
+*ut2004-3204 (20 May 2004)
+
+ 20 May 2004; Chris Gianelloni <wolf31o2@gentoo.org> +metadata.xml,
+ +files/ut2004.xml, +ut2004-3204.ebuild:
+ Initial import. Ebuild by me.
+
diff --git a/games-fps/ut2004/Manifest b/games-fps/ut2004/Manifest
new file mode 100644
index 000000000000..a4e6180411ca
--- /dev/null
+++ b/games-fps/ut2004/Manifest
@@ -0,0 +1,3 @@
+MD5 b043ebede9d6ac995f42b5f211d0a2f1 ut2004-3204.ebuild 7152
+MD5 e199cda0f458ab3a4b3ca2e482451c8f files/ut2004.xml 358
+MD5 38a2ab1b4c41c3400282d142baabc6e1 files/digest-ut2004-3204 74
diff --git a/games-fps/ut2004/files/digest-ut2004-3204 b/games-fps/ut2004/files/digest-ut2004-3204
new file mode 100644
index 000000000000..ddb779f165dc
--- /dev/null
+++ b/games-fps/ut2004/files/digest-ut2004-3204
@@ -0,0 +1 @@
+MD5 5f659552095b878a029b917d216d9664 ut2004-lnxpatch3204.tar.bz2 19790090
diff --git a/games-fps/ut2004/files/ut2004.xml b/games-fps/ut2004/files/ut2004.xml
new file mode 100644
index 000000000000..ddcf9f8b615b
--- /dev/null
+++ b/games-fps/ut2004/files/ut2004.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0"?>
+<product name="ut2004" desc="Unreal Tournament 2004" xmlversion="1.6" root="/opt/ut2004" update_url="http://unreal.epicgames.com/updates/ut2004/updates.txt">
+ <component name="__CDKEY__" version="3186" default="yes">
+ <option name="English"></option>
+ <option name="__CDKEY__" tag="__CDKEY__"></option>
+ </component>
+</product>
diff --git a/games-fps/ut2004/metadata.xml b/games-fps/ut2004/metadata.xml
new file mode 100644
index 000000000000..fe08918e6837
--- /dev/null
+++ b/games-fps/ut2004/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<maintainer>
+ <email>wolf31o2@gentoo.org</email>
+ <name>Chris Gianelloni</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-fps/ut2004/ut2004-3204.ebuild b/games-fps/ut2004/ut2004-3204.ebuild
new file mode 100644
index 000000000000..2e00341080c2
--- /dev/null
+++ b/games-fps/ut2004/ut2004-3204.ebuild
@@ -0,0 +1,236 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004/ut2004-3204.ebuild,v 1.1 2004/05/20 20:39:15 wolf31o2 Exp $
+
+inherit games
+
+DESCRIPTION="Unreal Tournament 2004 - follow-up to the 2003 multi-player first-person shooter"
+HOMEPAGE="http://www.unrealtournament2004.com/"
+SRC_URI="http://mirror1.icculus.org/ut2004/ut2004-lnxpatch3204.tar.bz2"
+
+LICENSE="ut2003"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+RESTRICT="nostrip"
+IUSE="opengl dedicated"
+
+DEPEND="virtual/glibc"
+RDEPEND="opengl? ( virtual/opengl )
+ dedicated? ( app-misc/screen )"
+
+S=${WORKDIR}
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+
+pkg_setup() {
+ check_license || die "License check failed"
+ ewarn "The installed game takes about 6.8GB of space!"
+
+ # The following is a nasty mess to determine if we are installing from
+ # a DVD or from multiple CDs. Anyone feel free to submit patches to this
+ # to bugs.gentoo.org as I know it is a very ugly hack.
+ if [ -n "${CD_ROOT}" ]; then
+ [ -d "${CD_ROOT}/CD1" ] && USE_DVD=1
+ else
+ local cd_dir="$(dirname ${@})"
+ local file="$(basename ${@})"
+ local mline=""
+ for mline in `mount | egrep -e '(iso|cdrom)' | awk '{print $3}'` ; do
+ [ -d "${mline}/${cd_dir}" ] || continue
+ [ ! -z "$(find ${mline}/${cd_dir} -iname ${file} -maxdepth 1)" ] \
+ && [ -d "${mline}/CD1" ] && USE_DVD=1
+ done
+ fi
+ if [ ${USE_DVD} ]; then
+ DISK1="CD1"
+ DISK2="CD2"
+ DISK3="CD3"
+ DISK4="CD4"
+ DISK5="CD5"
+ DISK6="CD6"
+ fi
+ cdrom_get_cds ${DISK1}/System/UT2004.ini \
+ ${DISK2}/Textures/2K4Fonts.utx.uz2 \
+ ${DISK3}/Textures/ONSDeadVehicles-TX.utx.uz2 \
+ ${DISK4}/Music/KR-UT2004-Menu.ogg \
+ ${DISK5}/Speech/ons.xml ${DISK6}/DirectX9/BDA.cab
+
+ games_pkg_setup
+}
+
+src_unpack() {
+ unpack_makeself ${CDROM_ROOT}/linux-installer.sh \
+ || die "unpacking linux installer"
+ unpack ${PN}-lnxpatch${PV}.tar.bz2
+}
+
+src_install() {
+ dodir ${dir}
+ dodir ${dir}/System
+ dodir ${dir}/System/editorres
+
+ # Disk 1
+ einfo "Copying files from Disk 1..."
+ cp -r ${CDROM_ROOT}/${DISK1}/{Animations,ForceFeedback,Help,KarmaData,Maps,Sounds,Web} ${Ddir} || die "copying files"
+ cp -r ${CDROM_ROOT}/${DISK1}/System/{editorres,*.{bat,bmp,dat,det,est,frt,ini,int,itt,kot,md5,smt,tmt,u,ucl,upl,url}} ${Ddir}/System || die "copying files"
+ mkdir -p ${Ddir}/Manual || dir "creating manual folder"
+ cp ${CDROM_ROOT}/${DISK1}/Manual/Manual.pdf ${Ddir}/Manual \
+ || die "copying manual"
+ mkdir -p ${Ddir}/Benchmark/Stuff || dir "creating benchmark folders"
+ cp -r ${CDROM_ROOT}/${DISK1}/Benchmark/Stuff/* ${Ddir}/Benchmark/Stuff \
+ || die "copying benchmark files"
+ cdrom_load_next_cd
+
+ # Disk 2
+ einfo "Copying files from Disk 2..."
+ cp -r ${CDROM_ROOT}/${DISK2}/{Sounds,Textures} ${Ddir} || die "copying files"
+ cdrom_load_next_cd
+
+ # Disk 3
+ einfo "Copying files from Disk 3..."
+ cp -r ${CDROM_ROOT}/${DISK3}/Textures ${Ddir} || die "copying files"
+ cdrom_load_next_cd
+
+ #Disk 4
+ einfo "Copying files from Disk 4..."
+ cp -r ${CDROM_ROOT}/${DISK4}/{Music,StaticMeshes,Textures} ${Ddir} \
+ || die "copying files"
+ cdrom_load_next_cd
+
+ #Disk 5
+ einfo "Copying files from Disk 5..."
+ cp -r ${CDROM_ROOT}/${DISK5}/{Music,Sounds} ${Ddir} \
+ || die "copying files"
+ cdrom_load_next_cd
+
+ #Disk 6
+ einfo "Copying files from Disk 6..."
+ cp -r ${CDROM_ROOT}/${DISK6}/Sounds ${Ddir} \
+ || die "copying files"
+
+ # create empty files in Benchmark
+ for j in {CSVs,Logs,Results} ; do
+ mkdir -p ${Ddir}/Benchmark/${j} || die "creating folders"
+ touch ${Ddir}/Benchmark/${j}/DO_NOT_DELETE.ME || die "creating files"
+ done
+
+ # install extra help files
+ insinto ${dir}/Help
+ doins ${S}/Unreal.bmp ${S}/UT2004Logo.bmp
+
+ # install eula
+ insinto ${dir}
+ doins ${S}/UT2004_EULA.txt
+
+ # install System.inis
+ insinto ${dir}/System
+ doins ${S}/ini-{det,est,frt,int,itt,kot,smt,tmt}.tar
+
+ # copy ut2004
+ exeinto ${dir}
+ doexe ${S}/bin/ut2004 || die "copying ut2004"
+
+ exeinto ${dir}/System
+ doexe ${S}/System/{libSDL-1.2.so.0,openal.so,ucc-bin} \
+ || die "copying libs/ucc"
+ doexe ${S}/ut2004-bin
+
+ # Removing uneccessary files in Sounds
+ rm -f ${Ddir}/Sounds/*.{det,est,frt,itt,kot,smt,tmt}_uax.uz2
+
+ # uncompressing files
+ einfo "Uncompressing files... this *will* take a while..."
+ for j in {Animations,Maps,Sounds,StaticMeshes,Textures} ; do
+ games_ut_unpack ${Ddir}/${j} || die "uncompressing files"
+ done
+
+ # Removing unneccessary files in System and Help
+ rm -f ${Ddir}/Help/{InstallerLogo.bmp,SAPI-EULA.txt,{Unreal,UnrealEd}.ico}
+ rm -f ${Ddir}/System/*.tar
+ rm -f ${Ddir}/System/{{License,Manifest}.smt,{ucc,StdOut}.log,{User,UT2004}.ini}
+
+ # installing documentation/icon
+ dodoc ${S}/README.linux || die "dodoc README.linux"
+ insinto /usr/share/pixmaps;
+ doins ${S}/ut2004.xpm || die "copying pixmap"
+ insinto ${dir}
+ doins ${S}/README.linux ${S}/ut2004.xpm || die "copying readme/icon"
+
+ # creating .manifest files
+ dodir ${dir}/.manifest
+ insinto ${dir}/.manifest
+ doins ${FILESDIR}/${PN}.xml
+
+ # creating .loki/installed links
+ mkdir -p ${D}/root/.loki/installed
+ dosym ${dir}/.manifest/${PN}.xml ${D}/root/.loki/installed/${PN}.xml
+
+ # installing patch files
+ cp ${S}/UT2004-Patch/Help/* ${Ddir}/Help
+ cp ${S}/UT2004-Patch/System/* ${Ddir}/System
+ cp ${S}/UT2004-Patch/Textures/* ${Ddir}/Textures
+
+ use amd64 && rm ${Ddir}/System/ucc-bin ${Ddir}/System/ut2004-bin \
+ && mv ${Ddir}/System/ucc-bin-linux-amd64 ${Ddir}/System/ucc-bin \
+ && ${Ddir}/System/ut2004-bin-linux-amd64 ${Ddir}/System/ut2004-bin
+ use x86 && rm ${Ddir}/System/ucc-bin-linux-amd64 \
+ ${Ddir}/System/ut2004-bin-linux-amd64
+
+ games_make_wrapper ut2004 ./ut2004 ${dir}
+
+ # now, since these files are coming off a cd, the times/sizes/md5sums wont
+ # be different ... that means portage will try to unmerge some files (!)
+ # we run touch on ${D} so as to make sure portage doesnt do any such thing
+ find ${Ddir} -exec touch '{}' \;
+
+ prepgamesdirs
+ make_desktop_entry ut2004 "Unreal Tournament 2004" ut2004.xpm
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ # here is where we check for the existence of a cdkey...
+ # if we don't find one, we ask the user for it
+ if [ -f ${dir}/System/cdkey ]; then
+ einfo "A cdkey file is already present in ${dir}/System"
+ else
+ ewarn "You MUST run this before playing the game:"
+ ewarn "ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config"
+ ewarn "That way you can [re]enter your cdkey."
+ fi
+ echo
+ einfo "To play the game run:"
+ einfo " ut2004"
+}
+
+pkg_postrm() {
+ ewarn "This package leaves a cdkey file in ${dir}/System that you need"
+ ewarn "to remove to completely get rid of this game's files."
+}
+
+pkg_config() {
+ ewarn "Your CD key is NOT checked for validity here."
+ ewarn " Make sure you type it in correctly."
+ eerror "If you CTRL+C out of this, the game will not run!"
+ echo
+ einfo "CD key format is: XXXXX-XXXXX-XXXXX-XXXXX"
+ while true ; do
+ einfo "Please enter your CD key:"
+ read CDKEY1
+ einfo "Please re-enter your CD key:"
+ read CDKEY2
+ if [ "$CDKEY1" == "" ] ; then
+ echo "You entered a blank CD key. Try again."
+ else
+ if [ "$CDKEY1" == "$CDKEY2" ] ; then
+ echo "$CDKEY1" | tr a-z A-Z > ${dir}/System/cdkey
+ einfo "Thank you!"
+ break
+ else
+ eerror "Your CD key entries do not match. Try again."
+ fi
+ fi
+ done
+}