summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2006-05-06 23:07:21 +0000
committerAlfredo Tupone <tupone@gentoo.org>2006-05-06 23:07:21 +0000
commit9c934ab7943b5a672d82eb2be85da0e649cc354c (patch)
tree14dae30cba36c0483cdd0528375905e0ed912aea /games-fps/rott
parentFix for gcc-4.1 (diff)
downloadgentoo-2-9c934ab7943b5a672d82eb2be85da0e649cc354c.tar.gz
gentoo-2-9c934ab7943b5a672d82eb2be85da0e649cc354c.tar.bz2
gentoo-2-9c934ab7943b5a672d82eb2be85da0e649cc354c.zip
Fix for gcc-4.1
(Portage version: 2.1_pre10-r3)
Diffstat (limited to 'games-fps/rott')
-rw-r--r--games-fps/rott/ChangeLog8
-rw-r--r--games-fps/rott/files/1.0-custom-datapath.patch8
-rw-r--r--games-fps/rott/files/digest-rott-1.04
-rw-r--r--games-fps/rott/files/rott-1.0-gcc41.patch22
-rw-r--r--games-fps/rott/rott-1.0.ebuild8
5 files changed, 41 insertions, 9 deletions
diff --git a/games-fps/rott/ChangeLog b/games-fps/rott/ChangeLog
index 86bf957bbb23..2d53eb8f7a73 100644
--- a/games-fps/rott/ChangeLog
+++ b/games-fps/rott/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-fps/rott
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/rott/ChangeLog,v 1.5 2005/09/16 01:19:49 mr_bones_ Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/rott/ChangeLog,v 1.6 2006/05/06 23:07:21 tupone Exp $
+
+ 06 May 2006; <Tupone@gentoo.org> +files/rott-1.0-gcc41.patch,
+ files/1.0-custom-datapath.patch, rott-1.0.ebuild:
+ Fix for gcc-4.1
16 Sep 2005; Michael Sterrett <mr_bones_@gentoo.org> rott-1.0.ebuild:
needs app-arch/unzip; tidy
diff --git a/games-fps/rott/files/1.0-custom-datapath.patch b/games-fps/rott/files/1.0-custom-datapath.patch
index 90c533113b1f..102801d852e0 100644
--- a/games-fps/rott/files/1.0-custom-datapath.patch
+++ b/games-fps/rott/files/1.0-custom-datapath.patch
@@ -1,5 +1,5 @@
---- rott-1.0/rott/rt_main.c.orig 2003-06-19 23:03:34.000000000 -0400
-+++ rott-1.0/rott/rt_main.c 2003-06-19 23:04:49.000000000 -0400
+--- rt_main.c.orig 2003-06-19 23:03:34.000000000 -0400
++++ rt_main.c 2003-06-19 23:04:49.000000000 -0400
@@ -763,9 +763,9 @@
// Normal ROTT wads
@@ -21,8 +21,8 @@
}
newargs [argnum++] = NULL;
---- rott-1.0/rott/_rt_ted.h.orig 2003-06-19 23:15:26.000000000 -0400
-+++ rott-1.0/rott/_rt_ted.h 2003-06-19 23:15:54.000000000 -0400
+--- _rt_ted.h.orig 2003-06-19 23:15:26.000000000 -0400
++++ _rt_ted.h 2003-06-19 23:15:54.000000000 -0400
@@ -84,17 +84,17 @@
#define MAXSILLYSTRINGS 32
diff --git a/games-fps/rott/files/digest-rott-1.0 b/games-fps/rott/files/digest-rott-1.0
index 0465c1828282..41cb378f078d 100644
--- a/games-fps/rott/files/digest-rott-1.0
+++ b/games-fps/rott/files/digest-rott-1.0
@@ -1,2 +1,6 @@
MD5 c1c6cbecf00f2229cf2e0053334dcfc1 rott-1.0.tar.gz 777281
+RMD160 539125b1e2f820f61029397df7c5ae829c043cc2 rott-1.0.tar.gz 777281
+SHA256 11f9cc331d0be87f0f172840e2bb6e03e27c3b8e9ecbb3eb8cffdc5b73afbd95 rott-1.0.tar.gz 777281
MD5 0150bf731e703cc91b8c5e21cb9402f3 swdata.zip 2889672
+RMD160 1a51acf050d543acbb22e99ae2a2d5f32e0c503a swdata.zip 2889672
+SHA256 e226d4958ce1294886b32faf782d9db3d3e66f875d9addd62982e2c8d104fd6b swdata.zip 2889672
diff --git a/games-fps/rott/files/rott-1.0-gcc41.patch b/games-fps/rott/files/rott-1.0-gcc41.patch
new file mode 100644
index 000000000000..c2f67b5e9e3c
--- /dev/null
+++ b/games-fps/rott/files/rott-1.0-gcc41.patch
@@ -0,0 +1,22 @@
+--- rt_actor.h.old 2006-05-07 00:54:12.000000000 +0200
++++ rt_actor.h 2006-05-07 00:54:23.000000000 +0200
+@@ -315,7 +315,6 @@
+ extern void *actorat[MAPSIZE][MAPSIZE];
+ extern int angletodir[ANGLES];
+ extern _2Dpoint SNAKEPATH[512];
+-extern int STOPSPEED;
+ extern int FRICTION;
+
+ extern int objcount;
+--- rt_in.h.old 2006-05-07 00:59:45.000000000 +0200
++++ rt_in.h 2006-05-07 01:00:07.000000000 +0200
+@@ -147,9 +147,6 @@
+
+ extern boolean Paused;
+ extern volatile int LastScan;
+-extern KeyboardDef KbdDefs;
+-extern JoystickDef JoyDefs[];
+-extern ControlType Controls[MAXPLAYERS];
+
+ extern boolean SpaceBallPresent;
+ extern boolean CybermanPresent;
diff --git a/games-fps/rott/rott-1.0.ebuild b/games-fps/rott/rott-1.0.ebuild
index 2a5ee9b44053..4b140e9c61c2 100644
--- a/games-fps/rott/rott-1.0.ebuild
+++ b/games-fps/rott/rott-1.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/rott/rott-1.0.ebuild,v 1.7 2005/09/16 01:19:49 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/rott/rott-1.0.ebuild,v 1.8 2006/05/06 23:07:21 tupone Exp $
inherit eutils games
@@ -23,7 +23,9 @@ S=${WORKDIR}/${P}/rott
src_unpack() {
unpack ${A}
- epatch "${FILESDIR}"/${PV}-custom-datapath.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-custom-datapath.patch \
+ "${FILESDIR}/${P}"-gcc41.patch
}
src_compile() {