summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-08-25 06:51:35 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-08-25 06:51:35 +0000
commit808991ddfb268a0f4508623123f6fb1f7933a098 (patch)
tree92e4648bce7859025e7e38dc84c76e6c96661cb8 /games-fps/rott
parentAdding version 1.5.9 until some issues are worked out; fixes bug (diff)
downloadgentoo-2-808991ddfb268a0f4508623123f6fb1f7933a098.tar.gz
gentoo-2-808991ddfb268a0f4508623123f6fb1f7933a098.tar.bz2
gentoo-2-808991ddfb268a0f4508623123f6fb1f7933a098.zip
version bump
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-fps/rott')
-rw-r--r--games-fps/rott/ChangeLog10
-rw-r--r--games-fps/rott/files/rott-1.1.1-full-version.patch11
-rw-r--r--games-fps/rott/rott-1.1.1.ebuild59
3 files changed, 78 insertions, 2 deletions
diff --git a/games-fps/rott/ChangeLog b/games-fps/rott/ChangeLog
index e3770e292bcb..114999d5b3bf 100644
--- a/games-fps/rott/ChangeLog
+++ b/games-fps/rott/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-fps/rott
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/rott/ChangeLog,v 1.8 2007/07/22 13:10:50 nyhm Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/rott/ChangeLog,v 1.9 2009/08/25 06:51:35 mr_bones_ Exp $
+
+*rott-1.1.1 (25 Aug 2009)
+
+ 25 Aug 2009; Michael Sterrett <mr_bones_@gentoo.org> +rott-1.1.1.ebuild,
+ +files/rott-1.1.1-full-version.patch:
+ version bump
22 Jul 2007; Tristan Heaven <nyhm@gentoo.org>
+files/rott-1.0-full-version.patch, rott-1.0.ebuild:
diff --git a/games-fps/rott/files/rott-1.1.1-full-version.patch b/games-fps/rott/files/rott-1.1.1-full-version.patch
new file mode 100644
index 000000000000..e1615e77f7fa
--- /dev/null
+++ b/games-fps/rott/files/rott-1.1.1-full-version.patch
@@ -0,0 +1,11 @@
+--- develop.h.orig 2007-05-13 22:42:39.000000000 +0200
++++ develop.h 2007-05-13 22:42:44.000000000 +0200
+@@ -40,7 +40,7 @@
+ #define LOWCOST 0
+
+ // Make sure only one of the following are on at one time
+-#define SHAREWARE 1
++#define SHAREWARE 0
+ #define SUPERROTT 0
+ #define SITELICENSE 0
+
diff --git a/games-fps/rott/rott-1.1.1.ebuild b/games-fps/rott/rott-1.1.1.ebuild
new file mode 100644
index 000000000000..08e9eef54792
--- /dev/null
+++ b/games-fps/rott/rott-1.1.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/rott/rott-1.1.1.ebuild,v 1.1 2009/08/25 06:51:35 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="Rise of the Triad for Linux!"
+HOMEPAGE="http://www.icculus.org/rott/"
+SRC_URI="http://www.icculus.org/rott/releases/${P}.tar.gz
+ demo? ( http://filesingularity.timedoctor.org/swdata.zip )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE="demo"
+
+RDEPEND="media-libs/libsdl
+ media-libs/sdl-mixer"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${P}/rott
+
+src_prepare() {
+ use demo || epatch "${FILESDIR}"/${P}-full-version.patch
+ cd "${S}"
+ sed -i \
+ -e '/^CC =/d' \
+ Makefile \
+ || die "sed failed"
+ emake clean || die
+}
+
+src_compile() {
+ emake -j1 \
+ EXTRACFLAGS="${CFLAGS} -DDATADIR=\\\"${GAMES_DATADIR}/${PN}/\\\"" \
+ || die "emake failed"
+}
+
+src_install() {
+ dogamesbin rott || die "dogamesbin failed"
+ dodoc ../doc/*.txt ../README
+ doman ../doc/rott.6
+ if use demo ; then
+ cd "${WORKDIR}"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins *.dmo huntbgin.* remote1.rts || die "doins failed"
+ fi
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ if ! use demo ; then
+ elog "To play the full version, just copy the"
+ elog "data files to ${GAMES_DATADIR}/${PN}/"
+ fi
+}