summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2011-04-18 12:14:10 +0000
committerAlfredo Tupone <tupone@gentoo.org>2011-04-18 12:14:10 +0000
commiteefd030ae79f7f117cab8780c50403fc63d5efc3 (patch)
tree76261dc79bb6f1100e43523b9206e6039e5a6436 /games-fps/quakeforge
parentold (diff)
downloadgentoo-2-eefd030ae79f7f117cab8780c50403fc63d5efc3.tar.gz
gentoo-2-eefd030ae79f7f117cab8780c50403fc63d5efc3.tar.bz2
gentoo-2-eefd030ae79f7f117cab8780c50403fc63d5efc3.zip
Fix build with gcc-4.6 Bug #362839
(Portage version: 2.1.9.46/cvs/Linux i686)
Diffstat (limited to 'games-fps/quakeforge')
-rw-r--r--games-fps/quakeforge/ChangeLog6
-rw-r--r--games-fps/quakeforge/files/quakeforge-0.5.5-gcc46.patch174
-rw-r--r--games-fps/quakeforge/quakeforge-0.5.5-r2.ebuild3
3 files changed, 181 insertions, 2 deletions
diff --git a/games-fps/quakeforge/ChangeLog b/games-fps/quakeforge/ChangeLog
index 550c2ef59447..b93e1022d1d4 100644
--- a/games-fps/quakeforge/ChangeLog
+++ b/games-fps/quakeforge/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-fps/quakeforge
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quakeforge/ChangeLog,v 1.25 2011/03/08 17:05:10 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quakeforge/ChangeLog,v 1.26 2011/04/18 12:14:09 tupone Exp $
+
+ 18 Apr 2011; Tupone Alfredo <tupone@gentoo.org> quakeforge-0.5.5-r2.ebuild,
+ +files/quakeforge-0.5.5-gcc46.patch:
+ Fix build with gcc-4.6 Bug #362839 by Diego Elio Pettenò
08 Mar 2011; Tomáš Chvátal <scarabeus@gentoo.org> quakeforge-0.5.5.ebuild,
quakeforge-0.5.5-r2.ebuild:
diff --git a/games-fps/quakeforge/files/quakeforge-0.5.5-gcc46.patch b/games-fps/quakeforge/files/quakeforge-0.5.5-gcc46.patch
new file mode 100644
index 000000000000..9ce55330c7c1
--- /dev/null
+++ b/games-fps/quakeforge/files/quakeforge-0.5.5-gcc46.patch
@@ -0,0 +1,174 @@
+--- libs/audio/cd/Makefile.am.old 2011-04-18 11:40:51.058924897 +0200
++++ libs/audio/cd/Makefile.am 2011-04-18 12:24:29.486917778 +0200
+@@ -5,13 +5,12 @@
+ SDL_LIBS= @SDL_LIBS@
+ XMMS_LIBS= @XMMS_LIBS@
+ plugin_version= 1:0:0
+-plugin_ldflags= @plugin_ldflags@
++plugin_ldflags= @plugin_ldflags@ -module
+ plugin_libadd= @plugin_libadd@
+ EXEEXT=
+
+-plugin_PROGRAMS= @CD_PLUGIN_TARGETS@
+-noinst_PROGRAMS= @CD_PLUGIN_STATIC@
+-EXTRA_PROGRAMS= cd_file.la cd_linux.la cd_sdl.la cd_sgi.la cd_win.la cd_xmms.la
++plugin_LTLIBRARIES= @CD_PLUGIN_TARGETS@
++EXTRA_LTLIBRARIES= cd_file.la cd_linux.la cd_sdl.la cd_sgi.la cd_win.la cd_xmms.la
+
+ cd_file_la_LDFLAGS= $(plugin_ldflags)
+ cd_file_la_SOURCES= cd_file.c
+@@ -20,19 +19,19 @@
+ cd_linux_la_SOURCES= cd_linux.c
+
+ cd_sdl_la_LDFLAGS= $(plugin_ldflags)
+-cd_sdl_la_LDADD= $(SDL_LIBS) $(plugin_libadd)
++cd_sdl_la_LIBADD= $(SDL_LIBS) $(plugin_libadd)
+ cd_sdl_la_CFLAGS= $(SDL_CFLAGS)
+ cd_sdl_la_SOURCES= cd_sdl.c
+
+ cd_sgi_la_LDFLAGS= $(plugin_ldflags)
+-cd_sgi_la_LDADD= $(SGI_CD_LIBS)
++cd_sgi_la_LIBADD= $(SGI_CD_LIBS)
+ cd_sgi_la_SOURCES= cd_sgi.c
+
+ cd_win_la_LDFLAGS= $(plugin_ldflags)
+-cd_win_la_LDADD= $(plugin_libadd)
++cd_win_la_LIBADD= $(plugin_libadd)
+ cd_win_la_SOURCES= cd_win.c
+
+ cd_xmms_la_LDFLAGS= $(plugin_ldflags)
+-cd_xmms_la_LDADD= $(XMMS_LIBS)
++cd_xmms_la_LIBADD= $(XMMS_LIBS)
+ cd_xmms_la_CFLAGS= $(XMMS_CFLAGS)
+ cd_xmms_la_SOURCES= cd_xmms.c
+--- libs/audio/targets/Makefile.am.old 2011-04-18 12:50:20.674846930 +0200
++++ libs/audio/targets/Makefile.am 2011-04-18 12:53:22.220844800 +0200
+@@ -4,39 +4,38 @@
+ INCLUDES= -I$(top_srcdir)/include
+ SDL_LIBS = @SDL_LIBS@
+ plugin_version= 1:0:0
+-plugin_ldflags= @plugin_ldflags@
++plugin_ldflags= @plugin_ldflags@ -module
+ plugin_libadd= @plugin_libadd@
+ EXEEXT=
+
+-plugin_PROGRAMS= @SND_PLUGIN_TARGETS@
+-noinst_PROGRAMS= @SND_PLUGIN_STATIC@
+-EXTRA_PROGRAMS= \
++plugin_LTLIBRARIES= @SND_PLUGIN_TARGETS@
++EXTRA_LTLIBRARIES= \
+ snd_output_sdl.la snd_output_alsa.la snd_output_alsa0_9.la\
+ snd_output_oss.la snd_output_sgi.la snd_output_sun.la \
+ snd_output_win.la snd_output_dx.la snd_output_disk.la
+
+ snd_output_sdl_la_LDFLAGS= $(plugin_ldflags)
+-snd_output_sdl_la_LDADD= $(SDL_LIBS) $(plugin_libadd)
++snd_output_sdl_la_LIBADD= $(SDL_LIBS) $(plugin_libadd)
+ snd_output_sdl_la_CFLAGS= $(SDL_CFLAGS)
+ snd_output_sdl_la_SOURCES= snd_sdl.c
+
+ snd_output_alsa_la_LDFLAGS= $(plugin_ldflags)
+-snd_output_alsa_la_LDADD=
++snd_output_alsa_la_LIBADD=
+ snd_output_alsa_la_CFLAGS= $(ALSA_CFLAGS)
+ snd_output_alsa_la_SOURCES= snd_alsa.c
+
+ snd_output_alsa0_9_la_LDFLAGS= $(plugin_ldflags)
+-snd_output_alsa0_9_la_LDADD=
++snd_output_alsa0_9_la_LIBADD=
+ snd_output_alsa0_9_la_CFLAGS= $(ALSA_CFLAGS)
+ snd_output_alsa0_9_la_SOURCES= snd_alsa_0_9.c
+
+ snd_output_oss_la_LDFLAGS= $(plugin_ldflags)
+-snd_output_oss_la_LDADD= $(OSS_LIBS)
++snd_output_oss_la_LIBADD= $(OSS_LIBS)
+ snd_output_oss_la_CFLAGS= $(OSS_CFLAGS)
+ snd_output_oss_la_SOURCES= snd_oss.c
+
+ snd_output_sgi_la_LDFLAGS= $(plugin_ldflags)
+-snd_output_sgi_la_LDADD= $(SGISND_LIBS)
++snd_output_sgi_la_LIBADD= $(SGISND_LIBS)
+ snd_output_sgi_la_CFLAGS= $(SGISND_CFLAGS)
+ snd_output_sgi_la_SOURCES= snd_sgi.c
+
+@@ -45,16 +44,16 @@
+ snd_output_sun_la_SOURCES= snd_sun.c
+
+ snd_output_win_la_LDFLAGS= $(plugin_ldflags)
+-snd_output_win_la_LDADD= $(WINSND_LIBS) $(plugin_libadd)
++snd_output_win_la_LIBADD= $(WINSND_LIBS) $(plugin_libadd)
+ snd_output_win_la_CFLAGS= $(WIN32SND_CFLAGS)
+ snd_output_win_la_SOURCES= snd_win.c
+
+ snd_output_dx_la_LDFLAGS= $(plugin_ldflags)
+-snd_output_dx_la_LDADD= $(WINSND_LIBS) $(plugin_libadd)
++snd_output_dx_la_LIBADD= $(WINSND_LIBS) $(plugin_libadd)
+ snd_output_dx_la_CFLAGS= $(WIN32SND_CFLAGS)
+ snd_output_dx_la_SOURCES= snd_dx.c
+
+ snd_output_disk_la_LDFLAGS= $(plugin_ldflags)
+-snd_output_disk_la_LDADD= $(plugin_libadd)
++snd_output_disk_la_LIBADD= $(plugin_libadd)
+ snd_output_disk_la_CFLAGS=
+ snd_output_disk_la_SOURCES= snd_disk.c
+--- libs/audio/renderer/Makefile.am.old 2011-04-18 12:54:32.560697490 +0200
++++ libs/audio/renderer/Makefile.am 2011-04-18 12:55:21.157363865 +0200
+@@ -3,21 +3,19 @@
+ AM_CFLAGS= @PREFER_PIC@ @VORBIS_CFLAGS@ @OGG_CFLAGS@
+ INCLUDES= -I$(top_srcdir)/include
+ plugin_version= 1:0:0
+-plugin_ldflags= @plugin_ldflags@
++plugin_ldflags= @plugin_ldflags@ -module
+ plugin_libadd= @plugin_libadd@
+ EXEEXT=
+
+-plugin_PROGRAMS= @SND_REND_TARGETS@
+-EXTRA_PROGRAMS= snd_render_default.la
+-
+-noinst_PROGRAMS= @SND_REND_STATIC@
++plugin_LTLIBRARIES= @SND_REND_TARGETS@
++EXTRA_LTLIBRARIES= snd_render_default.la
+
+ snd_render_default_la_LDFLAGS= $(plugin_ldflags)
+ snd_render_default_la_SOURCES= snd_dma.c snd_mem.c snd_mix.c vorbis.c wav.c midi.c
+ if ASM_ARCH
+-snd_render_default_la_LDADD= $(VORBISFILE_LIBS) $(VORBIS_LIBS) $(OGG_LIBS) $(WM_LIBS)
++snd_render_default_la_LIBADD= $(VORBISFILE_LIBS) $(VORBIS_LIBS) $(OGG_LIBS) $(WM_LIBS)
+ snd_render_default_la_DEPENDENCIES=
+ else
+-snd_render_default_la_LDADD= $(VORBISFILE_LIBS) $(VORBIS_LIBS) $(OGG_LIBS) $(WM_LIBS)
++snd_render_default_la_LIBADD= $(VORBISFILE_LIBS) $(VORBIS_LIBS) $(OGG_LIBS) $(WM_LIBS)
+ snd_render_default_la_DEPENDENCIES=
+ endif
+--- libs/console/Makefile.am.old 2011-04-18 12:56:29.253106265 +0200
++++ libs/console/Makefile.am 2011-04-18 12:57:28.784383855 +0200
+@@ -3,14 +3,13 @@
+ AM_CFLAGS= @PREFER_PIC@
+ INCLUDES= -I$(top_srcdir)/include
+ plugin_version= 1:0:0
+-plugin_ldflags= @plugin_ldflags@
++plugin_ldflags= @plugin_ldflags@ -module
+ plugin_libadd= @plugin_libadd@
+ EXEEXT=
+
+ lib_LTLIBRARIES= libQFconsole.la
+-plugin_PROGRAMS= @SERVER_PLUGIN_TARGETS@ @CLIENT_PLUGIN_TARGETS@
+-noinst_PROGRAMS= @SERVER_PLUGIN_STATIC@ @CLIENT_PLUGIN_STATIC@
+-EXTRA_PROGRAMS= console_server.la console_client.la
++plugin_LTLIBRARIES= @SERVER_PLUGIN_TARGETS@ @CLIENT_PLUGIN_TARGETS@
++EXTRA_LTLIBRARIES= console_server.la console_client.la
+
+ common_sources= \
+ buffer.c complete.c console.c inputline.c list.c filelist.c view.c
+@@ -22,9 +21,9 @@
+ libQFconsole_la_SOURCES= $(common_sources)
+
+ console_client_la_LDFLAGS= $(plugin_ldflags)
+-console_client_la_LDADD= $(plugin_libadd)
++console_client_la_LIBADD= $(plugin_libadd)
+ console_client_la_SOURCES= $(client_sources)
+
+ console_server_la_LDFLAGS= $(plugin_ldflags)
+-console_server_la_LDADD= $(CURSES_LIBS) $(plugin_libadd)
++console_server_la_LIBADD= $(CURSES_LIBS) $(plugin_libadd)
+ console_server_la_SOURCES= $(server_sources)
diff --git a/games-fps/quakeforge/quakeforge-0.5.5-r2.ebuild b/games-fps/quakeforge/quakeforge-0.5.5-r2.ebuild
index 40f91f53cead..dd6646b54c8a 100644
--- a/games-fps/quakeforge/quakeforge-0.5.5-r2.ebuild
+++ b/games-fps/quakeforge/quakeforge-0.5.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quakeforge/quakeforge-0.5.5-r2.ebuild,v 1.7 2011/03/08 17:05:10 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quakeforge/quakeforge-0.5.5-r2.ebuild,v 1.8 2011/04/18 12:14:09 tupone Exp $
EAPI=2
inherit base eutils autotools games
@@ -46,6 +46,7 @@ PATCHES=(
"${FILESDIR}"/${P}-keys.patch
"${FILESDIR}"/${P}-amd64.patch
"${FILESDIR}"/${P}-noWerror.patch
+ "${FILESDIR}"/${P}-gcc46.patch
)
src_prepare() {