summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-06-17 11:28:36 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-06-17 11:28:36 +0000
commit4e7f1ba369150bd55328f9b0b1bac885c7cf4742 (patch)
tree1b6eadc6a696359447255c1baad09ac27190cc08 /games-fps/quakeforge
parentQA: fix ebuild for EAPI=2; econf was being executed twice. (diff)
downloadgentoo-2-4e7f1ba369150bd55328f9b0b1bac885c7cf4742.tar.gz
gentoo-2-4e7f1ba369150bd55328f9b0b1bac885c7cf4742.tar.bz2
gentoo-2-4e7f1ba369150bd55328f9b0b1bac885c7cf4742.zip
Fix building with recent sys-libs/glibc and sys-libs/zlib wrt #421547 Diego Elio Pettenò
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'games-fps/quakeforge')
-rw-r--r--games-fps/quakeforge/ChangeLog10
-rw-r--r--games-fps/quakeforge/files/quakeforge-0.5.5-libc.patch17
-rw-r--r--games-fps/quakeforge/files/quakeforge-0.5.5-zlib-1.2.6.patch14
-rw-r--r--games-fps/quakeforge/quakeforge-0.5.5-r2.ebuild6
4 files changed, 43 insertions, 4 deletions
diff --git a/games-fps/quakeforge/ChangeLog b/games-fps/quakeforge/ChangeLog
index eb4ceca4f7f6..d33732d36ce5 100644
--- a/games-fps/quakeforge/ChangeLog
+++ b/games-fps/quakeforge/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-fps/quakeforge
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quakeforge/ChangeLog,v 1.27 2011/05/03 21:15:11 mr_bones_ Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quakeforge/ChangeLog,v 1.28 2012/06/17 11:28:36 ssuominen Exp $
+
+ 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org>
+ quakeforge-0.5.5-r2.ebuild, +files/quakeforge-0.5.5-libc.patch,
+ +files/quakeforge-0.5.5-zlib-1.2.6.patch:
+ Fix building with recent sys-libs/glibc and sys-libs/zlib wrt #421547 Diego
+ Elio Pettenò
03 May 2011; Michael Sterrett <mr_bones_@gentoo.org>
quakeforge-0.5.5-r2.ebuild:
diff --git a/games-fps/quakeforge/files/quakeforge-0.5.5-libc.patch b/games-fps/quakeforge/files/quakeforge-0.5.5-libc.patch
new file mode 100644
index 000000000000..0161c606c891
--- /dev/null
+++ b/games-fps/quakeforge/files/quakeforge-0.5.5-libc.patch
@@ -0,0 +1,17 @@
+http://quake.git.sourceforge.net/git/gitweb.cgi?p=quake/quakeforge;a=commit;h=cdf5ef256583dea6caa34464f6a82222cc43d2fd
+
+--- libs/net/nc/net_udp6.c
++++ libs/net/nc/net_udp6.c
+@@ -111,10 +111,10 @@ static __attribute__ ((used)) const char rcsid[] =
+ # define MAXHOSTNAMELEN 512
+ #endif
+
+-#ifdef __GLIBC__ // glibc macro
++#if defined(__GLIBC__) && !defined(s6_addr32) // glibc macro
+ # define s6_addr32 in6_u.u6_addr32
+ # if ! __GLIBC_PREREQ (2,2)
+-# define ss_family __ss_family
++# define ss_family __ss_family
+ # endif
+ #endif
+
diff --git a/games-fps/quakeforge/files/quakeforge-0.5.5-zlib-1.2.6.patch b/games-fps/quakeforge/files/quakeforge-0.5.5-zlib-1.2.6.patch
new file mode 100644
index 000000000000..eae1e1e44785
--- /dev/null
+++ b/games-fps/quakeforge/files/quakeforge-0.5.5-zlib-1.2.6.patch
@@ -0,0 +1,14 @@
+http://bugs.gentoo.org/421547
+http://quake.git.sourceforge.net/git/gitweb.cgi?p=quake/quakeforge;a=commit;h=d8a37bc7910366904ef4559bef3b13feec378113
+
+--- libs/util/quakeio.c
++++ libs/util/quakeio.c
+@@ -80,7 +80,7 @@ static __attribute__ ((used)) const char rcsid[] =
+ struct QFile_s {
+ FILE *file;
+ #ifdef HAVE_ZLIB
+- gzFile *gzfile;
++ gzFile gzfile;
+ #endif
+ off_t size;
+ off_t start;
diff --git a/games-fps/quakeforge/quakeforge-0.5.5-r2.ebuild b/games-fps/quakeforge/quakeforge-0.5.5-r2.ebuild
index 9a658b50748f..aa96e102db37 100644
--- a/games-fps/quakeforge/quakeforge-0.5.5-r2.ebuild
+++ b/games-fps/quakeforge/quakeforge-0.5.5-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quakeforge/quakeforge-0.5.5-r2.ebuild,v 1.9 2011/05/03 21:15:11 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quakeforge/quakeforge-0.5.5-r2.ebuild,v 1.10 2012/06/17 11:28:36 ssuominen Exp $
EAPI=2
inherit base eutils autotools games
@@ -47,6 +47,8 @@ PATCHES=(
"${FILESDIR}"/${P}-amd64.patch
"${FILESDIR}"/${P}-noWerror.patch
"${FILESDIR}"/${P}-gcc46.patch
+ "${FILESDIR}"/${P}-zlib-1.2.6.patch
+ "${FILESDIR}"/${P}-libc.patch
)
src_prepare() {