summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-05-10 00:23:42 +0000
committerMike Frysinger <vapier@gentoo.org>2006-05-10 00:23:42 +0000
commit8f8315fa0fe58044257abecb9a203eacfce21996 (patch)
treebe228e69aa57a6d67cc8724daca3d7052580a1da /games-fps/quake3
parentmark ~ppc (Bug #130382) (diff)
downloadgentoo-2-8f8315fa0fe58044257abecb9a203eacfce21996.tar.gz
gentoo-2-8f8315fa0fe58044257abecb9a203eacfce21996.tar.bz2
gentoo-2-8f8315fa0fe58044257abecb9a203eacfce21996.zip
Version bump for security #132377.
(Portage version: 2.1_pre10-r3)
Diffstat (limited to 'games-fps/quake3')
-rw-r--r--games-fps/quake3/ChangeLog8
-rw-r--r--games-fps/quake3/files/digest-quake3-1.34_alpha7783
-rw-r--r--games-fps/quake3/quake3-1.34_alpha778.ebuild119
3 files changed, 129 insertions, 1 deletions
diff --git a/games-fps/quake3/ChangeLog b/games-fps/quake3/ChangeLog
index 7318be5b4e11..826aa53172ea 100644
--- a/games-fps/quake3/ChangeLog
+++ b/games-fps/quake3/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-fps/quake3
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/ChangeLog,v 1.36 2006/04/19 23:43:44 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/ChangeLog,v 1.37 2006/05/10 00:23:42 vapier Exp $
+
+*quake3-1.34_alpha778 (10 May 2006)
+
+ 10 May 2006; Mike Frysinger <vapier@gentoo.org>
+ +quake3-1.34_alpha778.ebuild:
+ Version bump for security #132377.
*quake3-1.34_alpha711 (19 Apr 2006)
diff --git a/games-fps/quake3/files/digest-quake3-1.34_alpha778 b/games-fps/quake3/files/digest-quake3-1.34_alpha778
new file mode 100644
index 000000000000..c5974c8ca18f
--- /dev/null
+++ b/games-fps/quake3/files/digest-quake3-1.34_alpha778
@@ -0,0 +1,3 @@
+MD5 7e38dabd290dd6374be3b4f1f074b784 quake3-1.34_SVN778M.tar.bz2 2450805
+RMD160 4fc1d22fbfeb0c59661bb9ac9e4a44e8077a4703 quake3-1.34_SVN778M.tar.bz2 2450805
+SHA256 9e69dfadd83abedcf163ea39416ccd986fe7371d24d7656298fc7ba8a05bd35c quake3-1.34_SVN778M.tar.bz2 2450805
diff --git a/games-fps/quake3/quake3-1.34_alpha778.ebuild b/games-fps/quake3/quake3-1.34_alpha778.ebuild
new file mode 100644
index 000000000000..a275ed3cb9f2
--- /dev/null
+++ b/games-fps/quake3/quake3-1.34_alpha778.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/quake3-1.34_alpha778.ebuild,v 1.1 2006/05/10 00:23:42 vapier Exp $
+
+# quake3-9999 -> latest svn
+# quake3-9999.REV -> use svn REV
+# quake3-VER_alphaREV -> svn snapshot REV for version VER
+# quake3-VER -> normal quake release
+
+if [[ ${PV} == 9999* ]] ; then
+ [[ ${PV} == 9999.* ]] && ESVN_UPDATE_CMD="svn up -r ${PV/9999./}"
+ ESVN_REPO_URI="svn://svn.icculus.org/quake3/trunk"
+ inherit subversion toolchain-funcs eutils games
+
+ SRC_URI=""
+ S=${WORKDIR}/trunk
+elif [[ ${PV} == *_alpha* ]] ; then
+ inherit toolchain-funcs eutils games
+
+ MY_PV=${PV/_alpha*/}
+ SNAP=${PV/*_alpha/}
+ MY_P=${PN}-${MY_PV}_SVN${SNAP}M
+ SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
+ S=${WORKDIR}/${MY_P}
+else
+ inherit toolchain-funcs eutils games
+
+ SRC_URI="http://icculus.org/quake3/${P}.tar.bz2"
+fi
+
+DESCRIPTION="Quake III Arena - 3rd installment of the classic id 3D first-person shooter"
+HOMEPAGE="http://icculus.org/quake3/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="dedicated opengl"
+
+RDEPEND="opengl? (
+ virtual/opengl
+ media-libs/openal
+ || (
+ (
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp )
+ virtual/x11 )
+ media-libs/libsdl )
+ !dedicated? (
+ virtual/opengl
+ || (
+ (
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp )
+ virtual/x11 )
+ media-libs/libsdl )
+ games-fps/quake3-data
+ teamarena? ( games-fps/quake3-teamarena )"
+
+src_unpack() {
+ if [[ ${PV} == 9999* ]] ; then
+ subversion_src_unpack
+ else
+ unpack ${A}
+ fi
+ # This is a dirty hack around bug #121428 and should be removed once the
+ # upstream bug https://bugzilla.icculus.org/show_bug.cgi?id=2634 has been
+ # resolved.
+ sed -i -e 's|botlib.log|/dev/null|' ${S}/code/botlib/be_interface.c
+}
+
+src_compile() {
+ buildit() { use $1 && echo 1 || echo 0 ; }
+ emake \
+ BUILD_SERVER=$(buildit dedicated) \
+ BUILD_CLIENT=$(buildit opengl) \
+ TEMPDIR="${T}" \
+ CC="$(tc-getCC)" \
+ ARCH=$(tc-arch-kernel) \
+ OPTIMIZE="${CFLAGS}" \
+ DEFAULT_BASEDIR="${GAMES_DATADIR}/quake3" \
+ DEFAULT_LIBDIR="${GAMES_LIBDIR}/quake3" \
+ || die
+}
+
+src_install() {
+ dodoc id-readme.txt TODO README BUGS ChangeLog
+ cd code/unix
+ dodoc README.*
+
+ if use opengl ; then
+ doicon quake3.png
+ make_desktop_entry quake3 "Quake III Arena"
+ fi
+
+ cd ../../build/release*
+ local old_x x
+ for old_x in ioq* ; do
+ x=${old_x%.*}
+ newgamesbin ${old_x} ${x} || die "newgamesbin ${x}"
+ dosym ${x} "${GAMES_BINDIR}"/${x/io}
+ done
+ exeinto "${GAMES_LIBDIR}"/${PN}/baseq3
+ doexe baseq3/*.so || die "baseq3 .so"
+ exeinto "${GAMES_LIBDIR}"/${PN}/missionpack
+ doexe missionpack/*.so || die "missionpack .so"
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ ewarn "The source version of Quake 3 will not work with Punk Buster."
+ ewarn "If you need pb support, then use the quake3-bin package."
+ echo
+}