summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-01-20 01:20:50 +0000
committerMike Frysinger <vapier@gentoo.org>2006-01-20 01:20:50 +0000
commit8291185e083be48c480d46688cdf39144fc95f31 (patch)
tree1bc120472c4939c7bc028c1ca4310da1a64f8a49 /games-fps/quake3
parentsvn version (diff)
downloadgentoo-2-8291185e083be48c480d46688cdf39144fc95f31.tar.gz
gentoo-2-8291185e083be48c480d46688cdf39144fc95f31.tar.bz2
gentoo-2-8291185e083be48c480d46688cdf39144fc95f31.zip
Version bump.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'games-fps/quake3')
-rw-r--r--games-fps/quake3/ChangeLog8
-rw-r--r--games-fps/quake3/files/digest-quake3-1.33_alpha5101
-rw-r--r--games-fps/quake3/quake3-1.33_alpha510.ebuild113
3 files changed, 121 insertions, 1 deletions
diff --git a/games-fps/quake3/ChangeLog b/games-fps/quake3/ChangeLog
index 1a83b2f23f76..4ee2f1a1069b 100644
--- a/games-fps/quake3/ChangeLog
+++ b/games-fps/quake3/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-fps/quake3
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/ChangeLog,v 1.28 2006/01/08 14:52:00 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/ChangeLog,v 1.29 2006/01/20 01:20:50 vapier Exp $
+
+*quake3-1.33_alpha510 (20 Jan 2006)
+
+ 20 Jan 2006; Mike Frysinger <vapier@gentoo.org>
+ +quake3-1.33_alpha510.ebuild:
+ Version bump.
08 Jan 2006; Chris Gianelloni <wolf31o2@gentoo.org>
quake3-1.33_alpha255.ebuild, quake3-1.33_alpha364.ebuild:
diff --git a/games-fps/quake3/files/digest-quake3-1.33_alpha510 b/games-fps/quake3/files/digest-quake3-1.33_alpha510
new file mode 100644
index 000000000000..e21a32babc13
--- /dev/null
+++ b/games-fps/quake3/files/digest-quake3-1.33_alpha510
@@ -0,0 +1 @@
+MD5 4d13297f42d985634aa7f240a37f4c63 quake3-1.33_SVN510M.tar.bz2 2433264
diff --git a/games-fps/quake3/quake3-1.33_alpha510.ebuild b/games-fps/quake3/quake3-1.33_alpha510.ebuild
new file mode 100644
index 000000000000..7d8caffd542b
--- /dev/null
+++ b/games-fps/quake3/quake3-1.33_alpha510.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/quake3-1.33_alpha510.ebuild,v 1.1 2006/01/20 01:20:50 vapier Exp $
+
+# quake3-9999 -> latest svn
+# quake3-9999.REV -> use svn REV
+# quake3-VER_alphaREV -> svn snapshot REV for version VER
+# quake3-VER -> normal quake release
+
+if [[ ${PV} == 9999* ]] ; then
+ [[ ${PV} == 9999.* ]] && ESVN_UPDATE_CMD="svn up -r ${PV/9999.}"
+ ESVN_REPO_URI="svn://svn.icculus.org/quake3/trunk"
+ inherit subversion games toolchain-funcs
+
+ SRC_URI=""
+ S=${WORKDIR}/trunk
+elif [[ ${PV} == *_alpha* ]] ; then
+ inherit games toolchain-funcs
+
+ MY_PV=${PV/_alpha*}
+ SNAP=${PV/*_alpha}
+ MY_P=${PN}-${MY_PV}_SVN${SNAP}M
+ SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
+ S=${WORKDIR}/${MY_P}
+else
+ inherit games toolchain-funcs
+
+ SRC_URI="http://icculus.org/quake3/${P}.tar.bz2"
+fi
+
+DESCRIPTION="Quake III Arena - 3rd installment of the classic id 3D first-person shooter"
+HOMEPAGE="http://icculus.org/quake3/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="dedicated opengl"
+
+RDEPEND="opengl? (
+ virtual/opengl
+ media-libs/openal
+ || (
+ (
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp )
+ virtual/x11 )
+ media-libs/libsdl )
+ !dedicated? (
+ virtual/opengl
+ || (
+ (
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp )
+ virtual/x11 )
+ media-libs/libsdl )
+ games-fps/quake3-data"
+
+src_unpack() {
+ if [[ ${PV} == 9999* ]] ; then
+ subversion_src_unpack
+ else
+ unpack ${A}
+ fi
+}
+
+src_compile() {
+ buildit() { use $1 && echo 1 || echo 0 ; }
+ emake \
+ BUILD_SERVER=$(buildit dedicated) \
+ BUILD_CLIENT=$(buildit opengl) \
+ TEMPDIR="${T}" \
+ CC="$(tc-getCC)" \
+ ARCH=$(tc-arch-kernel) \
+ OPTIMIZE="${CFLAGS}" \
+ DEFAULT_BASEDIR="${GAMES_DATADIR}/quake3" \
+ DEFAULT_LIBDIR="${GAMES_LIBDIR}/quake3" \
+ || die
+}
+
+src_install() {
+ dodoc id-readme.txt TODO README BUGS ChangeLog
+ cd code/unix
+ dodoc README.*
+
+ doicon quake3.xpm
+ make_desktop_entry quake3 "Quake III Arena" quake3.xpm
+
+ cd ../../build/release*
+ local old_x x
+ for old_x in ioquake3* ; do
+ x=${old_x%.*}
+ newgamesbin ${old_x} ${x} || die "dobin ${x}"
+ dosym ${x} "${GAMES_BINDIR}"/${x/io}
+ done
+ exeinto "${GAMES_LIBDIR}"/${PN}/baseq3
+ doexe baseq3/*.so || die "baseq3 .so"
+ exeinto "${GAMES_LIBDIR}"/${PN}/missionpack
+ doexe missionpack/*.so || die "missionpack .so"
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ ewarn "The source version of Quake 3 will not work with Punk Buster."
+ ewarn "If you need pb support, then use the quake3-bin package."
+ echo
+}