summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-04-19 23:43:44 +0000
committerMike Frysinger <vapier@gentoo.org>2006-04-19 23:43:44 +0000
commit8031eee034d41913fd6e141694839412ea90da2a (patch)
tree335f49aab3ded78936c6be511ca9d47cb017e8f8 /games-fps/quake3
parentDrop release candidate versions. (diff)
downloadgentoo-2-8031eee034d41913fd6e141694839412ea90da2a.tar.gz
gentoo-2-8031eee034d41913fd6e141694839412ea90da2a.tar.bz2
gentoo-2-8031eee034d41913fd6e141694839412ea90da2a.zip
Version bump.
(Portage version: 2.1_pre9)
Diffstat (limited to 'games-fps/quake3')
-rw-r--r--games-fps/quake3/ChangeLog8
-rw-r--r--games-fps/quake3/files/digest-quake3-1.34_alpha7113
-rw-r--r--games-fps/quake3/quake3-1.34_alpha711.ebuild119
3 files changed, 129 insertions, 1 deletions
diff --git a/games-fps/quake3/ChangeLog b/games-fps/quake3/ChangeLog
index 39d1e8bfdae1..7318be5b4e11 100644
--- a/games-fps/quake3/ChangeLog
+++ b/games-fps/quake3/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-fps/quake3
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/ChangeLog,v 1.35 2006/03/31 02:11:39 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/ChangeLog,v 1.36 2006/04/19 23:43:44 vapier Exp $
+
+*quake3-1.34_alpha711 (19 Apr 2006)
+
+ 19 Apr 2006; Mike Frysinger <vapier@gentoo.org>
+ +quake3-1.34_alpha711.ebuild:
+ Version bump.
31 Mar 2006; Chris Gianelloni <wolf31o2@gentoo.org>
quake3-1.34_alpha632.ebuild, quake3-9999.ebuild:
diff --git a/games-fps/quake3/files/digest-quake3-1.34_alpha711 b/games-fps/quake3/files/digest-quake3-1.34_alpha711
new file mode 100644
index 000000000000..d4b1a476ea85
--- /dev/null
+++ b/games-fps/quake3/files/digest-quake3-1.34_alpha711
@@ -0,0 +1,3 @@
+MD5 a0ee79e4207ef90b8554ad64455b1ae2 quake3-1.34_SVN711M.tar.bz2 2449317
+RMD160 fb266ef356721658143b5bcc2732215763ae56e5 quake3-1.34_SVN711M.tar.bz2 2449317
+SHA256 25c423ed6222a8cf42b59499940bdad5f7f33dcad3d2102964578df237b9299c quake3-1.34_SVN711M.tar.bz2 2449317
diff --git a/games-fps/quake3/quake3-1.34_alpha711.ebuild b/games-fps/quake3/quake3-1.34_alpha711.ebuild
new file mode 100644
index 000000000000..86c2d0a62750
--- /dev/null
+++ b/games-fps/quake3/quake3-1.34_alpha711.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/quake3-1.34_alpha711.ebuild,v 1.1 2006/04/19 23:43:44 vapier Exp $
+
+# quake3-9999 -> latest svn
+# quake3-9999.REV -> use svn REV
+# quake3-VER_alphaREV -> svn snapshot REV for version VER
+# quake3-VER -> normal quake release
+
+if [[ ${PV} == 9999* ]] ; then
+ [[ ${PV} == 9999.* ]] && ESVN_UPDATE_CMD="svn up -r ${PV/9999./}"
+ ESVN_REPO_URI="svn://svn.icculus.org/quake3/trunk"
+ inherit subversion toolchain-funcs eutils games
+
+ SRC_URI=""
+ S=${WORKDIR}/trunk
+elif [[ ${PV} == *_alpha* ]] ; then
+ inherit toolchain-funcs eutils games
+
+ MY_PV=${PV/_alpha*/}
+ SNAP=${PV/*_alpha/}
+ MY_P=${PN}-${MY_PV}_SVN${SNAP}M
+ SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
+ S=${WORKDIR}/${MY_P}
+else
+ inherit toolchain-funcs eutils games
+
+ SRC_URI="http://icculus.org/quake3/${P}.tar.bz2"
+fi
+
+DESCRIPTION="Quake III Arena - 3rd installment of the classic id 3D first-person shooter"
+HOMEPAGE="http://icculus.org/quake3/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="dedicated opengl"
+
+RDEPEND="opengl? (
+ virtual/opengl
+ media-libs/openal
+ || (
+ (
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp )
+ virtual/x11 )
+ media-libs/libsdl )
+ !dedicated? (
+ virtual/opengl
+ || (
+ (
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp )
+ virtual/x11 )
+ media-libs/libsdl )
+ games-fps/quake3-data
+ teamarena? ( games-fps/quake3-teamarena )"
+
+src_unpack() {
+ if [[ ${PV} == 9999* ]] ; then
+ subversion_src_unpack
+ else
+ unpack ${A}
+ fi
+ # This is a dirty hack around bug #121428 and should be removed once the
+ # upstream bug https://bugzilla.icculus.org/show_bug.cgi?id=2634 has been
+ # resolved.
+ sed -i -e 's|botlib.log|/dev/null|' ${S}/code/botlib/be_interface.c
+}
+
+src_compile() {
+ buildit() { use $1 && echo 1 || echo 0 ; }
+ emake \
+ BUILD_SERVER=$(buildit dedicated) \
+ BUILD_CLIENT=$(buildit opengl) \
+ TEMPDIR="${T}" \
+ CC="$(tc-getCC)" \
+ ARCH=$(tc-arch-kernel) \
+ OPTIMIZE="${CFLAGS}" \
+ DEFAULT_BASEDIR="${GAMES_DATADIR}/quake3" \
+ DEFAULT_LIBDIR="${GAMES_LIBDIR}/quake3" \
+ || die
+}
+
+src_install() {
+ dodoc id-readme.txt TODO README BUGS ChangeLog
+ cd code/unix
+ dodoc README.*
+
+ if use opengl ; then
+ doicon quake3.png
+ make_desktop_entry quake3 "Quake III Arena"
+ fi
+
+ cd ../../build/release*
+ local old_x x
+ for old_x in ioq* ; do
+ x=${old_x%.*}
+ newgamesbin ${old_x} ${x} || die "newgamesbin ${x}"
+ dosym ${x} "${GAMES_BINDIR}"/${x/io}
+ done
+ exeinto "${GAMES_LIBDIR}"/${PN}/baseq3
+ doexe baseq3/*.so || die "baseq3 .so"
+ exeinto "${GAMES_LIBDIR}"/${PN}/missionpack
+ doexe missionpack/*.so || die "missionpack .so"
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ ewarn "The source version of Quake 3 will not work with Punk Buster."
+ ewarn "If you need pb support, then use the quake3-bin package."
+ echo
+}