summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-10-26 00:29:12 +0000
committerMike Frysinger <vapier@gentoo.org>2005-10-26 00:29:12 +0000
commit3f47f51de0777eaa4dd02cae475a0b971a33ba47 (patch)
treeb6962e209693029e600ffa08060922afae79253f /games-fps/quake3
parent-move games-fps/quake3 games-fps/quake3-bin (diff)
downloadgentoo-2-3f47f51de0777eaa4dd02cae475a0b971a33ba47.tar.gz
gentoo-2-3f47f51de0777eaa4dd02cae475a0b971a33ba47.tar.bz2
gentoo-2-3f47f51de0777eaa4dd02cae475a0b971a33ba47.zip
initial version of quake3-from-source #103591
(Portage version: 2.0.53_rc6)
Diffstat (limited to 'games-fps/quake3')
-rw-r--r--games-fps/quake3/ChangeLog10
-rw-r--r--games-fps/quake3/Manifest2
-rw-r--r--games-fps/quake3/files/digest-quake3-1.33_alpha1771
-rw-r--r--games-fps/quake3/metadata.xml18
-rw-r--r--games-fps/quake3/quake3-1.33_alpha177.ebuild72
5 files changed, 103 insertions, 0 deletions
diff --git a/games-fps/quake3/ChangeLog b/games-fps/quake3/ChangeLog
new file mode 100644
index 000000000000..551c05cc7d7e
--- /dev/null
+++ b/games-fps/quake3/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-fps/quake3
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/ChangeLog,v 1.24 2005/10/26 00:29:12 vapier Exp $
+
+*quake3-1.33_alpha177 (26 Oct 2005)
+
+ 26 Oct 2005; Mike Frysinger <vapier@gentoo.org> +metadata.xml,
+ +quake3-1.33_alpha177.ebuild:
+ Initial version of quake3-from-source #103591.
+
diff --git a/games-fps/quake3/Manifest b/games-fps/quake3/Manifest
new file mode 100644
index 000000000000..09b5cc78edbb
--- /dev/null
+++ b/games-fps/quake3/Manifest
@@ -0,0 +1,2 @@
+MD5 0b69f4d246be341cc59cdfee97f91a6a files/digest-quake3-1.33_alpha177 73
+MD5 b26bc54db8bbbd34423b6ea58c0f2f37 quake3-1.33_alpha177.ebuild 1564
diff --git a/games-fps/quake3/files/digest-quake3-1.33_alpha177 b/games-fps/quake3/files/digest-quake3-1.33_alpha177
new file mode 100644
index 000000000000..819a771598d1
--- /dev/null
+++ b/games-fps/quake3/files/digest-quake3-1.33_alpha177
@@ -0,0 +1 @@
+MD5 5ddd5ee10d87fb1586d40095f65469c8 quake3-1.33_SVN177M.tar.bz2 2529215
diff --git a/games-fps/quake3/metadata.xml b/games-fps/quake3/metadata.xml
new file mode 100644
index 000000000000..f4f43499c2b3
--- /dev/null
+++ b/games-fps/quake3/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription>
+Quake III Arena is the third installment of the extremely popular and
+successful Quake series by id software. The game was released by id
+software for both Windows and Linux. The Linux version of the game was
+maintained and sold by the now defunct Loki Entertainment. The powerful
+Quake III engine is the basis for many other commercial games, as id's
+major source of revenue is licensing their game engines. The engine
+allows for user-contributed modifications to be made, allowing the game
+to be extensible and expandable. This game is commercial software, and
+requires the data from a retail copy of the game to play. If you're
+interested in checking out the technology behind Quake III, then
+"emerge quake3-demo" to get the playable demo.
+</longdescription>
+</pkgmetadata>
diff --git a/games-fps/quake3/quake3-1.33_alpha177.ebuild b/games-fps/quake3/quake3-1.33_alpha177.ebuild
new file mode 100644
index 000000000000..c621e4809e96
--- /dev/null
+++ b/games-fps/quake3/quake3-1.33_alpha177.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/quake3-1.33_alpha177.ebuild,v 1.1 2005/10/26 00:29:12 vapier Exp $
+
+if [[ ${PV} == "9999" ]] ; then
+ ESVN_REPO_URI="svn://svn.icculus.org/quake3/trunk"
+ inherit subversion games toolchain-funcs
+
+ SRC_URI=""
+ S=${WORKDIR}/trunk
+elif [[ ${PV} == *_alpha* ]] ; then
+ inherit games toolchain-funcs
+
+ MY_PV=${PV/_alpha*}
+ SNAP=${PV/*_alpha}
+ MY_P=${PN}-${MY_PV}_SVN${SNAP}M
+ SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
+ S=${WORKDIR}/${MY_P}
+else
+ inherit games toolchain-funcs
+
+ SRC_URI="http://icculus.org/quake3/${P}.tar.bz2"
+fi
+
+DESCRIPTION="Quake III Arena - 3rd installment of the classic id 3D first-person shooter"
+HOMEPAGE="http://icculus.org/quake3/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dedicated opengl"
+
+RDEPEND="opengl? ( virtual/opengl virtual/x11 )
+ games-fps/quake3-data"
+
+src_unpack() {
+ if [[ ${PV} == "9999" ]] ; then
+ subversion_src_unpack
+ else
+ unpack ${A}
+ fi
+}
+
+src_compile() {
+ emake \
+ TEMPDIR="${T}" \
+ CC="$(tc-getCC)" \
+ ARCH=$(tc-arch-kernel) \
+ OPTIMIZE="${CFLAGS}" \
+ DEFAULT_BASEDIR="${GAMES_DATADIR}/quake3" \
+ || die
+}
+
+src_install() {
+ dodoc id-readme.txt i_o-q3-readme
+ cd code/unix
+ dodoc ChangeLog README*
+
+ doicon quake3.xpm
+ make_desktop_entry quake3 "Quake III Arena" quake3.xpm
+
+ cd release*
+ for x in linux* ; do
+ newgamesbin ${x} ${x/linux} || die "dobin ${x}"
+ done
+ exeinto ${GAMES_LIBDIR}/${PN}/baseq3
+ doexe baseq3/*.so || die "baseq3 .so"
+ exeinto ${GAMES_LIBDIR}/${PN}/missionpack
+ doexe missionpack/*.so || die "missionpack .so"
+
+ prepgamesdirs
+}