summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-07-24 21:19:53 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-07-24 21:19:53 +0000
commit1931cde7330846fc27932e3c7ba5e8e790d95132 (patch)
tree843faff5b6038840477b2963fbed35d334ee071f /games-fps/quake3-cpma
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-1931cde7330846fc27932e3c7ba5e8e790d95132.tar.gz
gentoo-2-1931cde7330846fc27932e3c7ba5e8e790d95132.tar.bz2
gentoo-2-1931cde7330846fc27932e3c7ba5e8e790d95132.zip
version bump (bug #204954)
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-fps/quake3-cpma')
-rw-r--r--games-fps/quake3-cpma/ChangeLog10
-rw-r--r--games-fps/quake3-cpma/quake3-cpma-1.46.ebuild36
2 files changed, 44 insertions, 2 deletions
diff --git a/games-fps/quake3-cpma/ChangeLog b/games-fps/quake3-cpma/ChangeLog
index e867eb683516..fa5ccf32be8e 100644
--- a/games-fps/quake3-cpma/ChangeLog
+++ b/games-fps/quake3-cpma/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-fps/quake3-cpma
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3-cpma/ChangeLog,v 1.17 2007/08/17 23:27:40 wolf31o2 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3-cpma/ChangeLog,v 1.18 2009/07/24 21:19:53 mr_bones_ Exp $
+
+*quake3-cpma-1.46 (24 Jul 2009)
+
+ 24 Jul 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +quake3-cpma-1.46.ebuild:
+ version bump (bug #204954)
*quake3-cpma-1.43 (17 Aug 2007)
diff --git a/games-fps/quake3-cpma/quake3-cpma-1.46.ebuild b/games-fps/quake3-cpma/quake3-cpma-1.46.ebuild
new file mode 100644
index 000000000000..b5a1a65c4112
--- /dev/null
+++ b/games-fps/quake3-cpma/quake3-cpma-1.46.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3-cpma/quake3-cpma-1.46.ebuild,v 1.1 2009/07/24 21:19:53 mr_bones_ Exp $
+
+MOD_DESC="advanced FPS competition mod"
+MOD_NAME="Challenge Pro Mode Arena"
+MOD_DIR="cpma"
+
+inherit games games-mods
+
+HOMEPAGE="http://www.promode.org/"
+SRC_URI="http://www.challenge-tv.com/demostorage/files/cpm/cpma${PV//.}-nomaps.zip
+ http://ftp1.srv.endpoint.nu/pub/repository/challenge-tv/demostorage/files/cpm/cpma${PV//.}-nomaps.zip
+ http://www.promode.org/files/cpma-mappack-full.zip"
+
+LICENSE="as-is"
+
+KEYWORDS="-* ~amd64 ~ppc ~x86"
+
+RDEPEND="ppc? ( games-fps/${GAME} )
+ !ppc? (
+ || (
+ games-fps/${GAME}
+ games-fps/${GAME}-bin ) )"
+
+src_install() {
+ insinto "${GAMES_DATADIR}/${GAME}/baseq3"
+ doins "${WORKDIR}"/*.pk3 || die "pk3"
+
+ games-mods_src_install
+}
+
+pkg_postinst() {
+ games-mods_pkg_postinst
+ elog " To enable bots add: +bot_enable 1"
+}