summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-10-23 20:05:08 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-10-23 20:05:08 +0000
commit94e040b5b84365265f84f65182c34ce1a8359c07 (patch)
tree98e022cc9c0ad667e17fe3b43129a4719b7ecd75 /games-fps/quake3-alternatefire
parentdev-perl/rpm (diff)
downloadgentoo-2-94e040b5b84365265f84f65182c34ce1a8359c07.tar.gz
gentoo-2-94e040b5b84365265f84f65182c34ce1a8359c07.tar.bz2
gentoo-2-94e040b5b84365265f84f65182c34ce1a8359c07.zip
Added new revision for testing which uses the brand-spankin-new games-mods.eclass to reduce ebuild code.
(Portage version: 2.1.2_pre3-r5)
Diffstat (limited to 'games-fps/quake3-alternatefire')
-rw-r--r--games-fps/quake3-alternatefire/ChangeLog11
-rw-r--r--games-fps/quake3-alternatefire/files/digest-quake3-alternatefire-2.02
-rw-r--r--games-fps/quake3-alternatefire/files/digest-quake3-alternatefire-2.0-r13
-rw-r--r--games-fps/quake3-alternatefire/quake3-alternatefire-2.0-r1.ebuild22
4 files changed, 36 insertions, 2 deletions
diff --git a/games-fps/quake3-alternatefire/ChangeLog b/games-fps/quake3-alternatefire/ChangeLog
index afdc6c55f6f0..04c989a02135 100644
--- a/games-fps/quake3-alternatefire/ChangeLog
+++ b/games-fps/quake3-alternatefire/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-fps/quake3-alternatefire
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3-alternatefire/ChangeLog,v 1.5 2004/06/24 22:44:03 agriffis Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3-alternatefire/ChangeLog,v 1.6 2006/10/23 20:05:08 wolf31o2 Exp $
+
+*quake3-alternatefire-2.0-r1 (23 Oct 2006)
+
+ 23 Oct 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ +quake3-alternatefire-2.0-r1.ebuild:
+ Added new revision for testing which uses the brand-spankin-new
+ games-mods.eclass to reduce ebuild code.
*quake3-alternatefire-2.0 (29 Nov 2002)
diff --git a/games-fps/quake3-alternatefire/files/digest-quake3-alternatefire-2.0 b/games-fps/quake3-alternatefire/files/digest-quake3-alternatefire-2.0
index 6f1eeb73b39c..7048fd5fdf66 100644
--- a/games-fps/quake3-alternatefire/files/digest-quake3-alternatefire-2.0
+++ b/games-fps/quake3-alternatefire/files/digest-quake3-alternatefire-2.0
@@ -1 +1,3 @@
MD5 31aa389d47b4eb6f34c6869a978e409e alternatefire-2.0.zip 2015159
+RMD160 da16c05c5200ea0ccc49b839a27a26c9dcee6391 alternatefire-2.0.zip 2015159
+SHA256 8964bc680b713753b103d54211af46895990d6d10243102a2a13b01eaa678cbe alternatefire-2.0.zip 2015159
diff --git a/games-fps/quake3-alternatefire/files/digest-quake3-alternatefire-2.0-r1 b/games-fps/quake3-alternatefire/files/digest-quake3-alternatefire-2.0-r1
new file mode 100644
index 000000000000..7048fd5fdf66
--- /dev/null
+++ b/games-fps/quake3-alternatefire/files/digest-quake3-alternatefire-2.0-r1
@@ -0,0 +1,3 @@
+MD5 31aa389d47b4eb6f34c6869a978e409e alternatefire-2.0.zip 2015159
+RMD160 da16c05c5200ea0ccc49b839a27a26c9dcee6391 alternatefire-2.0.zip 2015159
+SHA256 8964bc680b713753b103d54211af46895990d6d10243102a2a13b01eaa678cbe alternatefire-2.0.zip 2015159
diff --git a/games-fps/quake3-alternatefire/quake3-alternatefire-2.0-r1.ebuild b/games-fps/quake3-alternatefire/quake3-alternatefire-2.0-r1.ebuild
new file mode 100644
index 000000000000..b6a9642eb41c
--- /dev/null
+++ b/games-fps/quake3-alternatefire/quake3-alternatefire-2.0-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3-alternatefire/quake3-alternatefire-2.0-r1.ebuild,v 1.1 2006/10/23 20:05:08 wolf31o2 Exp $
+
+MOD_DESC="adds unique new secondary attacks to weapons"
+MOD_NAME="Alternate Fire"
+MOD_DIR="alternatefire"
+
+inherit games games-mods
+
+SRC_URI="http://network3.filefront.com/planetquake3/alternatefire-${PV}.zip"
+HOMEPAGE="http://www.planetquake.com/alternatefire/"
+
+LICENSE="freedist"
+
+KEYWORDS="-* ~amd64 ~ppc ~x86"
+
+RDEPEND="ppc? ( games-fps/${GAME} )
+ !ppc? (
+ || (
+ games-fps/${GAME}
+ games-fps/${GAME}-bin ) )"