summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-10-05 02:29:36 +0000
committerMike Frysinger <vapier@gentoo.org>2003-10-05 02:29:36 +0000
commit711b8dfe42707c51be4ef027cf4d602d4eb2d925 (patch)
treecd25138965aa67ad1857b060ada553ff8e352b4a /games-fps/quake3-alternatefire
parentmmm quake3 (diff)
downloadgentoo-2-711b8dfe42707c51be4ef027cf4d602d4eb2d925.tar.gz
gentoo-2-711b8dfe42707c51be4ef027cf4d602d4eb2d925.tar.bz2
gentoo-2-711b8dfe42707c51be4ef027cf4d602d4eb2d925.zip
quake3
Diffstat (limited to 'games-fps/quake3-alternatefire')
-rw-r--r--games-fps/quake3-alternatefire/ChangeLog11
-rw-r--r--games-fps/quake3-alternatefire/files/digest-quake3-alternatefire-2.01
-rw-r--r--games-fps/quake3-alternatefire/files/server.cfg109
-rw-r--r--games-fps/quake3-alternatefire/quake3-alternatefire-2.0.ebuild12
4 files changed, 133 insertions, 0 deletions
diff --git a/games-fps/quake3-alternatefire/ChangeLog b/games-fps/quake3-alternatefire/ChangeLog
new file mode 100644
index 000000000000..5ba68b98b46e
--- /dev/null
+++ b/games-fps/quake3-alternatefire/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for games-fps/quake3-alternatefire
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3-alternatefire/ChangeLog,v 1.4 2003/10/05 02:26:20 vapier Exp $
+
+*quake3-alternatefire-2.0 (29 Nov 2002)
+
+ 15 Jul 2003; Mike Frysinger <vapier@gentoo.org> :
+ Updated to use games-q3mod.eclass #23871.
+
+ 29 Nov 2002; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by CJ Kucera <pez@apocalyptech.com>.
diff --git a/games-fps/quake3-alternatefire/files/digest-quake3-alternatefire-2.0 b/games-fps/quake3-alternatefire/files/digest-quake3-alternatefire-2.0
new file mode 100644
index 000000000000..6f1eeb73b39c
--- /dev/null
+++ b/games-fps/quake3-alternatefire/files/digest-quake3-alternatefire-2.0
@@ -0,0 +1 @@
+MD5 31aa389d47b4eb6f34c6869a978e409e alternatefire-2.0.zip 2015159
diff --git a/games-fps/quake3-alternatefire/files/server.cfg b/games-fps/quake3-alternatefire/files/server.cfg
new file mode 100644
index 000000000000..0ee5c8a202e3
--- /dev/null
+++ b/games-fps/quake3-alternatefire/files/server.cfg
@@ -0,0 +1,109 @@
+// Sample .cfg file for the Alternate Fire mod
+// ==================================================================
+
+// It's set up for CTF, since that's my favorite game type :)
+// (besides, the lightning web is just awesome in CTF).
+
+// ---- General setup ----
+
+seta sv_pure 1
+seta sv_hostname "Gentoo - Alternate Fire"
+seta sv_maxclients 10
+seta sv_floodprotect 0
+seta g_motd "Welcome to AlternateFire"
+seta g_allowVote 1
+
+// Kick 'em after 3 minutes if they go inactive
+seta g_inactivity 180
+
+// Yes, they do need the z-alternatefire-0xx.pk3
+// Make sure it's in the right place ("alternatefire", not "baseq3")
+// (If you're running this on Linux, put it in ~/.q3a/alternatefire
+// or it won't upload)
+seta sv_allowDownload 1
+// Also, make sure you remove the old .pk3 when you upgrade!
+
+// ---- Bots ----
+
+seta bot_enable 1
+// This is per-team in team games
+seta bot_minplayers 4
+
+// ---- Game parameters ----
+
+// 0 - Free For All, 1 - Tournament,
+// 3 - Team Deathmatch, 4 - Capture the Flag
+seta g_gametype 4
+seta capturelimit 8
+seta timelimit 20
+seta g_friendlyFire 0
+
+// ---- Extra-special new stuff ----
+
+// Uncomment this if you want no falling damage
+//g_fallingDamage 0
+
+// Uncomment this if you want self damage to only damage armor
+// Set it to 0 to disable self damage altogether (default: 2)
+//g_selfDamage 1
+
+// Uncomment this if you like to play CTF the "old" way
+// (the player only has to touch his flag to return it)
+//g_returnFlag 0
+
+// Uncomment this if you want a mad, mad, mad game of
+// multi-flag CTF (everyone can have their own flag!)
+//g_multiFlag 1
+
+// Uncomment this if you want an offhand grapple
+// Your players will need to bind +button6 to something,
+// or set up their grapples in SETUP->CONTROLS->SHOOT
+// WARNING: The grappling hook IS NOT client-side predicted,
+// which means it's awful for anybody with a ping over 100
+//g_offhandGrapple 1
+
+// ---- Chat/Name Filter ----
+
+// ** PLEASE READ THE README BEFORE ENABLING THESE OPTIONS **
+
+// Uncomment this to force every client's chat filter on
+// They can override this in the GAME OPTIONS menu - which
+// means that setting this really just makes the chat filter
+// opt-out
+//g_forceChatFilter 1
+
+// Uncomment this to force every client's name filter and
+// kick players with dirty names
+//g_forceNameFilter 1
+
+// ** Be careful with the next two - the chat filter may
+// act differently than you think. Read the README. **
+
+// Use this to add words for chat filtering (separate words
+// with spaces, use an underscore ("_") in place of a space
+// if you need to filter phrases)
+//g_filteredWords
+
+// Use this to filter additional names - same format as above
+//g_filteredNames "bin_laden terrorist"
+
+// ---- Map rotation ----
+
+// An id/threewave CTF map rotation
+// Even if you don't use this rotation, I suggest using "d1"
+// as the command for the first map, since players can vote
+// to reset the map rotation. That action will set nextmap
+// to "vstr d1".
+set d1 "map q3ctf1; set nextmap vstr d2"
+set d2 "map q3wctf2; set nextmap vstr d3"
+set d3 "map q3ctf4; set nextmap vstr d4"
+set d4 "map q3wctf1; set nextmap vstr d5"
+set d5 "map q3ctf2; set nextmap vstr d6"
+set d6 "map q3wctf3; set nextmap vstr d7"
+set d7 "map q3ctf3; set nextmap vstr d1"
+vstr d1
+
+// If you want to change the game type (and other things) per map, do stuff like this:
+//set d1 "set g_gametype 0; set fraglimit 20; map q3dm17; set nextmap vstr d2"
+//set d2 "set g_gametype 1; set fraglimit 15; set timelimit 10; map q3tourney3; set nextmap vstr d1"
+//vstr d1
diff --git a/games-fps/quake3-alternatefire/quake3-alternatefire-2.0.ebuild b/games-fps/quake3-alternatefire/quake3-alternatefire-2.0.ebuild
new file mode 100644
index 000000000000..c080a6e046ff
--- /dev/null
+++ b/games-fps/quake3-alternatefire/quake3-alternatefire-2.0.ebuild
@@ -0,0 +1,12 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3-alternatefire/quake3-alternatefire-2.0.ebuild,v 1.3 2003/10/05 02:26:20 vapier Exp $
+
+MOD_DESC="Alternate Fire"
+MOD_NAME=alternatefire
+inherit games games-q3mod
+
+SRC_URI="http://network3.filefront.com/planetquake3/alternatefire-${PV}.zip"
+HOMEPAGE="http://www.planetquake.com/alternatefire/"
+
+LICENSE="freedist"