summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-16 23:56:01 +0000
committerMike Frysinger <vapier@gentoo.org>2005-01-16 23:56:01 +0000
commitc7d09e8c8912be95044f2dfd78a0a4b7dfee98e2 (patch)
tree28e4a33bb94cac04147005faf077ffa08edf6d7d /games-fps/quake1-rally
parentunset libdir srcdir objdir since they may contain settings for previous modules. (diff)
downloadgentoo-2-c7d09e8c8912be95044f2dfd78a0a4b7dfee98e2.tar.gz
gentoo-2-c7d09e8c8912be95044f2dfd78a0a4b7dfee98e2.tar.bz2
gentoo-2-c7d09e8c8912be95044f2dfd78a0a4b7dfee98e2.zip
make sure we extract with -LL
(Portage version: 2.0.51-r13)
Diffstat (limited to 'games-fps/quake1-rally')
-rw-r--r--games-fps/quake1-rally/quake1-rally-1.2.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/games-fps/quake1-rally/quake1-rally-1.2.ebuild b/games-fps/quake1-rally/quake1-rally-1.2.ebuild
index 8a7ece3d8337..18475cd89347 100644
--- a/games-fps/quake1-rally/quake1-rally-1.2.ebuild
+++ b/games-fps/quake1-rally/quake1-rally-1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake1-rally/quake1-rally-1.2.ebuild,v 1.1 2005/01/16 22:48:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake1-rally/quake1-rally-1.2.ebuild,v 1.2 2005/01/16 23:56:01 vapier Exp $
inherit games eutils
@@ -22,9 +22,9 @@ S=${WORKDIR}
src_unpack() {
echo ">>> Unpacking qr12.zip to ${PWD}"
- unzip -qoL "${DISTDIR}"/qr12.zip || die "unpacking qr12.zip failed"
+ unzip -qoLL "${DISTDIR}"/qr12.zip || die "unpacking qr12.zip failed"
echo ">>> Unpacking qrlo1.zip to ${PWD}"
- unzip -qoL "${DISTDIR}"/qrlo1.zip || die "unpacking qrlo1.zip failed"
+ unzip -qoLL "${DISTDIR}"/qrlo1.zip || die "unpacking qrlo1.zip failed"
rm -f button.wav qrally.exe
cd rally
edos2unix $(find . -name '*.txt' -o -name '*.cfg')
@@ -35,6 +35,6 @@ src_install() {
local dir=${GAMES_DATADIR}/quake-data
dodir "${dir}"
insinto "${dir}"
- doins -r *
+ doins -r * || die "doins"
prepgamesdirs
}