summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-16 23:01:21 +0000
committerMike Frysinger <vapier@gentoo.org>2005-01-16 23:01:21 +0000
commitbc7e15e36e89efe534cd0b0a865efd3cf1b4afd5 (patch)
tree72d566129ea5a36d95b28f9b4f6013453667871f /games-fps/quake1-killer/quake1-killer-2.2z.ebuild
parentFixes for hardened-gccs, trying to solve bug #52642 (diff)
downloadgentoo-2-bc7e15e36e89efe534cd0b0a865efd3cf1b4afd5.tar.gz
gentoo-2-bc7e15e36e89efe534cd0b0a865efd3cf1b4afd5.tar.bz2
gentoo-2-bc7e15e36e89efe534cd0b0a865efd3cf1b4afd5.zip
initial import
(Portage version: 2.0.51-r13)
Diffstat (limited to 'games-fps/quake1-killer/quake1-killer-2.2z.ebuild')
-rw-r--r--games-fps/quake1-killer/quake1-killer-2.2z.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/games-fps/quake1-killer/quake1-killer-2.2z.ebuild b/games-fps/quake1-killer/quake1-killer-2.2z.ebuild
new file mode 100644
index 000000000000..2ba385814a61
--- /dev/null
+++ b/games-fps/quake1-killer/quake1-killer-2.2z.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake1-killer/quake1-killer-2.2z.ebuild,v 1.1 2005/01/16 23:01:21 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="The Killer Quake Patch"
+HOMEPAGE="http://kqp.mpog.com/ http://www.planetquake.com/qca/reviews/patch143.htm"
+SRC_URI="http://www.gamers.org/pub/idgames2/quakec/compilations/kqp220z.zip
+ mirror://gentoo/kqp220z.zip"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}
+
+src_unpack() {
+ echo ">>> Unpacking kqp220z.zip to ${PWD}"
+ unzip -qoL "${DISTDIR}"/kqp220z.zip || die "unpacking kqp220z.zip failed"
+}
+
+src_install() {
+ local dir=${GAMES_DATADIR}/quake-data/killer
+ dodir "${dir}"
+ insinto "${dir}"
+ doins -r *
+ prepgamesdirs
+}