summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-10-30 07:27:52 +0000
committerMike Frysinger <vapier@gentoo.org>2003-10-30 07:27:52 +0000
commit27f3fae3f329101acee221d0bf4404ea6bab2e89 (patch)
tree3c7cb12baed60620b38fad451cd0aabeb6fb6abf /games-fps/industri
parentremove useless white space (diff)
downloadgentoo-2-27f3fae3f329101acee221d0bf4404ea6bab2e89.tar.gz
gentoo-2-27f3fae3f329101acee221d0bf4404ea6bab2e89.tar.bz2
gentoo-2-27f3fae3f329101acee221d0bf4404ea6bab2e89.zip
initial ebuild
Diffstat (limited to 'games-fps/industri')
-rw-r--r--games-fps/industri/ChangeLog8
-rw-r--r--games-fps/industri/files/1.01-nvidia-opengl.patch20
-rw-r--r--games-fps/industri/files/digest-industri-1.012
-rw-r--r--games-fps/industri/files/industri.pretty2
-rw-r--r--games-fps/industri/industri-1.01.ebuild62
-rw-r--r--games-fps/industri/metadata.xml18
6 files changed, 112 insertions, 0 deletions
diff --git a/games-fps/industri/ChangeLog b/games-fps/industri/ChangeLog
new file mode 100644
index 000000000000..885ab51b31c2
--- /dev/null
+++ b/games-fps/industri/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for games-fps/industri
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/industri/ChangeLog,v 1.1 2003/10/30 07:27:52 vapier Exp $
+
+*industri-1.01 (30 Oct 2003)
+
+ 30 Oct 2003; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by me.
diff --git a/games-fps/industri/files/1.01-nvidia-opengl.patch b/games-fps/industri/files/1.01-nvidia-opengl.patch
new file mode 100644
index 000000000000..1bbd5f1e585b
--- /dev/null
+++ b/games-fps/industri/files/1.01-nvidia-opengl.patch
@@ -0,0 +1,20 @@
+--- glquake.h 2003-07-14 17:06:01.000000000 -0400
++++ ../../glquake.h 2003-07-15 02:24:09.000000000 -0400
+@@ -657,7 +657,7 @@
+ #endif /* !__APPLE__ && !MACOSX */
+
+ // - DC -
+-#if !defined(SDL) && !defined (__glx__)
++//#if !defined(SDL) && !defined (__glx__)
+ typedef void (APIENTRY * PFNGLCOMBINERPARAMETERFVNVPROC) (GLenum pname, const GLfloat *params);
+ typedef void (APIENTRY * PFNGLCOMBINERPARAMETERFNVPROC) (GLenum pname, GLfloat param);
+ typedef void (APIENTRY * PFNGLCOMBINERPARAMETERIVNVPROC) (GLenum pname, const GLint *params);
+@@ -671,7 +671,7 @@
+ typedef void (APIENTRY * PFNGLGETCOMBINEROUTPUTPARAMETERIVNVPROC) (GLenum stage, GLenum portion, GLenum pname, GLint *params);
+ typedef void (APIENTRY * PFNGLGETFINALCOMBINERINPUTPARAMETERFVNVPROC) (GLenum variable, GLenum pname, GLfloat *params);
+ typedef void (APIENTRY * PFNGLGETFINALCOMBINERINPUTPARAMETERIVNVPROC) (GLenum variable, GLenum pname, GLint *params);
+-#endif
++//#endif
+
+ extern PFNGLCOMBINERPARAMETERFVNVPROC qglCombinerParameterfvNV;
+ extern PFNGLCOMBINERPARAMETERIVNVPROC qglCombinerParameterivNV;
diff --git a/games-fps/industri/files/digest-industri-1.01 b/games-fps/industri/files/digest-industri-1.01
new file mode 100644
index 000000000000..b1c96738d599
--- /dev/null
+++ b/games-fps/industri/files/digest-industri-1.01
@@ -0,0 +1,2 @@
+MD5 edb5be2c2ef71a74f5fbaaf6cfeeece1 industri_BIN-1.01-src.tar.gz 1086838
+MD5 5c34bb609a4ba5b1df88e5b76cf1934d industri-1.00.zip 30339989
diff --git a/games-fps/industri/files/industri.pretty b/games-fps/industri/files/industri.pretty
new file mode 100644
index 000000000000..b328c803b9df
--- /dev/null
+++ b/games-fps/industri/files/industri.pretty
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec industri +sh_glares 1 "$@"
diff --git a/games-fps/industri/industri-1.01.ebuild b/games-fps/industri/industri-1.01.ebuild
new file mode 100644
index 000000000000..6d82c737510f
--- /dev/null
+++ b/games-fps/industri/industri-1.01.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/industri/industri-1.01.ebuild,v 1.1 2003/10/30 07:27:52 vapier Exp $
+
+inherit games
+
+DESCRIPTION="Quake/Tenebrae based, single player game"
+HOMEPAGE="http://industri.sourceforge.net/"
+SRC_URI="mirror://sourceforge/industri/industri_BIN-${PV}-src.tar.gz
+ mirror://sourceforge/industri/industri-1.00.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/opengl
+ virtual/x11
+ sdl? ( media-libs/libsdl )
+ media-libs/libpng
+ sys-libs/zlib"
+
+S=${WORKDIR}/industri_BIN
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/linux
+ mv Makefile.i386linux Makefile
+ local gl="`ls -al /usr/include/GL/gl.h | awk '{print $NF}' | cut -d/ -f5`"
+ [ "${gl}" == "nvidia" ] && epatch ${FILESDIR}/${PV}-nvidia-opengl.patch
+ sed -i "s:-mpentiumpro.*:${CFLAGS} \\\\:" Makefile
+
+# if [ `use sdl` ] ; then
+# cd ${S}/sdl
+# ./autogen.sh || die "autogen failed"
+# fi
+}
+
+src_compile() {
+ cd linux
+ emake MASTER_DIR=${GAMES_DATADIR}/quake-data build_release || die
+
+# if [ `use sdl` ] ; then
+# cd ${S}/sdl
+# export GAMEDIR=${GAMES_DATADIR}/quake-data
+# egamesconf || die
+# emake || die "emake failed"
+# fi
+}
+
+src_install() {
+ newgamesbin linux/release*/bin/industri.run industri
+ dogamesbin ${FILESDIR}/industri.pretty
+ insinto /usr/share/icons
+ doins industri.ico quake.ico
+ dodoc linux/README
+ cd ${WORKDIR}/industri
+ dodoc *.txt && rm *.txt
+ insinto ${GAMES_DATADIR}/quake-data/industri
+ doins *
+ prepgamesdirs
+}
diff --git a/games-fps/industri/metadata.xml b/games-fps/industri/metadata.xml
new file mode 100644
index 000000000000..cc1b465b77de
--- /dev/null
+++ b/games-fps/industri/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<maintainer>
+ <email>vapier@gentoo.org</email>
+ <name>Mike Frysinger</name>
+</maintainer>
+<longdescription>
+industri is a Quake based, single player game using a modified version of the
+Tenebrae 1.x engine. The Tenebrae engine is an Open Source (GNU GPL) modification
+of Quake that brings per-pixel lighting, stencil shadows, hi-res textures,
+bumpmap and normalmaps to the gaming experince.
+
+The focus of industri is a rich single-player game and engine. There is no
+multi-player at all.
+</longdescription>
+</pkgmetadata>