summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-12-05 12:15:59 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-12-05 12:15:59 +0000
commit0cbd5c13bdb955617392aff568c11273a491612f (patch)
tree58e91d6b64e5a22ec8b8314c00fdec1a75aa5f17 /games-fps/duke3d
parentRevision bump, closes bug #72818 (Manifest recommit) (diff)
downloadgentoo-2-0cbd5c13bdb955617392aff568c11273a491612f.tar.gz
gentoo-2-0cbd5c13bdb955617392aff568c11273a491612f.tar.bz2
gentoo-2-0cbd5c13bdb955617392aff568c11273a491612f.zip
fix build with USE=-opengl (bug #73391); tidy
Diffstat (limited to 'games-fps/duke3d')
-rw-r--r--games-fps/duke3d/ChangeLog5
-rw-r--r--games-fps/duke3d/duke3d-20040817.ebuild32
2 files changed, 23 insertions, 14 deletions
diff --git a/games-fps/duke3d/ChangeLog b/games-fps/duke3d/ChangeLog
index 0049a6a131be..330dc20ce44f 100644
--- a/games-fps/duke3d/ChangeLog
+++ b/games-fps/duke3d/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-fps/duke3d
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/duke3d/ChangeLog,v 1.17 2004/08/27 02:45:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/duke3d/ChangeLog,v 1.18 2004/12/05 12:15:59 mr_bones_ Exp $
+
+ 05 Dec 2004; Michael Sterrett <mr_bones_@gentoo.org> duke3d-20040817.ebuild:
+ fix build with USE=-opengl (bug #73391); tidy
26 Aug 2004; Mike Frysinger <vapier@gentoo.org> duke3d-20040817.ebuild
+files/20040817-endian.patch:
diff --git a/games-fps/duke3d/duke3d-20040817.ebuild b/games-fps/duke3d/duke3d-20040817.ebuild
index 525dbe08ba70..8d1e8eb4f6f5 100644
--- a/games-fps/duke3d/duke3d-20040817.ebuild
+++ b/games-fps/duke3d/duke3d-20040817.ebuild
@@ -1,15 +1,16 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/duke3d/duke3d-20040817.ebuild,v 1.3 2004/08/27 02:45:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/duke3d/duke3d-20040817.ebuild,v 1.4 2004/12/05 12:15:59 mr_bones_ Exp $
fromcvs=0
ECVS_MODULE="duke3d"
if [ ${fromcvs} -eq 1 ] ; then
-ECVS_PASS="anonymous"
-ECVS_SERVER="icculus.org:/cvs/cvsroot"
-inherit cvs
+ ECVS_PASS="anonymous"
+ ECVS_SERVER="icculus.org:/cvs/cvsroot"
+ inherit cvs eutils flag-o-matic games
+else
+ inherit eutils flag-o-matic games
fi
-inherit eutils flag-o-matic games
DESCRIPTION="port of the original DukeNukem 3D"
HOMEPAGE="http://icculus.org/projects/duke3d/"
@@ -46,7 +47,7 @@ src_unpack() {
fi
# configure buildengine
- cd ${S}/source/buildengine
+ cd "${S}/source/buildengine"
sed -i \
-e "/^useperl := / s:=.*:= $(use_tf perl):" \
-e "/^useopengl := / s:=.*:= $(use_tf opengl):" \
@@ -55,21 +56,26 @@ src_unpack() {
-e 's:/usr/lib/perl5/i386-linux/CORE/libperl.a::' \
Makefile \
|| die "sed build Makefile failed"
- epatch ${FILESDIR}/${PV}-endian.patch
+ epatch "${FILESDIR}/${PV}-endian.patch"
# configure duke3d
- cd ${S}/source
+ cd "${S}/source"
epatch "${FILESDIR}/${PV}-credits.patch"
- epatch "${FILESDIR}/${PV}-duke3d-makefile-opts.patch" # need to sync features with build engine
+ # need to sync features with build engine
+ epatch "${FILESDIR}/${PV}-duke3d-makefile-opts.patch"
epatch "${FILESDIR}/${PV}-gcc34.patch" # compile fixes for GCC 3.4
sed -i \
- -e "/^useopengl := / s:=.*:= $(use_tf opengl):" \
- -e "/^usephysfs := / s:=.*:= false:" \
+ -e "/^use_opengl := / s:=.*:= $(use_tf opengl):" \
+ -e "/^use_physfs := / s:=.*:= false:" \
Makefile \
|| die "sed duke3d Makefile failed"
if use x86 ; then
- sed -i -e 's:^#USE_ASM:USE_ASM:' buildengine/Makefile
- sed -i -e '/^#use_asm := /s:#::' Makefile
+ sed -i \
+ -e 's:^#USE_ASM:USE_ASM:' buildengine/Makefile \
+ || die "sed failed"
+ sed -i \
+ -e '/^#use_asm := /s:#::' Makefile \
+ || die "sed failed"
fi
# causes crazy redefine errors with gcc-3.[2-4].x