summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-11-15 20:00:33 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-11-15 20:00:33 +0000
commitdfda991c8c8d6fb2827592cfdb6c9e623889b125 (patch)
tree1fce901507b2637e23b7a4af3108c90e516d52e1 /games-fps/doom3-phantasm/doom3-phantasm-1.2.ebuild
parentVersion Bump. Added dbus love to dependencies fixes bug #155280. (diff)
downloadgentoo-2-dfda991c8c8d6fb2827592cfdb6c9e623889b125.tar.gz
gentoo-2-dfda991c8c8d6fb2827592cfdb6c9e623889b125.tar.bz2
gentoo-2-dfda991c8c8d6fb2827592cfdb6c9e623889b125.zip
Initial import. Ebuild by Paul Bredbury <brebs@sent.com>. Closing bug #154152.
(Portage version: 2.1.2_rc1-r6)
Diffstat (limited to 'games-fps/doom3-phantasm/doom3-phantasm-1.2.ebuild')
-rw-r--r--games-fps/doom3-phantasm/doom3-phantasm-1.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/games-fps/doom3-phantasm/doom3-phantasm-1.2.ebuild b/games-fps/doom3-phantasm/doom3-phantasm-1.2.ebuild
new file mode 100644
index 000000000000..805d09d81767
--- /dev/null
+++ b/games-fps/doom3-phantasm/doom3-phantasm-1.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/doom3-phantasm/doom3-phantasm-1.2.ebuild,v 1.1 2006/11/15 20:00:33 wolf31o2 Exp $
+
+MOD_DESC="single-player short mod based on the Phantasm horror movies"
+MOD_NAME="Phantasm"
+MOD_DIR="phantasm"
+MOD_BINS="phantasm"
+
+inherit games games-mods
+
+HOMEPAGE="http://www.freewebs.com/bladeghost_j/
+ http://doom3.filefront.com/file/Phantasm_D3;72040"
+SRC_URI="mirror://filefront/Doom_III/Mods/Addons/phantasm_d3_${PV}.zip
+ ftp://files.mhgaming.com/doom3/mods/phantasm_d3_${PV}.zip"
+
+LICENSE="as-is"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="games-fps/doom3"
+
+S=${WORKDIR}
+
+src_unpack() {
+ games-mods_src_unpack
+ cd "${S}"
+
+ # Remove useless "_d3" from directory name
+ mv "${MOD_DIR}"* "${MOD_DIR}" || die
+
+ # Oh no, a filename containing a space! Gives Portage the heebee-jeebies:
+ # * checking 8 files for package collisions
+ # existing file /usr/share/games/doom3/phantasm/
+ # phantasm_d3_1.2 readme.txt is not owned by this package
+ mv "${MOD_DIR}"/phantasm*.txt "${MOD_DIR}"/README.phantasm.txt || die
+}