summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-02-13 23:10:08 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-02-13 23:10:08 +0000
commit3589e5814bce34465e06696ef0012f50b43fd90b (patch)
tree3f3052677952c78521fee5787f3a4aeb01115dce /games-fps/alephone
parentClean out old version (diff)
downloadgentoo-2-3589e5814bce34465e06696ef0012f50b43fd90b.tar.gz
gentoo-2-3589e5814bce34465e06696ef0012f50b43fd90b.tar.bz2
gentoo-2-3589e5814bce34465e06696ef0012f50b43fd90b.zip
Version bump, bug #159132
(Portage version: 2.1.2-r9)
Diffstat (limited to 'games-fps/alephone')
-rw-r--r--games-fps/alephone/ChangeLog10
-rw-r--r--games-fps/alephone/alephone-20061228.ebuild66
-rw-r--r--games-fps/alephone/files/alephone-20061228-configure.patch38
-rw-r--r--games-fps/alephone/files/alephone.pngbin13265 -> 0 bytes
-rw-r--r--games-fps/alephone/files/digest-alephone-200612283
5 files changed, 115 insertions, 2 deletions
diff --git a/games-fps/alephone/ChangeLog b/games-fps/alephone/ChangeLog
index 2e23a4eb1cfd..6bc6655d3a84 100644
--- a/games-fps/alephone/ChangeLog
+++ b/games-fps/alephone/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-fps/alephone
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/alephone/ChangeLog,v 1.14 2006/10/08 21:29:47 tupone Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/alephone/ChangeLog,v 1.15 2007/02/13 23:10:08 nyhm Exp $
+
+*alephone-20061228 (13 Feb 2007)
+
+ 13 Feb 2007; Tristan Heaven <nyhm@gentoo.org>
+ +files/alephone-20061228-configure.patch, +alephone-20061228.ebuild:
+ Version bump, bug #159132
*alephone-20060701 (08 Oct 2006)
diff --git a/games-fps/alephone/alephone-20061228.ebuild b/games-fps/alephone/alephone-20061228.ebuild
new file mode 100644
index 000000000000..d57ebc13a3e2
--- /dev/null
+++ b/games-fps/alephone/alephone-20061228.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/alephone/alephone-20061228.ebuild,v 1.1 2007/02/13 23:10:08 nyhm Exp $
+
+inherit autotools eutils games
+
+DESCRIPTION="An enhanced version of the game engine from the classic Mac game, Marathon"
+HOMEPAGE="http://source.bungie.org/"
+SRC_URI="mirror://sourceforge/marathon/AlephOne-${PV}-nolibs.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lua opengl speex"
+
+DEPEND="lua? ( dev-lang/lua )
+ opengl? ( virtual/opengl )
+ speex? ( media-libs/speex )
+ dev-libs/boost
+ media-libs/smpeg
+ media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/sdl-sound
+ media-libs/sdl-net"
+
+S=${WORKDIR}/AlephOne-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed "s:GAMES_DATADIR:${GAMES_DATADIR}:g" \
+ "${FILESDIR}"/${PN}.sh > "${T}"/${PN}.sh \
+ || die "sed failed"
+ epatch "${FILESDIR}"/${P}-configure.patch
+ eautoreconf
+}
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable lua) \
+ $(use_enable opengl) \
+ $(use_enable speex) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dogamesbin "${T}"/${PN}.sh || die "dogamesbin failed"
+ dodoc AUTHORS README docs/Cheat_Codes
+ dohtml docs/MML.html
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ elog "Read the docs and install the data files accordingly to play."
+ echo
+ elog "If you only want to install one scenario, read"
+ elog "http://traxus.jjaro.net/traxus/AlephOne:Install_Guide#Single_scenario_3"
+ elog "If you want to install multiple scenarios, read"
+ elog "http://traxus.jjaro.net/traxus/AlephOne:Install_Guide#Multiple_scenarios_3"
+ echo
+}
diff --git a/games-fps/alephone/files/alephone-20061228-configure.patch b/games-fps/alephone/files/alephone-20061228-configure.patch
new file mode 100644
index 000000000000..5d58d039d67b
--- /dev/null
+++ b/games-fps/alephone/files/alephone-20061228-configure.patch
@@ -0,0 +1,38 @@
+--- configure.ac
++++ configure.ac
+@@ -15,6 +15,8 @@
+
+ dnl Configure options.
+ AC_ARG_ENABLE(opengl, [ --enable-opengl use OpenGL for rendering [default=yes]], , enable_opengl=yes)
++AC_ARG_ENABLE(lua, , , enable_lua=yes)
++AC_ARG_ENABLE(speex, , , enable_speex=yes)
+
+ dnl Checks for programs.
+ AC_PROG_CC
+@@ -98,6 +100,7 @@
+ ])
+ ])
+
++if [[ "x$enable_lua" = "xyes" ]]; then
+ dnl Check for Lua.
+ AC_ARG_VAR(LUA_CFLAGS, [C compiler flags for Lua])
+ AC_ARG_VAR(LUA_LIBS, [linker flags for Lua])
+@@ -124,14 +127,17 @@
+ AC_DEFINE(HAVE_LUA_H, 1, [Assuming <lua.h> is present])
+ AC_DEFINE(HAVE_LUALIB_H, 1, [Assuing <lualib.h> is present])
+ fi
++fi
+
++if [[ "x$enable_speex" = "xyes" ]]; then
+ dnl Check for Speex
+-AC_CHECK_HEADERS(speex.h, [
++AC_CHECK_HEADERS(speex/speex.h, [
+ AC_CHECK_LIB(speex, speex_decoder_init, [
+ LIBS="-lspeex $LIBS"
+ AC_DEFINE(SPEEX, 1, [Speex support is enabled])
+ ])
+ ])
++fi
+
+ dnl Figure out which OpenGL library to use
+ case "$target" in
diff --git a/games-fps/alephone/files/alephone.png b/games-fps/alephone/files/alephone.png
deleted file mode 100644
index 1939cca6101e..000000000000
--- a/games-fps/alephone/files/alephone.png
+++ /dev/null
Binary files differ
diff --git a/games-fps/alephone/files/digest-alephone-20061228 b/games-fps/alephone/files/digest-alephone-20061228
new file mode 100644
index 000000000000..0097bfad71ea
--- /dev/null
+++ b/games-fps/alephone/files/digest-alephone-20061228
@@ -0,0 +1,3 @@
+MD5 a46357669c73c9432610489ae9abcd6f AlephOne-20061228-nolibs.tar.bz2 1281295
+RMD160 22d911d20ef6aeda960b137c11d32afb92c34b09 AlephOne-20061228-nolibs.tar.bz2 1281295
+SHA256 2fdf96f97759432ef19f563e467439c6f1dddcd882adf9bfd10356a0a9e2190e AlephOne-20061228-nolibs.tar.bz2 1281295