summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-01-31 05:36:03 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-01-31 05:36:03 +0000
commitd50a78e025dcfb0ba09dc8c81834f61e4dd4c190 (patch)
tree262607c891adea68553a05ec94284a0b7c6a8d95 /games-engines
parentAdded newer version. (diff)
downloadgentoo-2-d50a78e025dcfb0ba09dc8c81834f61e4dd4c190.tar.gz
gentoo-2-d50a78e025dcfb0ba09dc8c81834f61e4dd4c190.tar.bz2
gentoo-2-d50a78e025dcfb0ba09dc8c81834f61e4dd4c190.zip
version bump
(Portage version: 2.0.54)
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/scummvm/ChangeLog10
-rw-r--r--games-engines/scummvm/Manifest3
-rw-r--r--games-engines/scummvm/files/digest-scummvm-0.8.11
-rw-r--r--games-engines/scummvm/files/scummvm-0.8.1-configure.patch8
-rw-r--r--games-engines/scummvm/scummvm-0.8.1.ebuild73
5 files changed, 93 insertions, 2 deletions
diff --git a/games-engines/scummvm/ChangeLog b/games-engines/scummvm/ChangeLog
index 0f6734501af9..8360ba8d4385 100644
--- a/games-engines/scummvm/ChangeLog
+++ b/games-engines/scummvm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-engines/scummvm
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.27 2005/10/31 01:25:52 vapier Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.28 2006/01/31 05:36:03 mr_bones_ Exp $
+
+*scummvm-0.8.1 (31 Jan 2006)
+
+ 31 Jan 2006; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/scummvm-0.8.1-configure.patch, +scummvm-0.8.1.ebuild:
+ version bump
*scummvm-0.8.0 (31 Oct 2005)
diff --git a/games-engines/scummvm/Manifest b/games-engines/scummvm/Manifest
index 874735dd0aae..f373f8fd58c1 100644
--- a/games-engines/scummvm/Manifest
+++ b/games-engines/scummvm/Manifest
@@ -1,5 +1,8 @@
MD5 36b3f0fa634eb72621fd10a51f2e6e33 ChangeLog 5861
MD5 6f31e946479f67ee67ba1f51819f5d60 files/digest-scummvm-0.8.0 67
+MD5 d7b2a434260c0c8a5b4c27bd434423fa files/digest-scummvm-0.8.1 67
MD5 960f5d0a4e84df65775164313f55ef59 files/scummvm-0.8.0-configure.patch 184
+MD5 960f5d0a4e84df65775164313f55ef59 files/scummvm-0.8.1-configure.patch 184
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 0e8df7593839cc383bdcbf7034cae1f4 scummvm-0.8.0.ebuild 1744
+MD5 0e8df7593839cc383bdcbf7034cae1f4 scummvm-0.8.1.ebuild 1744
diff --git a/games-engines/scummvm/files/digest-scummvm-0.8.1 b/games-engines/scummvm/files/digest-scummvm-0.8.1
new file mode 100644
index 000000000000..4570b292b4c0
--- /dev/null
+++ b/games-engines/scummvm/files/digest-scummvm-0.8.1
@@ -0,0 +1 @@
+MD5 4be961bc5a44c712c25f8d3a4932b770 scummvm-0.8.1.tar.bz2 2713782
diff --git a/games-engines/scummvm/files/scummvm-0.8.1-configure.patch b/games-engines/scummvm/files/scummvm-0.8.1-configure.patch
new file mode 100644
index 000000000000..0b955c2b6ab2
--- /dev/null
+++ b/games-engines/scummvm/files/scummvm-0.8.1-configure.patch
@@ -0,0 +1,8 @@
+--- configure
++++ configure
+@@ -433,4 +433,5 @@
+ _backend=`echo $ac_option | cut -d '=' -f 2`
+ ;;
++ --enable-debug);;
+ --disable-debug)
+ DEBFLAGS=""
diff --git a/games-engines/scummvm/scummvm-0.8.1.ebuild b/games-engines/scummvm/scummvm-0.8.1.ebuild
new file mode 100644
index 000000000000..265fd0d69f29
--- /dev/null
+++ b/games-engines/scummvm/scummvm-0.8.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/scummvm-0.8.1.ebuild,v 1.1 2006/01/31 05:36:03 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="Reimplementation of the SCUMM game engine used in Lucasarts adventures"
+HOMEPAGE="http://scummvm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/scummvm/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE="alsa debug flac mp3 ogg vorbis sdl zlib"
+RESTRICT="test" # it only looks like there's a test there #77507
+
+RDEPEND=">=media-libs/libsdl-1.2.2
+ >media-libs/libmpeg2-0.3.1
+ ogg? ( media-libs/libogg media-libs/libvorbis )
+ vorbis? ( media-libs/libogg media-libs/libvorbis )
+ alsa? ( >=media-libs/alsa-lib-0.9 )
+ mp3? ( media-libs/libmad )
+ flac? ( media-libs/flac )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ x86? ( dev-lang/nasm )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-configure.patch
+ if use x86 ; then
+ local f
+ for f in common/scaler/{hq3x_i386.asm,hq2x_i386.asm}
+ do
+ cat >> $f <<EOF
+ %ifidn __OUTPUT_FORMAT__,elf
+ section .note.GNU-stack noalloc noexec nowrite progbits
+ %endif
+EOF
+ done
+ fi
+}
+
+src_compile() {
+ local myconf="--backend=sdl" # x11 backend no worky (bug #83502)
+
+ (use vorbis || use ogg) \
+ && myconf="${myconf} --enable-vorbis" \
+ || myconf="${myconf} --disable-vorbis --disable-mpeg2"
+
+ # NOT AN AUTOCONF SCRIPT SO DONT CALL ECONF
+ # mpeg2 support needs vorbis (bug #79149) so turn it off if -oggvorbis
+ ./configure \
+ $(use_enable debug) \
+ $(use_enable alsa) \
+ $(use_enable mp3 mad) \
+ $(use_enable flac) \
+ $(use_enable zlib) \
+ $(use_enable x86 nasm) \
+ ${myconf} \
+ || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dogamesbin scummvm || die "dobin failed"
+ doman scummvm.6
+ dodoc NEWS README TODO
+ doicon scummvm.xpm
+ make_desktop_entry scummvm ScummVM
+ prepgamesdirs
+}